    
  
  
  
  
  
  
  
  
  



  



  



<!DOCTYPE html>
        <html lang="en">
        <head>
<base href="https://www.meridianstar.com/content/tncms/live/" />
<meta name="keywords" content="bob luke, downtown, commerce, economics, vision, city council, george thomas, fannie johnson, cost, council member" />
<meta name="news_keywords" content="bob luke, downtown, commerce, economics, vision, city council, george thomas, fannie johnson, cost, council member" />
<meta name="description" content="Improved landscaping, better traffic lights, redone roads and more green spaces are part of architect Bob Luke's vision of a revitalized downtown Meridian." />
<meta name="author" content="Ryan&nbsp;Oehrli roehrli@themeridianstar.com" />
<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1, user-scalable=0, shrink-to-fit=no" />
<meta name="apple-mobile-web-app-capable" content="yes" />
<meta name="apple-mobile-web-app-status-bar-style" content="black-translucent" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.meridianstar.com/news/local_news/meridian-master-plan-architect-presents-final-vision-for-downtown-no/article_2627feff-1d89-5259-beb3-36f8996e46da.html" />
<meta property="og:image" content="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/3/be/3bed533d-fe65-50db-9577-497a10fdd542/5d379506c2291.image.jpg?resize=800%2C508" />
<meta property="og:image:width" content="800" />
<meta property="og:image:height" content="508" />
<meta property="og:title" content="Meridian Master Plan: Architect presents final vision for downtown; No estimates on cost, impact" />
<meta property="og:description" content="Improved landscaping, better traffic lights, redone roads and more green spaces are part of architect Bob Luke's vision of a revitalized downtown Meridian." />
<meta property="og:site_name" content="Meridian Star" />
<meta property="og:section" content="Local News" />
<meta property="fb:app_id" content="116012378495089" />
<meta property="article:publisher" content="https://www.facebook.com/meridianstar/" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@meridianstar" />
<meta name="twitter:image:alt" content="Meridian Master Plan: Architect shows city council final vision for downtown; No estimates on cost, impact" />
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/styles/bootstrap.min.8aebbe9627939cd5a7c8e4f6930a23bd.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/shared-content/art/tncms/templates/libraries/flex/components/themes/resources/styles/font-awesome.min.e5604f5bf47d3b8b5552d999180549d2.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/styles/layout.f85bdd8ecb1a515ca678ac2197765d61.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/shared-content/art/tncms/templates/libraries/flex/components/themes/resources/styles/theme-basic.4cce04b95f9b49884d7452d4a02f3f09.css"/>
<!--[if lt IE 9]><link rel="stylesheet" href="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/styles/ie.css"/><![endif]-->
<link rel="stylesheet" href="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/live/global/resources/styles/site.css?_dc=1503084367"/>
<link rel="stylesheet" href="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/styles/owl.carousel.d631cca58a0d014854c4a6c1815f1da3.css"/>
<style>/*<![CDATA[*/ #weather-1562863 .list-unstyled { margin: 0; } #weather-1562863 span { display: block; } #weather-1562863 .forecast-link a { padding: 8px; margin-top: -10px; } #weather-1562863 .icon { position: relative; } #weather-1562863 .icon .tnt-svg { position: relative; font-size: 26px; margin-bottom: -6px; margin-right: 8px; margin-top: -8px; } #weather-1562863 .temp { font-size: 18px; line-height: 20px; font-weight: bold; } #weather-1562863 .cond { opacity: 0.7; } #weather-1562863 .current-conditions { float: left; height: 24px; } #weather-1562863 .dropdown-toggle { color: #49627b; display: block; } #site-top-nav #weather-1562863 .icon { margin-top: 4px; } #site-top-nav #weather-1562863 .temp { line-height: 36px; } #weather-1562863 .current-conditions { height: 36px; padding: 0 10px; } #main-navigation #weather-1562863 .current-conditions { padding-top: 11px; } #weather-1562863 .city-title { padding-top: 5px; } #weather-1562863 .weather-expanded { padding: 0 15px; width: 300px; font-weight: normal; } #weather-1562863 .weather-expanded h5 { border-top: 1px solid rgba(0,0,0,.05); padding-top: 10px; } #weather-1562863 .weather-expanded small { opacity: 0.5; } #weather-1562863 .zip-update-form { width: 140px; margin-top: -54px; background-color: #eee; padding: 5px; position: absolute; display: none; right: 0; } #weather-1562863 .zip-update { width: 75px; } #weather-1562863 .zip-update-link { color: #999; font-size: 18px; text-decoration: none; } #weather-1562863 .zip-update-link:hover { color: #777; } #tncms-block-1562862 .tnt-prop-img { max-width: 958px; } .follow-links-1562861 li { margin-right: 1px; padding: 0; } .follow-links-1562861 li a, .follow-links-1562861 li a:focus, .follow-links-1562861 li a:active { ; height: 36px; width: 36px; font-size: 24px; color: #fff!important; border-radius: 0; opacity: .8; padding:0; box-shadow: none; } .follow-links-1562861 li a:hover { text-decoration: none; opacity: 1; } .follow-links-1562861 li a.fs,.follow-links-1562861 li a.fs:hover { color: #fff; background-color: #1595C7; } #tncms-block-1562865 .tnt-prop-img { max-width: 958px; } #block-1560697 .most-popular .tab-text { display: none; } #block-1560697 .most-popular .active .tab-text { display: inline; } #tncms-block-1562866 .tnt-prop-img { max-width: 958px; } #block-1560669 { color: #000; } /*]]>*/</style>
<script type="text/javascript">(function(){var tnsrc=window.location.hash.match(/[&#]tncms-source=([^&]+)/);var dl = window.dataLayer = window.dataLayer || [];dl.push({"tncms":{"template":{"version":"3.142.0"},"page":{"grid":"pattern","style":"default","path":"\/news\/local_news","syndicated":"false","reaction":"true","app":"editorial","theme":"flex","skin":"flex-editorial","http_status":200},"subscription":{"required":"false"},"asset":{"author":"By\u00a0Ryan\u00a0Oehrli roehrli@themeridianstar.com"},"vendor":{"outbrain":"","taboola":""},"system":{"render_time":231},"client":{"is_bot":"no","is_gdpr":"no"}},"taxonomy_1":"news","taxonomy_2":"local_news","taxonomy_3":null,"taxonomy_4":null,"taxonomy_5":null,"blox_platform":"desktop","blox_page_type":"asset","blox_domain":"meridianstar.com","blox_skin":"flex-editorial","blox_application":"editorial","groups":{"content":"1","advertising":"2","utility":"3"},"content_group":"1","content_group_id":"news","blox_sections":"news,local_news","weather_temp":68,"weather_conditions":"Clear","asset_source":"local","blox_asset_type":"article","asset_section":"news\/local_news","asset_id":"2627feff-1d89-5259-beb3-36f8996e46da","asset_headline":"Meridian Master Plan: Architect presents final vision for downtown; No estimates on cost, impact","asset_byline":"By\u00a0Ryan\u00a0Oehrli roehrli@themeridianstar.com","asset_pub_date":"07\/23\/2019","asset_pub_time":"6:15 pm","asset_canonical":"https:\/\/www.meridianstar.com\/news\/local_news\/meridian-master-plan-architect-presents-final-vision-for-downtown-no\/article_2627feff-1d89-5259-beb3-36f8996e46da.html","asset_tag_1":"bob luke","asset_tag_2":"downtown","asset_tag_3":"commerce","asset_tag_4":"economics","asset_tag_5":"vision","asset_tag_6":"city council","asset_tag_7":"george thomas","asset_tag_8":"fannie johnson","asset_tag_9":"cost","asset_tag_10":"council member","asset_flag_1":"editors_pick","asset_flag_2":"top_story"});if (tnsrc && tnsrc[1]) {dl.push({'tncms.campaign.internal_source': tnsrc[1]});}window.addEventListener("DOMContentLoaded", function(oEvent) {var oTest = document.createElement('div');oTest.innerHTML = '&nbsp;';oTest.className = 'adsbox';document.body.appendChild(oTest);var nTimeoutID = window.setTimeout(function() {if (oTest.offsetHeight === 0) {dl.push({'event': 'tncms.ad.blocked'});}document.body.removeChild(oTest);window.clearTimeout(nTimeoutID);}, 100);});var nWidth=Math.max(document.documentElement.clientWidth, window.innerWidth || 0),aBPs=[[300,"Extra small: Most smartphones."],[768,"Small: Tablet devices."],[992,"Medium: Laptops & landscape tablets."],[1200,"Large: Desktop computers."]],i,c,aThisBP,aBP;for(i=0,c=aBPs.length;i<c;i++){aThisBP=aBPs[i];if(aBP===undefined||aThisBP[0]<=nWidth){aBP=aThisBP;}}if(aBP!==undefined){dl.push({'tncms.client.breakpoint':aBP[1]});}(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'tncms.start':new Date().getTime(),event:'tncms.start'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='https://www.googletagmanager.com/gtm.js?id='+i+dl+ '&gtm_auth=UaWpb3d_PDCaIVzoLRLRYA&gtm_preview=env-2&gtm_cookies_win=x';f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-PDQV3N');})();</script>
<script src="//tags.crwdcntrl.net/c/6893/cc.js?ns=_cc6893" id="LOTCC_6893"></script>
<script>
	if(document.cookie.indexOf('tncms-dmp-id') != -1) {
		_cc6893.add('tp', 'TNNW');
		_cc6893.add('act', ' User Login');
		_cc6893.add('tpid', document.cookie.split( ';' ).map( function( x ) { return x.trim().split( '=' ); } ).reduce(function( a, b ) { a[ b[ 0 ] ] = b[ 1 ]; return a; }, {} )[ "tncms-dmp-id"]);
		document.cookie = 'tncms-dmp-id=;expires=Thu, 01 Jan 1970 00:00:01 GMT';
		localStorage.removeItem('tncms.behaviors');
		localStorage.removeItem('tncms.dmp.audiences');
	}
	_cc6893.add('med', 'flag: editors pick');
	_cc6893.add('med', 'flag: top story');
	_cc6893.bcp();
</script>

<script src="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/shared-content/art/tncms/templates/libraries/flex/components/jquery/resources/scripts/jquery.min.d1a4f9eb1701d7bb8dd985a2ca0981e5.js"></script>
<script src="/shared-content/art/tncms/user/user.js"></script>
<script>/*<![CDATA[*/ TNCMS.User.restorePersistentSession(); /*]]>*/</script>
<script src="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/scripts/bootstrap.min.9ef2deb39dff2c51bd3efbbfc097b065.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/common.2298fa2c06ac9b301ef502070168c6dc.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.9329546da5f585bc9c9c9b7f9d6df105.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/application.cb8ce7db3d97ee68fa83a4ab2b12db43.js"></script>
<script>/*<![CDATA[*/ (function(d,w,s){
        if(w.fetch&&w.Promise&&w.IntersectionObserver&&[].includes&&Object.assign&&w.Map&&w.NodeList)return;
        var sc=d.getElementsByTagName(s)[0],js=d.createElement(s);
        js.src='https://polyfill.io/v3/polyfill.min.js?features=default,fetch,IntersectionObserver,NodeList.prototype.@@iterator';
        sc.parentNode.insertBefore(js, sc);
    }(document,window,'script')) /*]]>*/</script>
<script src="//cdn.livefyre.com/Livefyre.js"></script>
<script src="https://launch.newsinc.com/js/embed.js"></script>
<script async="async" src="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/shared-content/art/tncms/templates/libraries/flex/components/asset/resources/scripts/tnt.reactions.1b889029d49641c5bb4cc840c44ea815.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/shared-content/art/tncms/templates/libraries/flex/components/ads/resources/scripts/tnt.ads.advertisements.66a3812a7b5c12fde8cd998fd691ad7d.js"></script>
<script src="/shared-content/art/tncms/tracking.js"></script>

            
            <title>Meridian Master Plan: Architect presents final vision for downtown; No estimates on cost, impact | Local News | meridianstar.com</title>  
<!-- code here -->  

            
    
    <style>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</style>
    
        <link rel="apple-touch-icon" href="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/custom/image/fd346ea2-8893-11e5-8ab3-a796975542f9.png" />
    
        <link rel="amphtml" href="https://www.meridianstar.com/news/local_news/meridian-master-plan-architect-presents-final-vision-for-downtown-no/article_2627feff-1d89-5259-beb3-36f8996e46da.amp.html" />
    <link rel="alternate" type="application/rss+xml" title="Meridian Master Plan: Architect presents final vision for downtown; No estimates on cost, impact | Local News | meridianstar.com" href="http://www.meridianstar.com/search/?f=rss&amp;t=article&amp;c=news/local_news&amp;l=50&amp;s=start_time&amp;sd=desc" />
        <link rel="canonical" href="https://www.meridianstar.com/news/local_news/meridian-master-plan-architect-presents-final-vision-for-downtown-no/article_2627feff-1d89-5259-beb3-36f8996e46da.html" />
    
            
    <script defer src="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/fontawesome.4a9fdca450d57375be3be7a06b5bc5f0.js"></script>
            <!--Use for site customizations that need to be inserted into the site's header.-->
<meta name="google-site-verification" content="ls7KGAcrGT19QTOEavGLY3ZRp0hRBXRPOdZKPZ0jCJY" />
<script async src='https://tag.simpli.fi/sifitag/d65091c0-4d8b-0136-49c4-067f653fa718'></script><!-- DFP Include -->
<!-- dfp-update -->
<!-- [1] Load DFP as normal. -->
<script type='text/javascript'>
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
(function() {
var gads = document.createElement('script');
gads.async = true;
gads.type = 'text/javascript';
var useSSL = 'https:' == document.location.protocol;
gads.src = (useSSL ? 'https:' : 'http:') + 
'//www.googletagservices.com/tag/js/gpt.js';
var node = document.getElementsByTagName('script')[0];
node.parentNode.insertBefore(gads, node);
})();
</script>

<!-- [2] include the AdBridg library. -->
<script type='text/javascript'>
  var AdBridg = AdBridg || {};
  AdBridg.cmd = AdBridg.cmd || [];
  (function() {
      var adb = document.createElement("script");
      adb.async = true;
      adb.type = "text/javascript";
      adb.src = '//prod.adspsp.com/adb.1710310.min.js';
      var node = document.getElementsByTagName('script')[0];
      node.parentNode.insertBefore(adb, node);

      adb.onerror = function() {
          if (AdBridg.exists) { return; }
          document.createElement('IMG').src = '//adspsp.com/pt/1710310/3/1/?e=0';
          var dq = [], es;
          dq.process = function() { while(dq.length) { googletag.display(dq.shift()); }}
          AdBridg.defineSlot = function(p, s, d) { return googletag.defineSlot(p, s, d).addService(googletag.pubads()); }
          AdBridg.display = function(d) { dq.push(d); if (es) { dq.process(); }}
          AdBridg.refresh = function(s, o) { googletag.pubads().refresh(s, o); }
          AdBridg.render = function() { }
          AdBridg.serve = function() { googletag.enableServices(); es=1; dq.process(); }
          AdBridg.sizeMapping = function() { return googletag.sizeMapping(); }
          AdBridg.useSizeMapping = function() { }
          AdBridg.defineOutOfPageSlot = function(p, d) { return googletag.defineOutOfPageSlot(p, d).addService(googletag.pubads()); }
          while (AdBridg.cmd.length) { googletag.cmd.push(AdBridg.cmd.shift()); }
          AdBridg.cmd = googletag.cmd;
      }
  })();
</script>


<!-- [3] Define ad slots, replacing GPT with AdBridg's wrapper API. -->
<script type='text/javascript'>
AdBridg.cmd.push(function() {
var wwidth = $(window).width();
AdBridg.defineSlot('/9869277/cnhi/meridianstar/totalaudience', [300, 250], 'mediumRectangle_btf2_flex').addService(googletag.pubads()).setTargeting("pos", "btf2");
if (wwidth >= 992){
AdBridg.defineSlot('/9869277/cnhi/meridianstar/richmedia', [[950, 250],[950, 45]], 'billboard').addService(googletag.pubads());
AdBridg.defineSlot('/9869277/cnhi/meridianstar/weatherhousead', [120, 60], 'weather_atf').addService(googletag.pubads()).setTargeting("pos", "atf");
AdBridg.defineSlot('/9869277/cnhi/meridianstar/totalaudience', [728, 90], 'leaderboard_atf').addService(googletag.pubads()).setTargeting("pos", "atf");
AdBridg.defineSlot('/9869277/cnhi/meridianstar/totalaudience', [300, 250], 'mediumRectangle_btf1').addService(googletag.pubads()).setTargeting("pos", "btf1");
AdBridg.defineSlot('/9869277/cnhi/meridianstar/totalaudience', [[300, 250], [300,600]], 'mediumRectangle_atf').addService(googletag.pubads()).setTargeting("pos", "atf");
AdBridg.defineSlot('/9869277/cnhi/meridianstar/weatherhousead', [120, 60], 'button_btf1').addService(googletag.pubads()).setTargeting("pos", "btf1");
AdBridg.defineSlot('/9869277/cnhi/meridianstar/weatherhousead', [120, 60], 'button_btf2').addService(googletag.pubads()).setTargeting("pos", "btf2");
AdBridg.defineSlot('/9869277/cnhi/meridianstar/totalaudience', [[728, 90], [970, 250]], 'leaderboard_mid').addService(googletag.pubads()).setTargeting("pos", "btf2");
AdBridg.defineSlot('/9869277/cnhi/meridianstar/totalaudience', [[300, 250], [300,600]], 'mediumRectangle_btf3_flex').addService(googletag.pubads()).setTargeting("pos", "btf3");
AdBridg.defineSlot('/9869277/cnhi/meridianstar/totalaudience', [[728, 90], [970, 250]], 'leaderboard_btf').addService(googletag.pubads()).setTargeting("pos", "btf");
AdBridg.defineSlot('/9869277/cnhi/meridianstar/richmedia', [[728, 90], [970, 90]], 'floorboard').addService(googletag.pubads());
AdBridg.defineSlot('/9869277/cnhi/meridianstar/wallpaper', [1, 1], 'div-gpt-ad-1409848272015-0').addService(googletag.pubads());
AdBridg.defineOutOfPageSlot('/9869277/cnhi/meridianstar/wallpaper', 'div-gpt-ad-1409848272015-0-oop').addService(googletag.pubads());
} 
if (wwidth < 992){
AdBridg.defineSlot('/9869277/cnhi/meridianstar/totalaudience', [[320,50],[300, 50]], 'mobileBanner_atf_flex').addService(googletag.pubads()).setTargeting("pos", "atf");
AdBridg.defineSlot('/9869277/cnhi/meridianstar/totalaudience', [300, 250], 'mobileBanner_under_headlines').addService(googletag.pubads()).setTargeting("pos", "mob1");
AdBridg.defineSlot('/9869277/cnhi/meridianstar/totalaudience', [300, 250], 'mobileRectangle_atf').addService(googletag.pubads()).setTargeting("pos", "atf");
AdBridg.defineSlot('/9869277/cnhi/meridianstar/totalaudience', [[320,50],[300, 50]], 'mobileBanner_news_video').addService(googletag.pubads()).setTargeting("pos", "mob2");
AdBridg.defineSlot('/9869277/cnhi/meridianstar/totalaudience', [300, 250], 'mobileBanner_obits_pop').addService(googletag.pubads()).setTargeting("pos", "mob3");
AdBridg.defineSlot('/9869277/cnhi/meridianstar/totalaudience', [[320,50],[300, 50]], 'mobileBanner_under_sports').addService(googletag.pubads()).setTargeting("pos", "mob4");
AdBridg.defineSlot('/9869277/cnhi/meridianstar/totalaudience', [300, 250], 'mobileBanner_national').addService(googletag.pubads()).setTargeting("pos", "mob5");
AdBridg.defineSlot('/9869277/cnhi/meridianstar/totalaudience', [300, 250], 'mobileBanner_article_monster').addService(googletag.pubads()).setTargeting("pos", "mob6");
AdBridg.defineSlot('/9869277/cnhi/meridianstar/totalaudience', [[320,50],[300, 50]], 'mobileBanner_btf_flex').addService(googletag.pubads()).setTargeting("pos", "btf");
}

googletag.pubads().setTargeting('section','news/local_news');
googletag.pubads().enableSingleRequest();
googletag.pubads().collapseEmptyDivs();

// Start requesting the ads.
        AdBridg.serve();
});
</script>

<script type="text/javascript" src="https://meridianstar-cnhi-pw.newsmemory.com?meter&v=3&amp;service=onstop" async></script>

<style>
#leaderboard_atf{padding-top:10px}
.what-counts{background-color:#1c62b1;text-align:center;margin-top:10px;text-align:center;width:320px;margin-left:auto;margin-right:auto}
.what-counts-small{width:320px;margin-left:auto;margin-right:auto}
.janrainSocialRoot button.janrainProvider{width:32px;height:32px}
.cnhi-div-center{text-align:center;margin-left:auto;margin-right:auto}
.cnhi-tout{width:350px;margin-left:auto;margin-right:auto}
.cnhi-smugmug{width:350px;margin-left:auto;margin-right:auto}
.rounded-corners-fns{width:350px;margin-left:auto!important;margin-right:auto!important;text-align:center}
#omt-rounded-corners{background-color:#4C98CD}
#rounded-corners-red{background-color:#C00;background-position:left bottom;background-repeat:repeat-x;color:#555;font-size:150%;font-weight:700;text-align:justify;-moz-border-radius:10px;-webkit-border-radius:10px;border-radius:10px;padding:10px}
.rounded-corners-red{background-color:#C00;width:100%;margin:0 0 10px}
.yamm .dropdown.yamm-fw.span-class-fa-fa-home-span .dropdown-menu{left:auto;right:auto}
.yamm .dropdown.yamm-fw.span-class-fa-fa-home-span .dropdown-menu .yamm-content .col-sm-2{width:100%}
.yamm .dropdown.yamm-fw.span-class-fa-fa-home-span .dropdown-menu .yamm-content .col-sm-5{display:none}
</style>



<!-- Livefyre -->
<script>
Livefyre.require(["identity#1", "auth"],
    function (Identity, auth) {
        var identity = new Identity({
            app: "https://identity.livefyre.com/cnhi.fyre.co"
        });
        auth.delegate(identity);
    }
);
</script>

<!--  Nativo JS Here-->
<script type="text/javascript" src="//s.ntv.io/serve/load.js" async></script>

<!--  End Nativo JS Here-->
        </head>
        <body class="fixed-scroll-nav  blox-asset app-editorial uuid-2627feff-1d89-5259-beb3-36f8996e46da  section-news section-local-news type-article infinity-disabled">
	<script type='text/javascript' src='/shared-content/art/stats/common/tracker.js'></script>
	<script type='text/javascript'>
	<!--
	if (typeof(TNStats_Tracker) !== 'undefined' && typeof(TNTracker) === 'undefined') { TNTracker = new TNStats_Tracker('www.meridianstar.com'); TNTracker.trackPageView(); }
	// -->
	</script>
	<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-PDQV3N&tncms.template.version=3.142.0&tncms.page.grid=pattern&tncms.page.style=default&tncms.page.path=%2Fnews%2Flocal_news&tncms.page.syndicated=false&tncms.page.reaction=true&tncms.page.app=editorial&tncms.page.theme=flex&tncms.page.skin=flex-editorial&tncms.page.http_status=200&tncms.subscription.required=false&tncms.asset.author=By%C2%A0Ryan%C2%A0Oehrli+roehrli%40themeridianstar.com&tncms.vendor.outbrain=&tncms.vendor.taboola=&tncms.system.render_time=231&tncms.client.is_bot=no&tncms.client.is_gdpr=no&taxonomy_1=news&taxonomy_2=local_news&blox_platform=desktop&blox_page_type=asset&blox_domain=meridianstar.com&blox_skin=flex-editorial&blox_application=editorial&groups.content=1&groups.advertising=2&groups.utility=3&content_group=1&content_group_id=news&blox_sections=news%2Clocal_news&weather_temp=68&weather_conditions=Clear&asset_source=local&blox_asset_type=article&asset_section=news%2Flocal_news&asset_id=2627feff-1d89-5259-beb3-36f8996e46da&asset_headline=Meridian+Master+Plan%3A+Architect+presents+final+vision+for+downtown%3B+No+estimates+on+cost%2C+impact&asset_byline=By%C2%A0Ryan%C2%A0Oehrli+roehrli%40themeridianstar.com&asset_pub_date=07%2F23%2F2019&asset_pub_time=6%3A15+pm&asset_canonical=https%3A%2F%2Fwww.meridianstar.com%2Fnews%2Flocal_news%2Fmeridian-master-plan-architect-presents-final-vision-for-downtown-no%2Farticle_2627feff-1d89-5259-beb3-36f8996e46da.html&asset_tag_1=bob+luke&asset_tag_2=downtown&asset_tag_3=commerce&asset_tag_4=economics&asset_tag_5=vision&asset_tag_6=city+council&asset_tag_7=george+thomas&asset_tag_8=fannie+johnson&asset_tag_9=cost&asset_tag_10=council+member&asset_flag_1=editors_pick&asset_flag_2=top_story&tncms.client.noscript=yes" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript><div id="fb-root"></div>
        
        
        <!-- Google Tag Manager -->
        <script>
            var dataLayer = window.dataLayer || [];
            dataLayer.push(
                {'user_id': __tnt.user.screenName},
                {'user_state': __tnt.user.loggedIn ? 'logged in' : 'anonymous'},
                {'utm_label': __tnt.urlHash('utm_label')}
            );
        </script>
        <noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-52VL4R" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
        <script>
            (function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
            new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
            j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
            '//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
            })(window,document,'script','dataLayer','GTM-52VL4R');
        </script>
        <script>
            $(function(){
                var bloxServiceIDs = [];
                var bloxUserServiceIds = [];
                var dataLayer = window.dataLayer || [];

                

                if (__tnt.user.services){
                    var bloxUserServiceIDs = __tnt.user.services.replace('%2C',',').split(',');
                }

                // GTM tncms.subscription.paid_access_service_ids
                if(bloxServiceIDs){
                    dataLayer.push({'tncms':{'subscription':{'access_service_ids':bloxServiceIDs.toString()}}});
                }

                // GTM tncms.subscrption.user_service_ids
                if(bloxUserServiceIDs){
                    dataLayer.push({'tncms':{'subscription':{'user_service_ids':bloxUserServiceIDs.toString()}}});
                }
            });
        </script>
        
        <div id="site-container"><div id="asset-edit-container-2627feff-1d89-5259-beb3-36f8996e46da" class="asset-owner-content asset-edit-container progress hidden-print">
            <div class="progress-bar progress-bar-primary progress-bar-striped">
                <div class="asset-edit-icon pull-left hidden-sm hidden-xs"><i class="fas tnt-certificate"></i></div>
                <div class="asset-edit-message pull-left">You are the owner of this article.</div>
                <div class="asset-edit-btns pull-right">
                    <a class="btn btn-primary" href="https://www.meridianstar.com/users/admin/contribute/article/?assetid=2627feff-1d89-5259-beb3-36f8996e46da&assettype=article"><i class="fas tnt-pen-square"></i> Edit Article</a>
                    
                        <a class="btn btn-danger" href="https://www.meridianstar.com/users/admin/contribute/article/?from_section=/news/local_news"><i class="fas tnt-plus-square"></i> Add New Article</a>
                    
                </div>
                <div class="clearfix"></div>
            </div>
        </div><script>
        var oAuthors = [];jQuery(document).ready(function($){
            if( __tnt.user.loggedIn && jQuery.inArray(__tnt.user.screenName, oAuthors) !==-1 ){
                __tnt.isAuthor = true;
                $('.asset-owner-content').show();
            }
        });
    </script>

    
        
            <aside class="hidden-print offcanvas-drawer offcanvas-drawer-left ">
                <div id="tncms-region-mobile-nav-top-left-region" class="tncms-region "></div>
                <div id="tncms-region-nav-mobile-nav-left" class="tncms-region-nav"><div id="mobile-nav-left_menu" class="panel-group nav navbar-nav" role="tablist"><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="javascript:var onclick=ta_account();" id="ta_account_button"  class="nav-link tnt-section-login">Login</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="/"  class="nav-link tnt-section-span-class-fas-tnt-home-span"><span class="fas tnt-home"></span></a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-3" data-target="#mobile-nav-left_menu-child-3">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/news/"  class="nav-link tnt-section-news">News</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-3" class="collapse nav navbar-nav"><li>
                                    <a href="/news/local_news/"  class="nav-link tnt-section-local-news">Local News</a>
                                </li><li>
                                    <a href="/news/business/"  class="nav-link tnt-section-business">Business</a>
                                </li><li>
                                    <a href="/news/lifestyles/"  class="nav-link tnt-section-lifestyles">Lifestyles</a>
                                </li><li>
                                    <a href="/news/state_news/"  class="nav-link tnt-section-state-news">State News</a>
                                </li><li>
                                    <a href="/news/nation_and_world/"  class="nav-link tnt-section-nation-world">Nation & World</a>
                                </li><li>
                                    <a href="/news/max/"  class="nav-link tnt-section-max">MAX</a>
                                </li><li>
                                    <a href="/multimedia"  class="nav-link tnt-section-video">Video</a>
                                </li><li>
                                    <a href="https://meridianstar.com/bestof"  target="_blank" rel="noopener" class="nav-link tnt-section-readers-choice-contest">Readers Choice Contest</a>
                                </li><li>
                                    <a href="/homestyle/"  class="nav-link tnt-section-home-style-magazine">Home & Style Magazine</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="/multimedia/photos/"  class="nav-link tnt-section-photo-galleries">Photo Galleries</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-5" data-target="#mobile-nav-left_menu-child-5">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/sports/"  class="nav-link tnt-section-sports">Sports</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-5" class="collapse nav navbar-nav"><li>
                                    <a href="/sports/local_sports/"  class="nav-link tnt-section-local-sports">Local Sports</a>
                                </li><li>
                                    <a href="/sports/national_sports/"  class="nav-link tnt-section-national-sports">National Sports</a>
                                </li><li>
                                    <a href="/sports/state_sports/"  class="nav-link tnt-section-state-sports">State Sports</a>
                                </li><li>
                                    <a href="/sports/outdoors/"  class="nav-link tnt-section-outdoors">Outdoors</a>
                                </li><li>
                                    <a href="/sports/premierpreps/"  class="nav-link tnt-section-premier-preps">Premier Preps</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-6" data-target="#mobile-nav-left_menu-child-6">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/opinion/"  class="nav-link tnt-section-opinion">Opinion</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-6" class="collapse nav navbar-nav"><li>
                                    <a href="/opinion/columns/"  class="nav-link tnt-section-columns">Columns</a>
                                </li><li>
                                    <a href="/opinion/editorials/"  class="nav-link tnt-section-editorials">Editorials</a>
                                </li><li>
                                    <a href="/opinion/letters_to_the_editor/"  class="nav-link tnt-section-letters-to-the-editor">Letters to the Editor</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-7" data-target="#mobile-nav-left_menu-child-7">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/community/"  class="nav-link tnt-section-community">Community</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-7" class="collapse nav navbar-nav"><li>
                                    <a href="/community/anniversary/"  class="nav-link tnt-section-anniversary">Anniversary</a>
                                </li><li>
                                    <a href="/community/engagements"  class="nav-link tnt-section-engagements">Engagements</a>
                                </li><li>
                                    <a href="/community/weddings"  class="nav-link tnt-section-weddings">Weddings</a>
                                </li><li>
                                    <a href="http://www.meridianstar.com/community/births/"  target="_blank" rel="noopener" class="nav-link tnt-section-births">Births</a>
                                </li><li>
                                    <a href="/community/celebrations/"  class="nav-link tnt-section-celebrations">Celebrations</a>
                                </li><li>
                                    <a href="/multimedia/photos/"  class="nav-link tnt-section-photos">Photos</a>
                                </li><li>
                                    <a href="/community/religion/"  class="nav-link tnt-section-religion">Religion</a>
                                </li><li>
                                    <a href="/community/education/"  class="nav-link tnt-section-education">Education</a>
                                </li><li>
                                    <a href="/homestyle/"  class="nav-link tnt-section-meridian-home-style">Meridian Home & Style</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="http://celebrations.meridianstar.com/"  target="_blank" rel="noopener" class="nav-link tnt-section-celebrations">Celebrations</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="/obituaries"  class="nav-link tnt-section-obituaries">Obituaries</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-10" data-target="#mobile-nav-left_menu-child-10">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/classifieds"  class="nav-link tnt-section-classifieds">Classifieds</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-10" class="collapse nav navbar-nav"><li>
                                    <a href="/monster"  class="nav-link tnt-section-jobs">Jobs</a>
                                </li><li>
                                    <a href="Autos"  class="nav-link tnt-section-autos">Autos</a>
                                </li><li>
                                    <a href="/homes"  class="nav-link tnt-section-homes">Homes</a>
                                </li><li>
                                    <a href="/placeanad"  class="nav-link tnt-section-place-an-ad">Place An Ad</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="/e-edition"  class="nav-link tnt-section-e-paper">E-Paper</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="/app-downloads"  class="nav-link tnt-section-app">App</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="http://notices.meridianstar.com/"  target="_blank" rel="noopener" class="nav-link tnt-section-public-notices">Public Notices</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-14" data-target="#mobile-nav-left_menu-child-14">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/site/contact-us.html"  class="nav-link tnt-section-contact-us">Contact Us</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-14" class="collapse nav navbar-nav"><li>
                                    <a href="http://photos.meridianstar.com/"  target="_blank" rel="noopener" class="nav-link tnt-section-purchase-photos">Purchase Photos</a>
                                </li><li>
                                    <a href="/site/forms/online_services/letter/"  class="nav-link tnt-section-submit-a-letter-to-the-editor">Submit a Letter to the Editor</a>
                                </li><li>
                                    <a href="/site/forms/online_services/submit_news/"  class="nav-link tnt-section-submit-a-news-tip">Submit a News Tip</a>
                                </li><li>
                                    <a href="http://obituaries.meridianstar.com/select-notice-type"  target="_blank" rel="noopener" class="nav-link tnt-section-place-an-obituary">Place an Obituary</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-15" data-target="#mobile-nav-left_menu-child-15">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/subscriptions"  class="nav-link tnt-section-subscribe">Subscribe</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-15" class="collapse nav navbar-nav"><li>
                                    <a href="/subscriptions"  class="nav-link tnt-section-start-a-subscription">Start a Subscription</a>
                                </li><li>
                                    <a href="/subscriber-services"  class="nav-link tnt-section-manage-my-subscription">Manage My Subscription</a>
                                </li><li>
                                    <a href="/e-edition"  class="nav-link tnt-section-e-paper">E-Paper</a>
                                </li><li>
                                    <a href="/app-downloads"  class="nav-link tnt-section-app-downloads">App Downloads</a>
                                </li><li>
                                    <a href="https://visitor.r20.constantcontact.com/d.jsp?llr=99oml49ab&amp;p=oi&amp;m=1128481045338&amp;sit=s5fwgcwlb&amp;f=e95c0a03-8db9-4d2a-98d3-7dffa92feef5"  target="_blank" rel="noopener" class="nav-link tnt-section-newsletter">Newsletter</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-16" data-target="#mobile-nav-left_menu-child-16">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a   class="nav-link tnt-section-shop">Shop</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-16" class="collapse nav navbar-nav"><li>
                                    <a href="/coupondeals"  class="nav-link tnt-section-coupons">Coupons</a>
                                </li><li>
                                    <a href="/weeklyads"  class="nav-link tnt-section-weekly-ads">Weekly Ads</a>
                                </li><li>
                                    <a href="http://newspaperads.meridianstar.com/"  target="_blank" rel="noopener" class="nav-link tnt-section-newspaper-ads">Newspaper Ads</a>
                                </li></ul></div></div></div>
                
                
                <div id="tncms-region-mobile-nav-bottom-left-region" class="tncms-region "></div>
            </aside>
        
        

        <div class="offcanvas-inner">
            <div class="offcanvas-close-btn"></div>
    

    
    

    
        <div id="site-top-nav-container" class="hidden-sm hidden-xs hidden-print">
            <header id="site-top-nav" class="container">
                <div class="row">
                    <div id="topbar-col-one" class="col-md-6 col-sm-6"><div id="tncms-region-topbar-col-one" class="tncms-region "><div id="tncms-block-1562837" class="tncms-block hidden-xs"><!-- DFP Billboard Ad Update-->

<div id='billboard'  class="hidden-xs hidden-sm" style="width:100%; position: relative; top:0px; text-align:center !important;">
<script type='text/javascript'>
AdBridg.cmd.push(function() { AdBridg.display('billboard'); });
</script>
</div>
</div></div></div>
    <div id="topbar-col-two" class="col-md-6 col-sm-6"><div id="tncms-region-topbar-col-two" class="tncms-region "></div></div>
                </div>
            </header>
        </div>
    

    
        <div id="site-header-container" class="hidden-sm hidden-xs hidden-print">
            <header id="site-header" class="container" role="banner">
                <!-- tecnavia no esc -->

<script type="text/javascript">
document.onkeydown = function (e) {             
        var e = e || window.event;         
        var keyCode = (e.which) ? e.which : e.keyCode;                                                        
     if(keyCode == 27){
                alert("ESC key not allowed!");
                return false;                                   
        }
}                                                     
</script>



<script type="text/javascript" src="https://meridianstar-cnhi-pw.newsmemory.com?meter&v=3" async></script>

                <div class="row">
                    <div id="masthead-full-top" class="col-lg-12"><div id="tncms-region-masthead-full-top" class="tncms-region "><div id="tncms-block-1562854" class="tncms-block cnhionline-breaking-news-block"></div><div id="tncms-block-1614796" class="tncms-block"><div style="width:100%;height:15px"></div></div></div></div>
                </div>
                <div class="row">
                    
                    <div id="masthead-col-one" class="col-md-4 col-sm-4"><div id="tncms-region-masthead-col-one" class="tncms-region "><div id="tncms-block-1562863" class="tncms-block cnhi-weather-widget"><div id="weather-1562863" class="weather-current size-small pull-left">
    <ul class="list-unstyled">
        <li class="current-conditions dropdown">
            <a href="/weather/?weather_zip=39302" class="dropdown-toggle" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250">
                <span class="icon pull-left">
                    
                    <span class="fas tnt-wi-night-clear"></span>
                </span>
                <span class="pull-left temp-desc small">
                    <span class="temp">68&deg;</span>
                    
                </span>
                <span class="clearfix"></span>
            </a>
            
                <ul class="dropdown-menu" role="menu">
                    <li>
                        <div class="weather-expanded">
                            <form action="/weather/" class="zip-update-form form-inline" method="get">
                                <input type="text" class="zip-update form-control" name="weather_zip" title="Weather ZIP Code" value="39302"> <input class="btn btn-primary" type="submit" value="GO">
                            </form>

                            <a href="javascript:;" class="pull-right zip-update-link" aria-label="weather_zip_toggle" onclick="jQuery('#weather-1562863 .zip-update-form').toggle('fast'); return false;"><span class="fas tnt-cog"></span></a>

                            <h4 class="city-title"><i class="fas tnt-map-marker-alt"></i>
                                
                                    Meridian, MS
                                
                                 <small>(39302)</small>
                            </h4>
                            <h5>Today</h5>
                            <p>A mainly sunny sky. Less humid. High 87F. Winds NNE at 10 to 15 mph..</p>
                            <h5>Tonight</h5>
                            <p>A mostly clear sky. Low 64F. Winds NNE at 5 to 10 mph.</p>
                            <p class="text-center"><small><i class="fas tnt-info-circle"></i> Updated: July 24, 2019 @ 12:58 am</small></p>
                        </div>
                    </li>
                    <li role="presentation" class="divider"></li>
                    <li class="forecast-link text-center"><a href="/weather/?weather_zip=39302"><i class="fas tnt-caret-right"></i> Full Forecast</a></li>
                </ul>
            
        </li>
    </ul>
</div>

    <div class="clearfix"></div>
</div><div id="tncms-block-1562844" class="tncms-block"><!-- weather button atf-->
<div id='weather_atf'>
<script type='text/javascript'>
AdBridg.cmd.push(function() { AdBridg.display('weather_atf'); });
</script>
</div></div></div></div>
    <div id="masthead-col-two" class="col-md-4 col-sm-4"><div id="tncms-region-masthead-col-two" class="tncms-region "><div id="tncms-block-1562862" class="tncms-block a"><section id="block-1562862" class="block emphasis-h3   " ><div class="block"><a href="/" rel="nofollow" ><img 
            
            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
            data-srcset="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/custom/image/7b4f5514-4984-11e8-9199-eb94560e071b.png?resize=200%2C32 200w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/custom/image/7b4f5514-4984-11e8-9199-eb94560e071b.png?resize=300%2C49 300w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/custom/image/7b4f5514-4984-11e8-9199-eb94560e071b.png?resize=400%2C65 400w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/custom/image/7b4f5514-4984-11e8-9199-eb94560e071b.png?resize=540%2C87 540w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/custom/image/7b4f5514-4984-11e8-9199-eb94560e071b.png?resize=750%2C121 750w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/custom/image/7b4f5514-4984-11e8-9199-eb94560e071b.png 1200w" 
            data-sizes="auto" 
            class=" img-responsive lazyload tnt-prop-img"
            alt=""></a></div></section></div><div id="tncms-block-1562848" class="tncms-block"><p style="color:grey;font-size:12px;text-align:center">Your Star, Your World</p></div></div></div>
    <div id="masthead-col-three" class="col-md-4 col-sm-4"><div id="tncms-region-masthead-col-three" class="tncms-region "><div id="tncms-block-1562861" class="tncms-block"><div class="follow-links-1562861 pull-right">
    
    <section id="block-1562861" class="block emphasis-h3   " ><ul class="list-inline">
    
            <li>
                <a href="https://visitor.r20.constantcontact.com/d.jsp?llr=99oml49ab&p=oi&m=1128481045338&sit=s5fwgcwlb&f=e95c0a03-8db9-4d2a-98d3-7dffa92feef5" title="newsletter" target="_blank" class="btn btn-md btn-link fs">
                    <i class="fas tnt-envelope"></i>
                    <span class="sr-only">Newsletter</span>
                </a>
            </li>
        
        
        
        
        
        
        
        
        
        
        
    </ul>
    </section>
</div>
<script type="application/ld+json">
{ "@context" : "http://schema.org",
  "@type" : "Organization",
  "url" : "http://www.meridianstar.com",
  "sameAs" : ["https://visitor.r20.constantcontact.com/d.jsp?llr=99oml49ab&p=oi&m=1128481045338&sit=s5fwgcwlb&f=e95c0a03-8db9-4d2a-98d3-7dffa92feef5"] 
}
</script>
<div class="clearfix"></div>
    <script>
        jQuery(document).ready(function(){
            $('.follow-links-1562861 li a').tooltip({
                placement:'bottom'
            });
        });
    </script>
</div><div id="tncms-block-1562860" class="tncms-block cnhi-search"><section id="block-1562860" class="block emphasis-h3   " >
    <div class="clearfix"></div>
    <div id="search-form-1562860" class="search-form-container card clearfix text-center ">
    <form id="site-search-1562860" action="/search/" method="GET" >
    <input type="hidden" name="l" value="25">
    <input type="hidden" name="sd" value="desc">
    <input type="hidden" name="s" value="start_time">
    <input type="hidden" name="f" value="html">
    <input type="hidden" name="app" value="editorial">
    <div class="site-search-form input-group pull-right normal form-control">
        <input id="site-search-1562860-term" name="q" type="text" placeholder="Search..." class="form-control" autocomplete="off">
        <input type="submit" class="hide" value="Search">
        <span class="input-group-btn">
            <button id="site-search-1562860-btn" class="btn btn-link" type="submit">
                
            </button>
        </span>
    </div>
    <input type="hidden" name="nsa" value="eedition">
    <div class="clearfix"></div>
</form>
        
        
        <div class="clearfix"></div>
    </div>
    </section><style>
    #site-search-1562860 .search-spinner { position: absolute; }
    #site-search-1562860 .input-group-btn:last-child>.btn, .input-group-btn:last-child>.btn-group {margin-left: 0;}#search-form-1562860 { margin-bottom:0; }
        #site-search-1562860 .site-search-form { padding:0; }
        #site-search-1562860 #site-search-1562860-btn {
            outline: none;}
        #site-search-1562860 #site-search-1562860-term { border:0; box-shadow: none; }
    
    

    
</style> 

<script>
    $('#site-search-1562860-btn').on(__tnt.client.clickEvent, function(){
        $('#site-search-1562860').submit();
        return false;
    });

    $('#site-search-1562860').on('submit', function(){
        if( $('#site-search-1562860-term').val() ){
            $('#site-search-1562860-btn .fa').removeClass('fa-search').addClass('fa-spinner fa-spin');
            return true;
        }else{
            return false;
        }
    });</script></div></div></div>
                </div>
                <div class="row">
                    <div id="masthead-full-bottom" class="col-lg-12"><div id="tncms-region-masthead-full-bottom" class="tncms-region "><div id="tncms-block-1562869" class="tncms-block hidden-xs">

<!-- leaderboard mid -->
<div class="clear" style="padding-top:10px"></div>
        <div id='leaderboard_mid' style="width:100%;text-align:center">
        <script type='text/javascript'>
        AdBridg.cmd.push(function() { AdBridg.display('leaderboard_mid'); });
        </script>
        </div>
<div class="clear" style="padding-bottom:10px"></div>

</div></div></div>
                </div>
                
            </header>
        </div>
    

    
        <div id="site-navbar-container" class="hidden-print affix-top">
            
            <nav id="main-navigation" class="navbar yamm navbar-default container navbar-static">
                
                <div class="navbar-header">
                    
                    
                        <button type="button" class=" hamburger-desktop  navbar-toggle pull-left" data-toggle="offcanvas" data-target="left">
                            <span class="sr-only">Toggle navigation</span>
                            <span class="icon-bar"></span>
                            <span class="icon-bar"></span>
                            <span class="icon-bar"></span>
                            <span class="visible-lg visible-md sr-only-show">Menu</span>
                        </button>
                    
                    

                    
                        <div class="navbar-brand hidden-md hidden-lg pos_left_menu_right_search">
                            
                                <div id="tncms-region-main-nav-brand" class="tncms-region "><div id="tncms-block-1562865" class="tncms-block"><section id="block-1562865" class="block emphasis-h3   " ><div class="block"><a href="/" rel="nofollow" ><img 
            
            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
            data-srcset="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/custom/image/8a5ebc34-4984-11e8-90b1-c74aa99c9885.png?resize=200%2C32 200w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/custom/image/8a5ebc34-4984-11e8-90b1-c74aa99c9885.png?resize=300%2C49 300w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/custom/image/8a5ebc34-4984-11e8-90b1-c74aa99c9885.png?resize=400%2C65 400w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/custom/image/8a5ebc34-4984-11e8-90b1-c74aa99c9885.png?resize=540%2C87 540w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/custom/image/8a5ebc34-4984-11e8-90b1-c74aa99c9885.png?resize=750%2C121 750w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/custom/image/8a5ebc34-4984-11e8-90b1-c74aa99c9885.png 1200w" 
            data-sizes="auto" 
            class=" img-responsive lazyload tnt-prop-img"
            alt=""></a></div></section></div></div>
                            
                        </div>
                    

                    
                        <ul class="hidden-md hidden-lg nav navbar-nav pull-right site-search-full-mobile">
                            <li class="search-form-dropdown dropdown yamm-fw">
                                <a class="dropdown-toggle" data-toggle="dropdown"><span class="fas tnt-search"></span></a>
                                <ul class="dropdown-menu">
                                    <li>
                                        <form action="/search/" method="GET" class="yamm-content">
                                            <input type="hidden" name="l" value="25">
                                            <input type="hidden" name="sd" value="desc">
                                            <input type="hidden" name="s" value="start_time">
                                            <input type="hidden" name="f" value="html">
                                            <input type="hidden" name="t" value="article,video,youtube,collection">
                                            <div class="input-group">
                                                <input name="q" type="text" placeholder="Search..." title="Site Search" class="form-control" autocomplete="off">
                                                <input type="submit" class="hide" value="Search">
                                                <span class="input-group-btn">
                                                    <button class="btn btn-default site-search-btn" type="submit">
                                                        Search
                                                    </button>
                                                </span>
                                            </div>
                                            <div class="clearfix"></div>
                                        </form>
                                    </li>
                                </ul>
                            </li>
                        </ul>
                        <script>
                            $('.site-search-full-mobile button[type="submit"]').on(__tnt.client.clickEvent, function(){
                                $('.site-search-full-mobile form').submit();
                                return false;
                            });
                        </script>
                    
                </div>

                
                    <div id="navbar-collapse" class="navbar-collapse collapse">
                        
                            <div class="pull-right">
                                <div id="tncms-region-main-nav-right-region" class="tncms-region "></div>
                                <div id="tncms-region-nav-main-nav-right-nav" class="tncms-region-nav"><ul id="main-nav-right-nav_menu" class="nav navbar-nav"><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-contact-us"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/site/contact-us.html" >
                    <span class="nav-label">Contact Us</span>
                </a><ul id="main-nav-right-nav_menu-child-1" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-purchase-photos"  href="http://photos.meridianstar.com/"  target="_blank" rel="noopener">
                    <span class="nav-label">Purchase Photos</span>
                </a></li><li>
                <a class="nav-link  tnt-section-submit-a-letter-to-the-editor"  href="/site/forms/online_services/letter/" >
                    <span class="nav-label">Submit a Letter to the Editor</span>
                </a></li><li>
                <a class="nav-link  tnt-section-submit-a-news-tip"  href="/site/forms/online_services/submit_news/" >
                    <span class="nav-label">Submit a News Tip</span>
                </a></li><li>
                <a class="nav-link  tnt-section-place-an-obituary"  href="http://obituaries.meridianstar.com/select-notice-type"  target="_blank" rel="noopener">
                    <span class="nav-label">Place an Obituary</span>
                </a></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-subscribe"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/subscriptions" >
                    <span class="nav-label">Subscribe</span>
                </a><ul id="main-nav-right-nav_menu-child-2" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-start-a-subscription"  href="/subscriptions" >
                    <span class="nav-label">Start a Subscription</span>
                </a></li><li>
                <a class="nav-link  tnt-section-manage-my-subscription"  href="/subscriber-services" >
                    <span class="nav-label">Manage My Subscription</span>
                </a></li><li>
                <a class="nav-link  tnt-section-e-paper"  href="/e-edition" >
                    <span class="nav-label">E-Paper</span>
                </a></li><li>
                <a class="nav-link  tnt-section-app-downloads"  href="/app-downloads" >
                    <span class="nav-label">App Downloads</span>
                </a></li><li>
                <a class="nav-link  tnt-section-newsletter"  href="https://visitor.r20.constantcontact.com/d.jsp?llr=99oml49ab&p=oi&m=1128481045338&sit=s5fwgcwlb&f=e95c0a03-8db9-4d2a-98d3-7dffa92feef5"  target="_blank" rel="noopener">
                    <span class="nav-label">Newsletter</span>
                </a></li></ul></li><li>
                <a class="nav-link  tnt-section-login"  href="javascript:var onclick=ta_account();" id="ta_account_button2" >
                    <span class="nav-label">Login</span>
                </a></li></ul></div>
                            </div>
                        
                        <div class="navbar-left">
                            <div id="tncms-region-nav-main-nav" class="tncms-region-nav"><ul id="main-nav_menu" class="nav navbar-nav"><li class="dropdown">
                <a class="nav-link nav-home dropdown-toggle  tnt-section-span-class-fas-tnt-home-span"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/" >
                    <span class="nav-icon fas tnt-home tnt-fw"></span> <span class="nav-label"><span class="fas tnt-home"></span></span>
                </a><ul id="main-nav_menu-child-1" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-about-us"  href="/site/about-us.html" >
                    <span class="nav-label">About Us</span>
                </a></li><li>
                <a class="nav-link  tnt-section-contact-us"  href="/site/contact-us.html" >
                    <span class="nav-label">Contact Us</span>
                </a></li><li>
                <a class="nav-link  tnt-section-advertise-with-us"  href="/site/advertise-with-us.html" >
                    <span class="nav-label">Advertise with Us</span>
                </a></li><li>
                <a class="nav-link  tnt-section-readers-choice-contest"  href="https://meridianstar.com/bestof"  target="_blank" rel="noopener">
                    <span class="nav-label">Readers Choice Contest</span>
                </a></li></ul></li><li>
                <a class="nav-link  tnt-section-e-paper"  href="/e-edition" >
                    <span class="nav-label">E-Paper</span>
                </a></li><li>
                <a class="nav-link  tnt-section-app"  href="/app-downloads" >
                    <span class="nav-label">App</span>
                </a></li><li>
                <a class="nav-link  tnt-section-celebrations"  href="http://celebrations.meridianstar.com/"  target="_blank" rel="noopener">
                    <span class="nav-label">Celebrations</span>
                </a></li><li>
                <a class="nav-link  tnt-section-obituaries"  href="/obituaries/" >
                    <span class="nav-label">Obituaries</span>
                </a></li><li>
                <a class="nav-link  tnt-section-public-notices"  href="http://notices.meridianstar.com"  target="_blank" rel="noopener">
                    <span class="nav-label">Public Notices</span>
                </a></li></ul></div>
                        </div>
                    </div>
                

                
            </nav>
            
            
        </div>
        
            
                
            
        
    
    <div id="main-body-container">
    <section id="main-top-container" class="container-fullscreen-region container-fluid">
        
        <div class="fullscreen-region"><div id="tncms-region-global-container-top-fullscreen" class="tncms-region "><div id="tncms-block-1567732" class="tncms-block cnhionline-breaking-news-block visible-xs visible-sm"></div></div></div>
    </section>
    <section id="main-page-container" class="container">
        <div class="row">
                <div id="asset-container-top" class="col-md-12"><div id="tncms-region-asset_container_top" class="tncms-region hidden-print"></div></div>
            
            <div class="col-md-12"><div id="tncms-region-global-container-top" class="tncms-region "><div id="tncms-block-1562847" class="tncms-block visible-xs"><!-- Mobile Banner ATF  -->

<div id="mobileBanner_atf_flex" style="width:100%;text-align:center" class="visible-xs visible-sm">
<script type='text/javascript'>
AdBridg.cmd.push(function() { AdBridg.display('mobileBanner_atf_flex'); });
</script>
</div>
<div class="clear" style="padding-bottom:10px"></div>
</div><div id="tncms-block-1560694" class="tncms-block"></div></div></div>
        </div><div class="modal fullscreen" id="photo-carousel-2627feff-1d89-5259-beb3-36f8996e46da" tabindex="-1" role="dialog" aria-labelledby="photo-carousel" aria-hidden="true">
        <div class="modal-dialog modal-lg">
            <div class="modal-content">
                <div class="modal-body">
                    <button type="button" class="close" data-dismiss="modal">
                        <span aria-hidden="true" class="control-left fas tnt-times-circle"></span>
                        <span class="sr-only">Close</span>
                    </button>
                    
    <div id="carousel-2627feff-1d89-5259-beb3-36f8996e46da-photo-modal" class="card photo-carousel    subscriber-hide">
            
            <div class="photo-carousel-control-container">
                    <span class="photo-count">
                        <span class="current-count">1</span> of 4
                    </span>
                    <a class="photo-carousel-control left noselect hidden-print"><span class="control-left fas tnt-chevron-left"></span></a>
                    <a class="photo-carousel-control right noselect hidden-print"><span class="control-left fas tnt-chevron-right"></span></a>
            </div>
            
            <div id="gallery-items-2627feff-1d89-5259-beb3-36f8996e46da-photo-modal" class="carousel-inner">
                        <div  class="item photo-3bed533d-fe65-50db-9577-497a10fdd542 ">
                            <div class="item-container">
                                <div data-track-object='{"title":"Meridian Master Plan: Architect presents final vision for downtown; No estimates on cost, impact","url":"/news/local_news/meridian-master-plan-architect-presents-final-vision-for-downtown-no/article_2627feff-1d89-5259-beb3-36f8996e46da.html","uuid":"2627feff-1d89-5259-beb3-36f8996e46da","app":"editorial","metric":""}'  data-count="1"  class="photo-container layout-horizontal">
                                            <div class="loading-slide text-center"><i class="fas tnt-spinner tnt-spin"></i></div>
                                            
                                        
                                        
                                        
                                        
        
                <img
                    src="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/3/be/3bed533d-fe65-50db-9577-497a10fdd542/5d379506c2291.image.jpg"
                    
                    alt="Meridian Master Plan: Architect shows city council final vision for downtown; No estimates on cost, impact"
                    class="img-responsive owl-first-image owl-lazy"
                    width="800"
                    height="508"
                    data-src="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/3/be/3bed533d-fe65-50db-9577-497a10fdd542/5d379506c2291.image.jpg" />
                                        
                                        
                                </div>
        <div class="caption-container">
                <span class="pull-right photo-carousel-caption-toggle" data-toggle="collapse" data-instance="#carousel-2627feff-1d89-5259-beb3-36f8996e46da-photo-modal" data-target=".caption-inner-2627feff-1d89-5259-beb3-36f8996e46da-photo-modal">
                    <i class="fas tnt-minus-circle"></i>
                </span>
            <div class="caption-inner-2627feff-1d89-5259-beb3-36f8996e46da-photo-modal collapse in"><div class="caption-text"><p>Submitted photo </p><p>LPK Architects' master plan for Meridian includes improvements to the area west of Front Street. </p></div><div class="card-meta">
                        <ul class="list-inline">
                            
                                
                                
                                    <li class="credit"><span  class="tnt-byline">Dynelle</span></li>
                                
                            
                            
                            
                        </ul>
                    </div>
                    <div class="photo-share">
                        
                    </div>
            </div>
        </div>
    <div class="clearfix"></div>
                            </div>
                        </div>
                        <div  class="item photo-c8ff0983-747a-5e80-94fd-95df6ba2c5f9 hidden-print ">
                            <div class="item-container">
                                <div data-track-object='{"title":"Meridian Master Plan: Architect presents final vision for downtown; No estimates on cost, impact","url":"/news/local_news/meridian-master-plan-architect-presents-final-vision-for-downtown-no/article_2627feff-1d89-5259-beb3-36f8996e46da.html","uuid":"2627feff-1d89-5259-beb3-36f8996e46da","app":"editorial","metric":""}'  data-count="2"  class="photo-container layout-horizontal">
                                            <div class="loading-slide text-center"><i class="fas tnt-spinner tnt-spin"></i></div>
                                            
                                        
                                        
                                        
                                        
        
                <img
                    src="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/c/8f/c8ff0983-747a-5e80-94fd-95df6ba2c5f9/5d379506b935f.image.jpg"
                    
                    alt="Meridian Master Plan: Architect shows city council final vision for downtown; No estimates on cost, impact"
                    class="img-responsive owl-first-image owl-lazy"
                    width="800"
                    height="320"
                    data-src="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/c/8f/c8ff0983-747a-5e80-94fd-95df6ba2c5f9/5d379506b935f.image.jpg" />
                                        
                                        
                                </div>
        <div class="caption-container">
                <span class="pull-right photo-carousel-caption-toggle" data-toggle="collapse" data-instance="#carousel-2627feff-1d89-5259-beb3-36f8996e46da-photo-modal" data-target=".caption-inner-2627feff-1d89-5259-beb3-36f8996e46da-photo-modal">
                    <i class="fas tnt-minus-circle"></i>
                </span>
            <div class="caption-inner-2627feff-1d89-5259-beb3-36f8996e46da-photo-modal collapse in"><div class="caption-text"><p>Submitted photo </p><p>LPK Architects' master plan for Meridian includes improvements to 22nd Avenue.</p></div><div class="card-meta">
                        <ul class="list-inline">
                            
                                
                                
                                    <li class="credit"><span  class="tnt-byline">Dynelle</span></li>
                                
                            
                            
                            
                        </ul>
                    </div>
                    <div class="photo-share">
                        
                    </div>
            </div>
        </div>
    <div class="clearfix"></div>
                            </div>
                        </div>
                        <div  class="item photo-489f4115-e27b-5b18-9a72-6ac2a957ee1a hidden-print ">
                            <div class="item-container">
                                <div data-track-object='{"title":"Meridian Master Plan: Architect presents final vision for downtown; No estimates on cost, impact","url":"/news/local_news/meridian-master-plan-architect-presents-final-vision-for-downtown-no/article_2627feff-1d89-5259-beb3-36f8996e46da.html","uuid":"2627feff-1d89-5259-beb3-36f8996e46da","app":"editorial","metric":""}'  data-count="3"  class="photo-container layout-horizontal">
                                            <div class="loading-slide text-center"><i class="fas tnt-spinner tnt-spin"></i></div>
                                            
                                        
                                        
                                        
                                        
        
                <img
                    src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                    alt="Meridian Master Plan: Architect shows city council final vision for downtown; No estimates on cost, impact"
                    class="img-responsive owl-lazy"
                    width="800"
                    height="533"
                    data-src="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/4/89/489f4115-e27b-5b18-9a72-6ac2a957ee1a/5d379506bd605.image.jpg" />
                                        
                                        
                                </div>
        <div class="caption-container">
                <span class="pull-right photo-carousel-caption-toggle" data-toggle="collapse" data-instance="#carousel-2627feff-1d89-5259-beb3-36f8996e46da-photo-modal" data-target=".caption-inner-2627feff-1d89-5259-beb3-36f8996e46da-photo-modal">
                    <i class="fas tnt-minus-circle"></i>
                </span>
            <div class="caption-inner-2627feff-1d89-5259-beb3-36f8996e46da-photo-modal collapse in"><div class="caption-text"><p>Paula Merritt / The Meridian Star</p><p>Revitalization of the area west of Front Street is one part of a master plan being considered by the City of Meridian. </p></div><div class="card-meta">
                        <ul class="list-inline">
                            
                                
                                
                            
                            
                            
                        </ul>
                    </div>
                    <div class="photo-share">
                        
                    </div>
            </div>
        </div>
    <div class="clearfix"></div>
                            </div>
                        </div>
                        <div  class="item photo-0a7f6cbe-68db-5dab-adf8-8dde4add3376 hidden-print ">
                            <div class="item-container">
                                <div data-track-object='{"title":"Meridian Master Plan: Architect presents final vision for downtown; No estimates on cost, impact","url":"/news/local_news/meridian-master-plan-architect-presents-final-vision-for-downtown-no/article_2627feff-1d89-5259-beb3-36f8996e46da.html","uuid":"2627feff-1d89-5259-beb3-36f8996e46da","app":"editorial","metric":""}'  data-count="4"  class="photo-container layout-vertical">
                                            <div class="loading-slide text-center"><i class="fas tnt-spinner tnt-spin"></i></div>
                                            
                                        
                                        
                                        
                                        
        
                <img
                    src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                    alt="Architect Bob Luke files protective order with Meridian to block records request"
                    class="img-responsive owl-lazy"
                    width="413"
                    height="600"
                    data-src="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/0/a7/0a7f6cbe-68db-5dab-adf8-8dde4add3376/5cf98ce61837f.image.jpg" />
                                        
                                        
                                </div>
        <div class="caption-container">
                <span class="pull-right photo-carousel-caption-toggle" data-toggle="collapse" data-instance="#carousel-2627feff-1d89-5259-beb3-36f8996e46da-photo-modal" data-target=".caption-inner-2627feff-1d89-5259-beb3-36f8996e46da-photo-modal">
                    <i class="fas tnt-minus-circle"></i>
                </span>
            <div class="caption-inner-2627feff-1d89-5259-beb3-36f8996e46da-photo-modal collapse in"><div class="caption-text"><p>Bob Luke</p></div><div class="card-meta">
                        <ul class="list-inline">
                            
                                
                                
                            
                            
                            
                        </ul>
                    </div>
                    <div class="photo-share">
                        
                    </div>
            </div>
        </div>
    <div class="clearfix"></div>
                            </div>
                        </div>
            </div>
        </div>
                    <div class="clearfix"></div>
                </div>
            </div>
        </div>
    </div><article itemscope itemtype="https://schema.org/Article" id="asset-2627feff-1d89-5259-beb3-36f8996e46da" class="asset article-default"  data-url="https://www.meridianstar.com/news/local_news/meridian-master-plan-architect-presents-final-vision-for-downtown-no/article_2627feff-1d89-5259-beb3-36f8996e46da.html">
    <span itemscope itemtype="http://schema.org/SpeakableSpecification">
        <meta itemprop="cssSelector" content=".asset-header .headline" />
        <meta itemprop="cssSelector" content=".asset-content p:first-of-type" />
    </span><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
        <div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="url" content="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/3/be/3bed533d-fe65-50db-9577-497a10fdd542/5d379506c2291.image.jpg?resize=800%2C508">
            <meta itemprop="width" content="800">
            <meta itemprop="height" content="508">
        </div>
        <meta itemprop="name" content="meridianstar.com">
    </div>
    <link itemprop="mainEntityOfPage" href="https://www.meridianstar.com/news/local_news/meridian-master-plan-architect-presents-final-vision-for-downtown-no/article_2627feff-1d89-5259-beb3-36f8996e46da.html" />
    <style>
                .asset-paging .direction {
                    color: #495970;
                }
            </style><div class="asset-paging-container hidden-print">
            <div id="asset-paging-2627feff-1d89-5259-beb3-36f8996e46da" class="asset-paging">
                <div id="paging-prev-2627feff-1d89-5259-beb3-36f8996e46da" class="paging-link prev offset"></div>
                <div id="paging-next-2627feff-1d89-5259-beb3-36f8996e46da" class="paging-link next offset"></div>
                <div class="clearfix"></div>
            </div>
        </div>
        <script>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</script><div class="asset-masthead ">
        <header class="asset-header">
    
        <div class="asset-label-flags">
            <span class="tnt-flag label label-flag label-flag-default label-flag-editors-pick">editor's pick</span> <span class="tnt-flag label label-flag label-flag-default label-flag-top-story">top story</span> 
        </div>
    
    <h1 itemprop="headline" class="headline">
        <span>
            
            Meridian Master Plan: Architect presents final vision for downtown; No estimates on cost, impact
        </span>
    </h1>
    
    <div class="meta">
        <span>
            <ul class="list-inline">
        <li><span itemprop="author" class="tnt-byline">By Ryan Oehrli roehrli@themeridianstar.com</span></li>
        
        
            <li>
        <time datetime="2019-07-23T18:15:00-05:00" class="tnt-date asset-date text-muted">6 hrs ago</time></li>
        
        
            <li class="hidden-print"></li>
        
        
    </ul>
        </span>
    </div>
    <meta itemprop="dateCreated" content="2019-07-23T18:15:00-05:00">
    <meta itemprop="datePublished" content="2019-07-23T18:15:00-05:00">
    <meta itemprop="dateModified" content="2019-07-23T18:15:00-05:00">
</header>
        
        
            <div class="share-container headline-right pull-right hidden-xs" data-subscription-required-remove></div>
        
    </div>

    

    <div class="row">
        <div class="main-content col-lg-8 col-md-7"><div class="main-content-wrap">
            <div id="tncms-region-article_top" class="tncms-region hidden-print"></div>
            
            <div id="asset-photo" class="card"><figure class="photo layout-horizontal hover-expand"><span class="expand hidden-print"
               
               data-toggle="modal"
                
                    data-photo-target=".photo-3bed533d-fe65-50db-9577-497a10fdd542" 
                    data-instance="#gallery-items-2627feff-1d89-5259-beb3-36f8996e46da-photo-modal" 
                    data-target="#photo-carousel-2627feff-1d89-5259-beb3-36f8996e46da">
                       <span class="fas tnt-expand"></span>
                   </span>
            
            <div class="image" 
                 
                    data-toggle="modal" 
                     
                    data-photo-target=".photo-3bed533d-fe65-50db-9577-497a10fdd542" 
                    data-instance="#gallery-items-2627feff-1d89-5259-beb3-36f8996e46da-photo-modal" 
                    data-target="#photo-carousel-2627feff-1d89-5259-beb3-36f8996e46da">
                
                
                
                
        <div itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="width" content="800">
            <meta itemprop="height" content="508">
            <meta itemprop="contentUrl" content="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/3/be/3bed533d-fe65-50db-9577-497a10fdd542/5d379506c2291.image.jpg">
            <meta itemprop="url" content="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/3/be/3bed533d-fe65-50db-9577-497a10fdd542/5d379506c2291.image.jpg">
        <img
                    src="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/3/be/3bed533d-fe65-50db-9577-497a10fdd542/5d379506c2291.image.jpg?resize=400%2C254"
                    srcset="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/3/be/3bed533d-fe65-50db-9577-497a10fdd542/5d379506c2291.image.jpg?resize=200%2C127 200w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/3/be/3bed533d-fe65-50db-9577-497a10fdd542/5d379506c2291.image.jpg?resize=300%2C191 300w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/3/be/3bed533d-fe65-50db-9577-497a10fdd542/5d379506c2291.image.jpg?resize=400%2C254 400w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/3/be/3bed533d-fe65-50db-9577-497a10fdd542/5d379506c2291.image.jpg?resize=540%2C343 540w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/3/be/3bed533d-fe65-50db-9577-497a10fdd542/5d379506c2291.image.jpg?resize=750%2C476 750w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/3/be/3bed533d-fe65-50db-9577-497a10fdd542/5d379506c2291.image.jpg?resize=800%2C508 1200w"
                    sizes="(min-width: 1200px) 750px, (min-width: 992px) calc(66.70vw - 60px), 100vw"
                    width="800"
                    height="508"
                    alt="Meridian Master Plan: Architect shows city council final vision for downtown; No estimates on cost, impact"
                    class="img-responsive full tnt-restrict-img-3bed533d-fe65-50db-9577-497a10fdd542" />
            </div><style>
                .tnt-restrict-img-3bed533d-fe65-50db-9577-497a10fdd542 {
                    max-width: 760px;
                }
            </style>
                
            </div>
            
                
                
                    <figcaption class="caption">
                            <span class="caption-text">
                                <p>Submitted photo </p><p>LPK Architects' master plan for Meridian includes improvements to the area west of Front Street. </p>
                            </span>
                        
                        
                            <span class="credit">
                                <span  class="tnt-byline">Dynelle</span>
                            </span>
                        
                    </figcaption>
                
            
        </figure></div>

            

            

            <div id="tncms-region-article_top_content" class="tncms-region hidden-print"></div>

            <div id="asset-content" data-asset-uuid="2627feff-1d89-5259-beb3-36f8996e46da">
                

                <div class="row">
                    <div class="col-lg-12 col-md-12 col-sm-12" data-subscription-required-class="col-xs-12">
                        
                        <div class="asset-body" data-subscription-required-class="asset-body">
                            
                                <div class="share-container content-above" data-subscription-required-remove></div>
                            
<div style="margin-bottom:20px">	
        <a href="https://www.facebook.com/sharer/sharer.php?u=https://www.meridianstar.com/news/local_news/meridian-master-plan-architect-presents-final-vision-for-downtown-no/article_2627feff-1d89-5259-beb3-36f8996e46da.html" class="popup" style="padding:10px" style="padding:10px" data-toggle="new-window" data-new-window-width="500" data-new-window-height="300">
          <span class="rrssb-icon">
            <svg xmlns="http://www.w3.org/2000/svg" width="20" height="20" viewBox="0 0 29 29"><path d="M26.4 0H2.6C1.714 0 0 1.715 0 2.6v23.8c0 .884 1.715 2.6 2.6 2.6h12.393V17.988h-3.996v-3.98h3.997v-3.062c0-3.746 2.835-5.97 6.177-5.97 1.6 0 2.444.173 2.845.226v3.792H21.18c-1.817 0-2.156.9-2.156 2.168v2.847h5.045l-.66 3.978h-4.386V29H26.4c.884 0 2.6-1.716 2.6-2.6V2.6c0-.885-1.716-2.6-2.6-2.6z"/></svg>
          </span>
        </a>
        <a href="https://twitter.com/intent/tweet?text=Meridian Master Plan: Architect presents final vision for downtown; No estimates on cost, impact%20%7C%20https://www.meridianstar.com/news/local_news/meridian-master-plan-architect-presents-final-vision-for-downtown-no/article_2627feff-1d89-5259-beb3-36f8996e46da.html" class="popup" style="padding:10px" data-toggle="new-window" data-new-window-width="500" data-new-window-height="300">
          <span class="rrssb-icon">
            <svg xmlns="http://www.w3.org/2000/svg" width="20" height="20" viewBox="0 0 28 28"><path d="M24.253 8.756C24.69 17.08 18.297 24.182 9.97 24.62a15.093 15.093 0 0 1-8.86-2.32c2.702.18 5.375-.648 7.507-2.32a5.417 5.417 0 0 1-4.49-3.64c.802.13 1.62.077 2.4-.154a5.416 5.416 0 0 1-4.412-5.11 5.43 5.43 0 0 0 2.168.387A5.416 5.416 0 0 1 2.89 4.498a15.09 15.09 0 0 0 10.913 5.573 5.185 5.185 0 0 1 3.434-6.48 5.18 5.18 0 0 1 5.546 1.682 9.076 9.076 0 0 0 3.33-1.317 5.038 5.038 0 0 1-2.4 2.942 9.068 9.068 0 0 0 3.02-.85 5.05 5.05 0 0 1-2.48 2.71z"/></svg>
          </span>
        </a>
        <a href="https://plus.google.com/share?url=Meridian Master Plan: Architect presents final vision for downtown; No estimates on cost, impact%20https://www.meridianstar.com/news/local_news/meridian-master-plan-architect-presents-final-vision-for-downtown-no/article_2627feff-1d89-5259-beb3-36f8996e46da.html" class="popup" style="padding:10px"data-toggle="new-window" data-new-window-width="500" data-new-window-height="300">
          <span class="rrssb-icon">
            <svg xmlns="http://www.w3.org/2000/svg" width="20" height="20" viewBox="0 0 24 24"><path d="M21 8.29h-1.95v2.6h-2.6v1.82h2.6v2.6H21v-2.6h2.6v-1.885H21V8.29zM7.614 10.306v2.925h3.9c-.26 1.69-1.755 2.925-3.9 2.925-2.34 0-4.29-2.016-4.29-4.354s1.885-4.353 4.29-4.353c1.104 0 2.014.326 2.794 1.105l2.08-2.08c-1.3-1.17-2.924-1.883-4.874-1.883C3.65 4.586.4 7.835.4 11.8s3.25 7.212 7.214 7.212c4.224 0 6.953-2.988 6.953-7.082 0-.52-.065-1.104-.13-1.624H7.614z"/></svg>
            </span>

        </a>
        <a href="http://www.linkedin.com/shareArticle?mini=true&amp;url=https://www.meridianstar.com/news/local_news/meridian-master-plan-architect-presents-final-vision-for-downtown-no/article_2627feff-1d89-5259-beb3-36f8996e46da.html&amp;summary=Meridian Master Plan: Architect presents final vision for downtown; No estimates on cost, impact" class="popup" style="padding:10px"data-toggle="new-window" data-new-window-width="500" data-new-window-height="300">
          <span class="rrssb-icon">
            <svg xmlns="http://www.w3.org/2000/svg" width="20" height="20" viewBox="0 0 28 28"><path d="M25.424 15.887v8.447h-4.896v-7.882c0-1.98-.71-3.33-2.48-3.33-1.354 0-2.158.91-2.514 1.802-.13.315-.162.753-.162 1.194v8.216h-4.9s.067-13.35 0-14.73h4.9v2.087c-.01.017-.023.033-.033.05h.032v-.05c.65-1.002 1.812-2.435 4.414-2.435 3.222 0 5.638 2.106 5.638 6.632zM5.348 2.5c-1.676 0-2.772 1.093-2.772 2.54 0 1.42 1.066 2.538 2.717 2.546h.032c1.71 0 2.77-1.132 2.77-2.546C8.056 3.593 7.02 2.5 5.344 2.5h.005zm-2.48 21.834h4.896V9.604H2.867v14.73z"/></svg>
          </span>

        </a>

        <a href="http://pinterest.com/pin/create/button/?url=https://www.meridianstar.com/news/local_news/meridian-master-plan-architect-presents-final-vision-for-downtown-no/article_2627feff-1d89-5259-beb3-36f8996e46da.html&amp;media=https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/3/be/3bed533d-fe65-50db-9577-497a10fdd542/5d379506c2291.image.jpg?resize=760%2C483&amp;description=Meridian Master Plan: Architect presents final vision for downtown; No estimates on cost, impact"  style="padding:10px"data-toggle="new-window" data-new-window-width="500" data-new-window-height="300">
          <span class="rrssb-icon">
            <svg xmlns="http://www.w3.org/2000/svg" width="20" height="20" viewBox="0 0 28 28"><path d="M14.02 1.57c-7.06 0-12.784 5.723-12.784 12.785S6.96 27.14 14.02 27.14c7.062 0 12.786-5.725 12.786-12.785 0-7.06-5.724-12.785-12.785-12.785zm1.24 17.085c-1.16-.09-1.648-.666-2.558-1.22-.5 2.627-1.113 5.146-2.925 6.46-.56-3.972.822-6.952 1.462-10.117-1.094-1.84.13-5.545 2.437-4.632 2.837 1.123-2.458 6.842 1.1 7.557 3.71.744 5.226-6.44 2.924-8.775-3.324-3.374-9.677-.077-8.896 4.754.19 1.178 1.408 1.538.49 3.168-2.13-.472-2.764-2.15-2.683-4.388.132-3.662 3.292-6.227 6.46-6.582 4.008-.448 7.772 1.474 8.29 5.24.58 4.254-1.815 8.864-6.1 8.532v.003z"/></svg>
          </span>

        </a>

        <a href="mailto:?subject=Meridian Master Plan: Architect presents final vision for downtown; No estimates on cost, impact&amp;body=https://www.meridianstar.com/news/local_news/meridian-master-plan-architect-presents-final-vision-for-downtown-no/article_2627feff-1d89-5259-beb3-36f8996e46da.html"  style="padding:10px">
          <span class="rrssb-icon">
            <svg xmlns="http://www.w3.org/2000/svg" width="20" height="20" viewBox="0 0 28 28"><path d="M20.11 26.147c-2.335 1.05-4.36 1.4-7.124 1.4C6.524 27.548.84 22.916.84 15.284.84 7.343 6.602.45 15.4.45c6.854 0 11.8 4.7 11.8 11.252 0 5.684-3.193 9.265-7.398 9.3-1.83 0-3.153-.934-3.347-2.997h-.077c-1.208 1.986-2.96 2.997-5.023 2.997-2.532 0-4.36-1.868-4.36-5.062 0-4.75 3.503-9.07 9.11-9.07 1.713 0 3.7.4 4.6.972l-1.17 7.203c-.387 2.298-.115 3.3 1 3.4 1.674 0 3.774-2.102 3.774-6.58 0-5.06-3.27-8.994-9.304-8.994C9.05 2.87 3.83 7.545 3.83 14.97c0 6.5 4.2 10.2 10 10.202 1.987 0 4.09-.43 5.647-1.245l.634 2.22zM16.647 10.1c-.31-.078-.7-.155-1.207-.155-2.572 0-4.596 2.53-4.596 5.53 0 1.5.7 2.4 1.9 2.4 1.44 0 2.96-1.83 3.31-4.088l.592-3.72z"/></svg>
          </span>

        </a>

</div>
<div id="tncms-region-article_body_top" class="tncms-region hidden-print"></div>

                            <div itemprop="articleBody" class="asset-content  subscriber-premium">
                                <meta itemprop="isAccessibleForFree" content="true"/>
                                
        <style>#inform-video-player-1 .inform-embed { margin-top: 10px; margin-bottom: 20px; }</style>
        <div class="inform-container inform-video-player-1">
            <div class="inform-embed"
                 data-placement-id="inform-video-player-1"
                 data-tracking-group="92122"
                 data-width="100%"
                 data-aspect-ratio="16:9"
                 ></div>
            <script>var _informq = _informq || [];_informq.push(['embed']);</script>
        </div>
                                
        <style>#inform-video-player-2 .inform-embed { margin-top: 10px; margin-bottom: 20px; }</style>
        <div class="inform-container inform-video-player-2">
            <div class="inform-embed"
                 data-placement-id="inform-video-player-2"
                 data-tracking-group="92122"
                 data-width="100%"
                 data-aspect-ratio="16:9"
                 ></div>
            <script>var _informq = _informq || [];_informq.push(['embed']);</script>
        </div>
                                <p> Improved landscaping, better traffic lights, redone roads and more green spaces are part of architect Bob Luke's vision of a revitalized downtown Meridian.</p><div class="inline-asset inline-image layout-vertical  subscriber-hide  tnt-asset-presentation-mugshot  tnt-inline-asset tnt-inline-relcontent tnt-inline-image tnt-inline-relation-child tnt-inline-presentation-default tnt-inline-alignment-default tnt-inline-width-default"><figure class="photo layout-vertical hover-expand"><span class="expand hidden-print"
               
               data-toggle="modal"
                
                    data-photo-target=".photo-0a7f6cbe-68db-5dab-adf8-8dde4add3376" 
                    data-instance="#gallery-items-2627feff-1d89-5259-beb3-36f8996e46da-photo-modal" 
                    data-target="#photo-carousel-2627feff-1d89-5259-beb3-36f8996e46da">
                       <span class="fas tnt-expand"></span>
                   </span>
            
            <div class="image" 
                 
                    data-toggle="modal" 
                     
                    data-photo-target=".photo-0a7f6cbe-68db-5dab-adf8-8dde4add3376" 
                    data-instance="#gallery-items-2627feff-1d89-5259-beb3-36f8996e46da-photo-modal" 
                    data-target="#photo-carousel-2627feff-1d89-5259-beb3-36f8996e46da">
                
                
                
                
        <div itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="width" content="413">
            <meta itemprop="height" content="600">
            <meta itemprop="contentUrl" content="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/0/a7/0a7f6cbe-68db-5dab-adf8-8dde4add3376/5cf98ce61837f.image.jpg">
            <meta itemprop="url" content="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/0/a7/0a7f6cbe-68db-5dab-adf8-8dde4add3376/5cf98ce61837f.image.jpg">
        
                    <img
                        src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                        alt="Architect Bob Luke files protective order with Meridian to block records request"
                        class="img-responsive lazyload full"
                        width="413"
                        height="600"
                        data-sizes="auto"
                        data-srcset="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/0/a7/0a7f6cbe-68db-5dab-adf8-8dde4add3376/5cf98ce61837f.image.jpg?resize=200%2C291 200w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/0/a7/0a7f6cbe-68db-5dab-adf8-8dde4add3376/5cf98ce61837f.image.jpg?resize=300%2C436 300w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/0/a7/0a7f6cbe-68db-5dab-adf8-8dde4add3376/5cf98ce61837f.image.jpg?resize=400%2C581 400w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/0/a7/0a7f6cbe-68db-5dab-adf8-8dde4add3376/5cf98ce61837f.image.jpg?resize=413%2C600 540w" />
            </div>
                
            </div>
            
                
                
                    <figcaption class="caption">
                            <span class="caption-text">
                                <p>Bob Luke</p>
                            </span>
                        
                        
                    </figcaption>
                
            
        </figure></div><p>Luke, the managing principal of LPK Architects in Meridian, offered the city council a final look at a master plan for the city Tuesday morning, suggesting a myriad of potential improvements. </p><div id="tncms-region-article_instory_top" class="tncms-region hidden-print"></div><p>Estimated costs for the changes were not revealed, though, and one council member wanted an impact analysis that also was not provided.</p><p>LPK was contracted by the city for its master plan in December 2016. The council authorized a $93,500 agreement with the firm then.</p><p>“We have the most intact downtown in any city in Mississippi,” Luke said, adding that it needs to be capitalized on more.</p><p>New additions to the city could include public space that will take advantage of the city’s railroad infrastructure, similar to the High Line in New York City; a revitalization of 22nd Avenue as it enters downtown; another public space near City Hall; different types of trees planted downtown; and something to aid the historic African-American business district.</p><p>Luke also recommended that the old police station be remade into something for public use and that Sowashee Creek be restored.</p><div class="inline-asset inline-image layout-horizontal  subscriber-hide  tnt-inline-asset tnt-inline-relcontent tnt-inline-image tnt-inline-relation-child tnt-inline-presentation-default tnt-inline-alignment-default tnt-inline-width-default"><figure class="photo layout-horizontal hover-expand"><span class="expand hidden-print"
               
               data-toggle="modal"
                
                    data-photo-target=".photo-489f4115-e27b-5b18-9a72-6ac2a957ee1a" 
                    data-instance="#gallery-items-2627feff-1d89-5259-beb3-36f8996e46da-photo-modal" 
                    data-target="#photo-carousel-2627feff-1d89-5259-beb3-36f8996e46da">
                       <span class="fas tnt-expand"></span>
                   </span>
            
            <div class="image" 
                 
                    data-toggle="modal" 
                     
                    data-photo-target=".photo-489f4115-e27b-5b18-9a72-6ac2a957ee1a" 
                    data-instance="#gallery-items-2627feff-1d89-5259-beb3-36f8996e46da-photo-modal" 
                    data-target="#photo-carousel-2627feff-1d89-5259-beb3-36f8996e46da">
                
                
                
                
        <div itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="width" content="800">
            <meta itemprop="height" content="533">
            <meta itemprop="contentUrl" content="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/4/89/489f4115-e27b-5b18-9a72-6ac2a957ee1a/5d379506bd605.image.jpg">
            <meta itemprop="url" content="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/4/89/489f4115-e27b-5b18-9a72-6ac2a957ee1a/5d379506bd605.image.jpg">
        
                    <img
                        src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                        alt="Meridian Master Plan: Architect shows city council final vision for downtown; No estimates on cost, impact"
                        class="img-responsive lazyload full"
                        width="800"
                        height="533"
                        data-sizes="auto"
                        data-srcset="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/4/89/489f4115-e27b-5b18-9a72-6ac2a957ee1a/5d379506bd605.image.jpg?resize=200%2C133 200w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/4/89/489f4115-e27b-5b18-9a72-6ac2a957ee1a/5d379506bd605.image.jpg?resize=300%2C200 300w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/4/89/489f4115-e27b-5b18-9a72-6ac2a957ee1a/5d379506bd605.image.jpg?resize=400%2C267 400w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/4/89/489f4115-e27b-5b18-9a72-6ac2a957ee1a/5d379506bd605.image.jpg?resize=540%2C360 540w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/4/89/489f4115-e27b-5b18-9a72-6ac2a957ee1a/5d379506bd605.image.jpg?resize=750%2C500 750w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/4/89/489f4115-e27b-5b18-9a72-6ac2a957ee1a/5d379506bd605.image.jpg?resize=800%2C533 1200w" />
            </div>
                
            </div>
            
                
                
                    <figcaption class="caption">
                            <span class="caption-text">
                                <p>Paula Merritt / The Meridian Star</p><p>Revitalization of the area west of Front Street is one part of a master plan being considered by the City of Meridian. </p>
                            </span>
                        
                        
                    </figcaption>
                
            
        </figure></div><p>Small proposed changes include more green space, signage for parking spaces and making traffic lights coordinated instead of timed by default. After studying Oxford, Luke said paid parking may be one way to bring more revenue to Meridian.</p><p>A roughly three-mile area downtown is a food desert, said Luke, meaning it does not offer healthy food. If new businesses, such as food trucks or cooperatives that sell fresh produce, were attracted to set up shop, that problem could be alleviated, he and his team said.</p><p>Council members Weston Lindemann, Fannie Johnson and George Thomas raised concerns after the presentation.</p><p>Lindemann, who represents Ward 5, asked if Luke had an impact analysis—an assessment of how changes would affect downtown economically.</p><p>“What we do is give you the framework, and when you identify things, we can help you move forward,” replied Luke.</p><p>“A plan, by its very definition, would include that sort of information,” said Lindemann in an interview after the meeting. “What we really saw today is a vision for downtown, or a dream, but not a plan.”</p><p>Johnson, who represents Ward 3, said at the meeting that she was impressed but skeptical how the city would afford the proposed projects.</p><div class="inline-asset inline-image layout-horizontal  subscriber-hide  tnt-inline-asset tnt-inline-relcontent tnt-inline-image tnt-inline-relation-child tnt-inline-presentation-default tnt-inline-alignment-default tnt-inline-width-default"><figure class="photo layout-horizontal hover-expand"><span class="expand hidden-print"
               
               data-toggle="modal"
                
                    data-photo-target=".photo-c8ff0983-747a-5e80-94fd-95df6ba2c5f9" 
                    data-instance="#gallery-items-2627feff-1d89-5259-beb3-36f8996e46da-photo-modal" 
                    data-target="#photo-carousel-2627feff-1d89-5259-beb3-36f8996e46da">
                       <span class="fas tnt-expand"></span>
                   </span>
            
            <div class="image" 
                 
                    data-toggle="modal" 
                     
                    data-photo-target=".photo-c8ff0983-747a-5e80-94fd-95df6ba2c5f9" 
                    data-instance="#gallery-items-2627feff-1d89-5259-beb3-36f8996e46da-photo-modal" 
                    data-target="#photo-carousel-2627feff-1d89-5259-beb3-36f8996e46da">
                
                
                
                
        <div itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="width" content="800">
            <meta itemprop="height" content="320">
            <meta itemprop="contentUrl" content="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/c/8f/c8ff0983-747a-5e80-94fd-95df6ba2c5f9/5d379506b935f.image.jpg">
            <meta itemprop="url" content="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/c/8f/c8ff0983-747a-5e80-94fd-95df6ba2c5f9/5d379506b935f.image.jpg">
        
                    <img
                        src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                        alt="Meridian Master Plan: Architect shows city council final vision for downtown; No estimates on cost, impact"
                        class="img-responsive lazyload full"
                        width="800"
                        height="320"
                        data-sizes="auto"
                        data-srcset="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/c/8f/c8ff0983-747a-5e80-94fd-95df6ba2c5f9/5d379506b935f.image.jpg?resize=200%2C80 200w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/c/8f/c8ff0983-747a-5e80-94fd-95df6ba2c5f9/5d379506b935f.image.jpg?resize=300%2C120 300w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/c/8f/c8ff0983-747a-5e80-94fd-95df6ba2c5f9/5d379506b935f.image.jpg?resize=400%2C160 400w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/c/8f/c8ff0983-747a-5e80-94fd-95df6ba2c5f9/5d379506b935f.image.jpg?resize=540%2C216 540w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/c/8f/c8ff0983-747a-5e80-94fd-95df6ba2c5f9/5d379506b935f.image.jpg?resize=750%2C300 750w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/c/8f/c8ff0983-747a-5e80-94fd-95df6ba2c5f9/5d379506b935f.image.jpg?resize=800%2C320 1200w" />
            </div>
                
            </div>
            
                
                
                    <figcaption class="caption">
                            <span class="caption-text">
                                <p>Submitted photo </p><p>LPK Architects' master plan for Meridian includes improvements to 22nd Avenue.</p>
                            </span>
                        
                        
                            <span class="credit">
                                <span itemprop="author" class="tnt-byline">Dynelle</span>
                            </span>
                        
                    </figcaption>
                
            
        </figure></div><p>“At the end of the day, there’s some basic stuff that the city needs to handle,” she said later, adding that “it would be money well spent if we had the money to do it.”</p><div id="tncms-region-article_instory_middle" class="tncms-region hidden-print"><div id="tncms-block-1131386" class="tncms-block visible-xs">
<!-- Mobile Rectangle ATF 300x250 article -->
<div id="mobileRectangle_atf" style="width:100%;text-align:center" class="visible-xs visible-sm">
<script type='text/javascript'>
AdBridg.cmd.push(function() { AdBridg.display('mobileRectangle_atf'); });
</script>
</div>
<div class="clear" style="padding-bottom:10px"></div>


</div></div><p>Ward 1 councilman George Thomas was also impressed by the presentation but unsure whether the plan was geared towards creating a “historic” downtown or something more “contemporary.”</p><p>“If it’s a master plan, what are we? Who are we?” he asked.</p><p>In an interview after the meeting, Thomas said he expects 22nd Avenue and smaller-scale projects will be the first to tackle.</p><p>A reporter asked Luke why no cost estimates were provided in the presentation. Luke echoed his response to Lindemann’s question about an impact analysis, saying he was was giving a framework. </p><p>Chief Administrative Officer Richie McAlister said after the meeting that grants, partnerships and tax financing could all lower costs considerably. He gave reference to the 22nd Avenue project, which is a federal opportunity zone.</p><p>“It’s also the perfect location for a TIGER grant,” he added.</p><p>“A lot of these initial projects are just low-hanging projects. In the end, the city will be the catalyst for outside investors to come in and begin investing in the area.”</p><p>The city council is planning its budget for next year. The budget is due by the end of September, after which conversations about the master plan will likely begin again, according to council members.</p><div id="tncms-region-article_instory_bottom" class="tncms-region hidden-print"></div><div id="tncms-region-article_bottom_content" class="tncms-region hidden-print"></div>
                                
        <style>#inform-video-player-3 .inform-embed { margin-top: 10px; margin-bottom: 20px; }</style>
        <div class="inform-container inform-video-player-3">
            <div class="inform-embed"
                 data-placement-id="inform-video-player-3"
                 data-tracking-group="92122"
                 data-width="100%"
                 data-aspect-ratio="16:9"
                 ></div>
            <script>var _informq = _informq || [];_informq.push(['embed']);</script>
        </div>
                            </div>
                            
                            

                              
<!-- code here -->

    
        
            
                <div id="reaction-wrap" class="reaction-wrapper hidden-print reaction-2627feff-1d89-5259-beb3-36f8996e46da anonymous">
                    <div id="reaction">
                        
                            <h4>React to this story:</h4>
                        
                        
                        <div id="reaction-form-wrapper">
                            
                            <form id="reaction-form" onsubmit="return" data-uuid="2627feff-1d89-5259-beb3-36f8996e46da" method="post" action="/tncms/counter/editorial/2627feff-1d89-5259-beb3-36f8996e46da/?">
                                <input type="hidden" name="subkey" value="reaction">
                                <input type="hidden" name="action" value="add" id="action">
                                <input type="hidden" name="type" value="" id="hidden-type">
                                <input type="hidden" name="id" value="2627feff-1d89-5259-beb3-36f8996e46da" id="asset-id" />
                                <div class="form-icons love" data-user-reaction-emotion="love">
                                               <label class="love-icon reaction-name" data-user-reaction-emotion="love">
                                                   <span class="emotion-name" data-user-reaction-emotion="love">Love</span>
                                                   
                                               </label>
                                               <div class="emotion-container" data-user-reaction-emotion="love">
                                                   <div class="love-icon form-emoji" data-user-reaction-emotion="love"></div>
                                                   <div id="reaction-love-count" 
                                                        class="reaction-count count-love" 
                                                        data-user-reaction-count="1" 
                                                        data-user-reaction-emotion="love">1</div>
                                               </div>
                                           </div><div class="form-icons funny" data-user-reaction-emotion="funny">
                                               <label class="funny-icon reaction-name" data-user-reaction-emotion="funny">
                                                   <span class="emotion-name" data-user-reaction-emotion="funny">Funny</span>
                                                   
                                               </label>
                                               <div class="emotion-container" data-user-reaction-emotion="funny">
                                                   <div class="funny-icon form-emoji" data-user-reaction-emotion="funny"></div>
                                                   <div id="reaction-funny-count" 
                                                        class="reaction-count count-funny" 
                                                        data-user-reaction-count="1" 
                                                        data-user-reaction-emotion="funny">1</div>
                                               </div>
                                           </div><div class="form-icons wow" data-user-reaction-emotion="wow">
                                               <label class="wow-icon reaction-name" data-user-reaction-emotion="wow">
                                                   <span class="emotion-name" data-user-reaction-emotion="wow">Wow</span>
                                                   
                                               </label>
                                               <div class="emotion-container" data-user-reaction-emotion="wow">
                                                   <div class="wow-icon form-emoji" data-user-reaction-emotion="wow"></div>
                                                   <div id="reaction-wow-count" 
                                                        class="reaction-count count-wow" 
                                                        data-user-reaction-count="0" 
                                                        data-user-reaction-emotion="wow">0</div>
                                               </div>
                                           </div><div class="form-icons sad" data-user-reaction-emotion="sad">
                                               <label class="sad-icon reaction-name" data-user-reaction-emotion="sad">
                                                   <span class="emotion-name" data-user-reaction-emotion="sad">Sad</span>
                                                   
                                               </label>
                                               <div class="emotion-container" data-user-reaction-emotion="sad">
                                                   <div class="sad-icon form-emoji" data-user-reaction-emotion="sad"></div>
                                                   <div id="reaction-sad-count" 
                                                        class="reaction-count count-sad" 
                                                        data-user-reaction-count="0" 
                                                        data-user-reaction-emotion="sad">0</div>
                                               </div>
                                           </div><div class="form-icons angry" data-user-reaction-emotion="angry">
                                               <label class="angry-icon reaction-name" data-user-reaction-emotion="angry">
                                                   <span class="emotion-name" data-user-reaction-emotion="angry">Angry</span>
                                                   
                                               </label>
                                               <div class="emotion-container" data-user-reaction-emotion="angry">
                                                   <div class="angry-icon form-emoji" data-user-reaction-emotion="angry"></div>
                                                   <div id="reaction-angry-count" 
                                                        class="reaction-count count-angry" 
                                                        data-user-reaction-count="0" 
                                                        data-user-reaction-emotion="angry">0</div>
                                               </div>
                                           </div>
                            </form>
                        </div>
                    </div>
                    <div id="reaction-form-message" class="hide">
                        <p></p>
                    </div>
                </div>
        
    


                            
                                <div class="share-container content-below" data-subscription-required-remove></div>
                            
                        </div>
                        
                    </div></div><!-- /asset-content -->

                <div id="asset-below">
                    

                    

                    

                    

                    
                        <div class="asset-tags hidden-print">
                            <h4>Tags</h4>
                            <ul class="list-inline"><li>
                <a href="/search/?k=%22bob%20luke%22#tncms-source=keyword" class="tag-bob-luke label label-default" data-tncms-track-dmp='search: bob-luke'>Bob Luke</a>
            </li> <li>
                <a href="/search/?k=%22downtown%22#tncms-source=keyword" class="tag-downtown label label-default" data-tncms-track-dmp='search: downtown'>Downtown</a>
            </li> <li>
                <a href="/search/?k=%22commerce%22#tncms-source=keyword" class="tag-commerce label label-default" data-tncms-track-dmp='search: commerce'>Commerce</a>
            </li> <li>
                <a href="/search/?k=%22economics%22#tncms-source=keyword" class="tag-economics label label-default" data-tncms-track-dmp='search: economics'>Economics</a>
            </li> <li>
                <a href="/search/?k=%22vision%22#tncms-source=keyword" class="tag-vision label label-default" data-tncms-track-dmp='search: vision'>Vision</a>
            </li> <li>
                <a href="/search/?k=%22city%20council%22#tncms-source=keyword" class="tag-city-council label label-default" data-tncms-track-dmp='search: city-council'>City Council</a>
            </li> <li>
                <a href="/search/?k=%22george%20thomas%22#tncms-source=keyword" class="tag-george-thomas label label-default" data-tncms-track-dmp='search: george-thomas'>George Thomas</a>
            </li> <li>
                <a href="/search/?k=%22fannie%20johnson%22#tncms-source=keyword" class="tag-fannie-johnson label label-default" data-tncms-track-dmp='search: fannie-johnson'>Fannie Johnson</a>
            </li> <li>
                <a href="/search/?k=%22cost%22#tncms-source=keyword" class="tag-cost label label-default" data-tncms-track-dmp='search: cost'>Cost</a>
            </li> <li>
                <a href="/search/?k=%22council%20member%22#tncms-source=keyword" class="tag-council-member label label-default" data-tncms-track-dmp='search: council-member'>Council Member</a>
            </li> </ul>
                        </div>
                    

                    

                    

                    
<div id="nativo-article-bottom" class="nativo-article"></div>
<!-- livefyre code -->

<!-- Comments Widget -->
 <script type="text/javascript">
    var networkConfig = {
      network: 'cnhi.fyre.co'
    };
    var convConfig = {
      siteId: '362242',
      articleId: '2627feff-1d89-5259-beb3-36f8996e46da',
      el: 'livefyre',
      collectionMeta: 'eyJ0eXAiOiJKV1QiLCJhbGciOiJIUzUxMiJ9.eyJ1cmwiOiJodHRwczpcL1wvd3d3Lm1lcmlkaWFuc3Rhci5jb21cL25ld3NcL2xvY2FsX25ld3NcL21lcmlkaWFuLW1hc3Rlci1wbGFuLWFyY2hpdGVjdC1wcmVzZW50cy1maW5hbC12aXNpb24tZm9yLWRvd250b3duLW5vXC9hcnRpY2xlXzI2MjdmZWZmLTFkODktNTI1OS1iZWIzLTM2Zjg5OTZlNDZkYS5odG1sIiwidGFncyI6ImJvYiBsdWtlLGRvd250b3duLGNvbW1lcmNlLGVjb25vbWljcyx2aXNpb24sY2l0eSBjb3VuY2lsLGdlb3JnZSB0aG9tYXMsZmFubmllIGpvaG5zb24sY29zdCxjb3VuY2lsIG1lbWJlciIsInRpdGxlIjoiTWVyaWRpYW4gTWFzdGVyIFBsYW46IEFyY2hpdGVjdCBwcmVzZW50cyBmaW5hbCB2aXNpb24gZm9yIGRvd250b3duOyBObyBlc3RpbWF0ZXMgb24gY29zdCwgaW1wYWN0IiwiYXJ0aWNsZUlkIjoiMjYyN2ZlZmYtMWQ4OS01MjU5LWJlYjMtMzZmODk5NmU0NmRhIn0.hQbAvsn90IhoK8K-sCIIMW9oZCvw55eIhkaMkkAuCoDfq09vTYgMZq85BPMF6pAy4M83HXap1_I9ajIgGXI48Q',
      checksum: 'e60dbf50751067fdaaded4f8b5587221'
    };
   
    Livefyre.require([
      'fyre.conv#3', 
      'auth'], 
      function (Conv, auth) {
    new Conv(networkConfig, [convConfig], function (commentsWidget) {}());
    });
    </script>

    <div id="livefyre">
    </div>



<!-- Article Calendar -->
<div class="row">
<div class="col-lg-6 col-md-12" style="margin-bottom:20px;text-align:center">
<div data-cswidget="1488"> </div>
    <script type="text/javascript" async defer src="//cdn.cityspark.com/wid/get.js"> </script>
</div>
<div class="col-lg-6 col-md-12" style="margin-bottom:20px;text-align:center">
    <!-- mediumRectangle btf2 -->
    <div id='mediumRectangle_btf2_flex'>
    <script type='text/javascript'>
    googletag.cmd.push(function() { googletag.display('mediumRectangle_btf2_flex'); });
    </script>
    </div>
</div>
</div>



                    

                    

                    

                    <div id="tncms-region-article_bottom" class="tncms-region hidden-print"></div>

                    <div class="asset-comments hidden-print"></div></div>
            </div>

            

            </div>
        </div><div class="main-sidebar col-lg-4 col-md-5 hidden-print">
                <div class="main-sidebar-wrap">
                    <div id="tncms-region-article_side_top" class="tncms-region hidden-print"></div>  

<div class="row">
    <div class="col-md-12"><div id="tncms-region-option-rail-top-one" class="tncms-region "><div id="tncms-block-1560761" class="tncms-block hidden-xs"><!-- mediumRectangle atf -->
        <div id='mediumRectangle_atf' style="text-align:center">
        <script type='text/javascript'>
        AdBridg.cmd.push(function() { AdBridg.display('mediumRectangle_atf'); });
        </script>
        </div>
<div class="clear" style="padding-bottom:10px"></div></div><div id="tncms-block-1562846" class="tncms-block visible-xs"><!-- Mobile Rectangle ATF 300x250 Section-->



</div><div id="tncms-block-1562850" class="tncms-block">


<a href="/coupondeals" type="button" class="btn btn-default btn-lg side-bar-block-title" style="width:100%;margin-bottom:5px;border-color:#999999;border-radius:5px;color:#993133">COUPON DEALS</a>




<div class="panel panel-default" style="background-color:#eeeeee;border-radius:5px !important;box-shadow: 0px 0px 0px rgba(0,0,0,0);overflow:hidden">
    <div style="width:100%;text-align:center;padding-top:5px;">

        <a href="http://newspaperads.meridianstar.com"" class="side-bar-block-title" style="color:#033265;font-size: 18px;font-weight: bold;">NEWSPAPER ADS</a>


    </div>



    <div style="margin-top:5px; padding-left:10px; width:100%;margin-top:10px;margin-bottom:10px;height:125px !important">
        <script src="https://d1gzrgn7m19oq9.cloudfront.net/widget/retailadvertiser?hostname=newspaperads.meridianstar.com">
        </script>
    </div>
    
    
    
</div>
</div><div id="tncms-block-1562851" class="tncms-block"><!-- wishabi widget -->
<div class="block-title title-1303790 ">
        <div class="block-title-inner ">
            <h4 class="text-muted block-title-inner">
                This Week's Circulars
            </h4>
        </div>
    </div>
<div style="margin-top:10px !important">
<div id="circularhub_module_15592"></div>
<script src="//api.circularhub.com/15592/18e2ba61244fbc50/circularhub_module.js"></script>
</div></div><div id="tncms-block-1640630" class="tncms-block"><div style="width:100%;text-align:center">
<a href="https://www.meridianstar.com/podcasts" target="_blank">
<img src="https://static.cnhionline.com/meridianstar/ms-podcast-edt.jpg"></a>
</div></div><div id="tncms-block-1188144" class="tncms-block"><div style="width:100%;text-align:center">
<a href="http://www.goldenappleawards.com/" target="_blank">
<img src="https://static.cnhionline.com/meridianstar/GoldenApple_NOM-2017.jpg"></a>
</div></div><div id="tncms-block-1645618" class="tncms-block cnhi-obits-title"><section id="block-1645618" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-1645618 ">
        <div class="block-title-inner">
            <h4>
                
                Obituaries
                
            </h4>
        </div>
    </div></div>
    
    <div class="card-img-sm card-compact">
        
                
                <article id="card-summary-1645618-fa41fc4f-4274-5abe-9232-0daf8d304c26" class="clearfix card summary inherit  tnt-section-obituaries">
            <div class="card-container">
                
                <div class="card-body"><div class="card-headline"><h4 class="tnt-headline ">
        
             <a href="http://obituaries.meridianstar.com/obituary/john-williams-1075875040" class="tnt-asset-link">
        

        
            WILLIAMS, John</a></h4></div>
                    
                    
                    
                    
                        
                        
                            <div class="card-lead">
                                <p class="tnt-summary">QUITMAN - Funeral Services for John David Williams will be held July 25, 2019, at 10 a.m., at Wright's Funeral Home Chapel in Quitman, with the Rev. Doug Goodman officiating. Burial will follow at Oak Grove United Methodist Church Cemetery at 6884 Valley Road, Meridian. Mr. Williams, 76, pas&hellip;</p>
                            </div>
                        
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
            
                
                <article id="card-summary-1645618-85bef38b-4a24-57e1-9af9-57b486079a4b" class="clearfix card summary inherit  tnt-section-obituaries">
            <div class="card-container">
                
                <div class="card-body"><div class="card-headline"><h4 class="tnt-headline ">
        
             <a href="http://obituaries.meridianstar.com/obituary/jonnie-hill-1075875164" class="tnt-asset-link">
        

        
            Jonnie Hill</a></h4></div>
                    
                    
                    
                    
                        
                        
                            <div class="card-lead">
                                <p class="tnt-summary">Arrangements were incomplete at Berry and Gardner Funeral Home for Mrs. Jonnie Hill, 70, of Meridian, who died Tuesday, July 23, 2019, in Meridian. </p>
                            </div>
                        
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
            
                
                <article id="card-summary-1645618-b19b5ebf-e95e-5aed-8eed-3afd615d0b0b" class="clearfix card summary inherit  tnt-section-obituaries">
            <div class="card-container">
                
                <div class="card-body"><div class="card-headline"><h4 class="tnt-headline ">
        
             <a href="http://obituaries.meridianstar.com/obituary/mary-anderson-1075875192" class="tnt-asset-link">
        

        
            Mary Anderson</a></h4></div>
                    
                    
                    
                    
                        
                        
                            <div class="card-lead">
                                <p class="tnt-summary">Arrangements were incomplete at Berry and Gardner Funeral Home for Ms. Mary Ann Anderson, 52, of Pachuta, who died Sunday, July 21, 2019, at her residence. </p>
                            </div>
                        
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
            
                
                <article id="card-summary-1645618-c72b3077-addd-535c-b605-86b3964f74dd" class="clearfix card summary inherit  tnt-section-obituaries">
            <div class="card-container">
                
                <div class="card-body"><div class="card-headline"><h4 class="tnt-headline ">
        
             <a href="http://obituaries.meridianstar.com/obituary/james-amison-1075875198" class="tnt-asset-link">
        

        
            James Amison</a></h4></div>
                    
                    
                    
                    
                        
                        
                            <div class="card-lead">
                                <p class="tnt-summary">Memorial Service: Wednesday, July 24, 2019, at 3 p.m., at Berry and Gardner's Chapel. Burial: Monday, July 29, at the Veterans Cemetery, Newton. Mr. Amison, 62, of San Jose, Calif., died Monday, June 24, at his residence. </p>
                            </div>
                        
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
            
                
                <article id="card-summary-1645618-1f81f8f7-7c46-52f1-ac81-be16894adaae" class="clearfix card summary inherit  tnt-section-obituaries">
            <div class="card-container">
                
                <div class="card-body"><div class="card-headline"><h4 class="tnt-headline ">
        
             <a href="http://obituaries.meridianstar.com/obituary/stella-harvell-1075875207" class="tnt-asset-link">
        

        
            Stella  Harvell</a></h4></div>
                    
                    
                    
                    
                        
                        
                            <div class="card-lead">
                                <p class="tnt-summary">YORK [ndash] Graveside services for Stella Harvell, 91, of York, Ala., will be Wednesday, July 24, 2019, at 11 a.m., at the York City Cemetery. Arrangements by Bumpers Funeral Home of York. Visit bumpersfuneralhome.com. </p>
                            </div>
                        
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
            </div></section></div><div id="tncms-block-1560697" class="tncms-block"><section id="block-1560697" class="block emphasis-h3   " ><div class="clearfix">
    
    <div class="block-title title-1560697 ">
        <div class="block-title-inner">
            <h3>
                
                Most Popular
                
            </h3>
        </div>
    </div></div><div class="most-popular">
    <ul class="nav nav-tabs nav-tabs-popular">
        
            <li class="active">
                <a href="#articles-1560697" data-toggle="tab"><i class="far tnt-file-alt" title="Articles"></i><span class="tab-text"> Articles</span></a>
            </li>
        
        
            <li >
                <a href="#images-1560697" data-toggle="tab"><i class="far tnt-image" title="images"></i><span class="tab-text"> Images</span></a>
            </li>
        
        
            <li >
                <a href="#videos-1560697" data-toggle="tab"><i class="fas tnt-play-circle" title="Videos"></i><span class="tab-text"> Videos</span></a>
            </li>
        
        
        
        
            <li >
                <a href="#commented-1560697" data-toggle="tab"><i class="far tnt-comments" title="Commented"></i><span class="tab-text"> Commented</span></a>
            </li>
        
    </ul>
    <div class="tab-content">
        
            <div id="articles-1560697" class="tab-pane tab-pane-articles fade in active">
                <h4 class="tab-content-heading">Articles</h4><ul class="tab-content-list bullet-disc "><li><a href="/news/local_news/amtrak-train-kills-meridian-residents-in-collision-with-vehicle-near/article_a76d0312-acb6-11e9-a1b5-83f78e329327.html">Amtrak train kills 2 Meridian residents in collision with vehicle near Meridian</a></li><li><a href="/news/lauderdale-county-authorities-investigate-early-morning-shooting/article_bcddb020-a97d-11e9-965b-bbee6c149afd.html">Lauderdale County authorities investigate early morning shooting</a></li><li><a href="/news/local_news/suspect-in-two-meridian-murders-arrested/article_1ace5532-f940-5da9-8b0f-587bd80f112e.html">Suspect in two Meridian murders arrested</a></li><li><a href="/news/local_news/meridian-natives-plan-health-fair-saturday/article_46677d87-2481-52c5-9eb4-0c66d4437b7e.html">Meridian natives plan health fair Saturday</a></li><li><a href="/community/education/tracy-henshaw-jackson-brings-her-love-of-learning-to-parkview/article_1fe60346-da3f-52b8-9f45-07d7b68ae6a8.html">Tracy Henshaw-Jackson brings her love of learning to Parkview in Meridian</a></li><li><a href="/news/nation_and_world/ex-giants-offensive-lineman-mitch-petrus-dies-of-heat-stroke/article_52b0a41d-0882-58a7-8606-f49e412af1e5.html">Ex-Giants offensive lineman Mitch Petrus dies of heat stroke</a></li><li><a href="/news/local_news/meridian-master-plan-architect-presents-final-vision-for-downtown-no/article_2627feff-1d89-5259-beb3-36f8996e46da.html">Meridian Master Plan: Architect presents final vision for downtown; No estimates on cost, impact</a></li><li><a href="/sports/meridian-alumnus-davis-named-preseason-all-sec/article_bd42cb36-aa6d-11e9-82e1-c70e86dfddec.html">Meridian alumnus Davis named Preseason All-SEC</a></li><li><a href="/news/security-cameras-to-go-up-at-highland-park-bonita-lakes/article_3559b762-a823-11e9-bfe8-bf011b41b64e.html">Security cameras to go up at Highland Park, Bonita Lakes and Northeast Park in Meridian</a></li><li><a href="/community/education/mcc-appoints-leia-hill-to-lead-mcc-foundation/article_3afafb80-d699-5ac9-86a9-57642e296f36.html">MCC appoints Leia Hill to lead MCC Foundation</a></li></ul></div>
        
        
            <div id="images-1560697" class="tab-pane tab-pane-images fade in ">
                <h4 class="tab-content-heading">Images</h4><ul class="tab-content-list">
                            <li><figure class="photo layout-square">
            <div class="image" 
                >
                
                    <a href="/van-goodman/image_1ed063d6-a3c7-509b-9401-546f2091c7ef.html" class="tnt-asset-link">
                
                
                
                
        
                    <img
                        src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                        alt="Van Goodman"
                        class="img-responsive lazyload full"
                        width="480"
                        height="480"
                        data-sizes="auto"
                        data-srcset="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/1/ed/1ed063d6-a3c7-509b-9401-546f2091c7ef/5d17959e43f50.image.jpg?crop=480%2C480%2C0%2C59&resize=100%2C100&order=crop%2Cresize 100w" />
                </a>
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square">
            <div class="image" 
                >
                
                    <a href="/cornelius-parks/image_879a498e-fb6f-5e4e-ad71-e77823a21739.html" class="tnt-asset-link">
                
                
                
                
        
                    <img
                        src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                        alt="Cornelius Parks"
                        class="img-responsive lazyload full"
                        width="459"
                        height="459"
                        data-sizes="auto"
                        data-srcset="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/8/79/879a498e-fb6f-5e4e-ad71-e77823a21739/5d1795a005a47.image.jpg?crop=459%2C459%2C0%2C70&resize=100%2C100&order=crop%2Cresize 100w" />
                </a>
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square">
            <div class="image" 
                >
                
                    <a href="/region/years-after-fire-a-comeback-for-hubig-s-pies/image_82124bec-6676-5ea1-a152-a4182b220450.html" class="tnt-asset-link">
                
                
                
                
        
                    <img
                        src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                        alt="7 years after fire, a comeback for Hubig's Pies"
                        class="img-responsive lazyload ap-photo full"
                        width="1198"
                        height="1198"
                        data-sizes="auto"
                        data-srcset="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/8/21/82124bec-6676-5ea1-a152-a4182b220450/5d309f5a1f78d.image.jpg?crop=1198%2C1198%2C266%2C0&resize=100%2C100&order=crop%2Cresize 100w" />
                </a>
            </div>
            
        </figure></li>
                        </ul></div>
        
        <div id="videos-1560697" class="tab-pane tab-pane-videos fade in ">
                <h4 class="tab-content-heading">Videos</h4><ul class="tab-content-list">
                            <li><figure class="photo layout-square">
            <div class="image" 
                >
                
                    <a href="/multimedia/video-lt-gov-tate-reeves-outlines-workforce-training-plan-at/video_57bd5bbb-2aee-5f1b-8513-d754db6e9669.html" class="tnt-asset-link">
                
                
                
                
        
                    <img
                        src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                        alt="VIDEO: Lt. Gov. Tate Reeves outlines workforce training plan at MCC Workforce Development Center"
                        class="img-responsive lazyload full"
                        width="360"
                        height="360"
                        data-sizes="auto"
                        data-srcset="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/5/7b/57bd5bbb-2aee-5f1b-8513-d754db6e9669/5d35de312baef.image.jpg?crop=360%2C360%2C140%2C0&resize=100%2C100&order=crop%2Cresize 100w" />
                </a>
            </div>
            
        </figure></li>
                        </ul></div>
        
        
        
        
            <div id="commented-1560697" class="tab-pane tab-pane-commented fade in ">
                <h4 class="tab-content-heading">Commented</h4><p class="no-results text-muted">Sorry, there are no recent results for popular commented articles.</p></div>
        
    </div>
</div></section></div></div></div>
</div>

<div class="row">
    <div class="col-md-12"><div id="tncms-region-option-rail-top-two" class="tncms-region "><div id="tncms-block-1562849" class="tncms-block"><!-- 120x60 house ads -->
<div style="width:100%;">
    <!-- button btf1-->
    <div id='button_btf1' style="float:left;margin:10px;">
        <script type='text/javascript'>
        AdBridg.cmd.push(function() { AdBridg.display('button_btf1'); });
        </script>
    </div>
    <!-- button btf2-->
    <div id='button_btf2' style="float:right;margin:10px;">
        <script type='text/javascript'>
        AdBridg.cmd.push(function() { AdBridg.display('button_btf2'); });
        </script>
    </div>
</div></div></div></div>
</div>

<div class="row">
    <div class="col-md-12"><div id="tncms-region-option-rail-top-three" class="tncms-region "></div></div>
</div>

<div class="row">
    <div class="col-md-12"><div id="tncms-region-option-rail-top-four" class="tncms-region "></div></div>
</div>

<div id="tncms-region-asset_side_top" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-primary" class="tncms-region "><div id="tncms-block-1623591" class="tncms-block"><!-- Mobile 300x250 between obits and most pop -->

<div id="mobileBanner_obits_pop" style="width:100%;text-align:center" class="visible-xs visible-sm">
<script type='text/javascript'>
AdBridg.cmd.push(function() { AdBridg.display('mobileBanner_obits_pop'); });
</script>
</div>
<div class="clear" style="padding-bottom:10px"></div>
</div><div id="tncms-block-1562838" class="tncms-block hidden-xs"><!-- mediumRectangle_btf1 flex right rail -->


        <div id='mediumRectangle_btf1' style="text-align:center">
        <script type='text/javascript'>
        AdBridg.cmd.push(function() { AdBridg.display('mediumRectangle_btf1'); });
        </script>
        </div>
<div class="clear" style="padding-bottom:10px"></div>
</div><div id="tncms-block-1623589" class="tncms-block"><!-- Mobile article 300x250 under Monster block -->

<div id="mobileBanner_article_monster" style="width:100%;text-align:center" class="visible-xs visible-sm">
<script type='text/javascript'>
AdBridg.cmd.push(function() { AdBridg.display('mobileBanner_article_monster'); });
</script>
</div>
<div class="clear" style="padding-bottom:10px"></div>
</div><div id="tncms-block-1562836" class="tncms-block"><script type="text/javascript">var monsterJsrWidget = {"layout":{"height":"300px","displayJobDesc":false},"id":"monster_cms_iframe_np","disablePastSearch":true,"searchParams":{"ch":"NEWSMMS","rows":10}};</script>
<script type="text/javascript" src="https://jobswidget-local-jobs.monster.com/GetResource?name=jsrwidgetmin&fileType=js&custhandler=jsrwidget&lcl=content"></script></div><div id="tncms-block-1562870" class="tncms-block hidden-xs"><!-- mediumRectangle_btf3_flex Section -->



</div></div>  

<div class="row">
    <div class="col-md-12"><div id="tncms-region-option-rail-middle-one" class="tncms-region "><div id="tncms-block-1562833" class="tncms-block">
<!-- mediumRectangle_btf2_flex redesign -->


</div></div></div>
</div>

<div class="row">
    <div class="col-md-12"><div id="tncms-region-option-rail-middle-two" class="tncms-region "></div></div>
</div>

<div class="row">
    <div class="col-md-12"><div id="tncms-region-option-rail-middle-three" class="tncms-region "></div></div>
</div>

<div class="row">
    <div class="col-md-12"><div id="tncms-region-option-rail-middle-four" class="tncms-region "></div></div>
</div>

<div id="tncms-region-asset_side_middle" class="tncms-region hidden-print"></div><div id="tncms-region-article_side_middle" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-secondary" class="tncms-region hidden-print"></div>  

<div class="row">
    <div class="col-md-12"><div id="tncms-region-option-rail-bottom-one" class="tncms-region "></div></div>
</div>

<div class="row">
    <div class="col-md-12"><div id="tncms-region-option-rail-bottom-two" class="tncms-region "></div></div>
</div>

<div class="row">
    <div class="col-md-12"><div id="tncms-region-option-rail-bottom-three" class="tncms-region "></div></div>
</div>

<div class="row">
    <div class="col-md-12"><div id="tncms-region-option-rail-bottom-four" class="tncms-region "></div></div>
</div>

<div id="tncms-region-asset_side_bottom" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-tertiary" class="tncms-region "></div><div id="tncms-region-article_side_bottom" class="tncms-region hidden-print"></div>
                <div id="sticky-right-rail-spacer">
                    <div id="sticky-right-rail"><div id="tncms-region-global-side-sticky" class="tncms-region hidden-print"></div><div id="tncms-region-asset_side_sticky" class="tncms-region hidden-print"><div id="tncms-block-1562868" class="tncms-block hidden-xs"><!-- mediumRectangle_btf3_flex -->
        <div id='mediumRectangle_btf3_flex' style="text-align:center">
        <script type='text/javascript'>
        AdBridg.cmd.push(function() { AdBridg.display('mediumRectangle_btf3_flex'); });
        </script>
        </div>
<div class="clear" style="padding-bottom:10px"></div></div></div></div>
                </div>
                </div>
            </div></div>
</article>



        <div class="row">
            <div class="col-md-12"><div id="tncms-region-global-container-bottom" class="tncms-region "><div id="tncms-block-1560690" class="tncms-block hidden-xs"><!-- leaderboard btf -->

<div class="clear" style="padding-top:10px"></div>
        <div id='leaderboard_btf' style="width:100%;text-align:center">
        <script type='text/javascript'>
        AdBridg.cmd.push(function() { AdBridg.display('leaderboard_btf'); });
        </script>
        </div>
<div class="clear" style="padding-bottom:10px"></div>
</div></div></div>
        </div></section>
    <section id="main-bottom-container" class="container-fullscreen-region container-fluid">
        <div class="fullscreen-region"><div id="tncms-region-global-container-bottom-fullscreen" class="tncms-region "></div></div>
    </section><!-- / main-body-container -->
    </div>
    <div id="site-footer-container" class="hidden-print">
         
            <div class="container">
                <div id="asset-container-bottom" class="col-md-12">
                    <div id="tncms-region-asset_container_bottom" class="tncms-region hidden-print"></div> 
                </div>
            </div>
        

        
            <footer id="site-footer" class="container well-main">
                  
<!-- code here -->  

                <div id="tncms-region-footer-top-col-full" class="tncms-region "><div id="tncms-block-1560670" class="tncms-block"><div style="font-family:times;font-style:italic;margin-bottom:20px" class="fa-block">
<p style="font-size:18px"><span style="font-weight:bold">First Amendment:</span> Congress shall make no law respecting an establishment of religion, or prohibiting the free exercise thereof; or abridging the freedom of speech, or of the press; or the right of the people peaceably to assemble, and to petition the Government for a redress of grievances.</p>
</div></div></div>
                <div class="row">
                    <div id="footer-col-one" class="col-md-4 col-sm-4">
        <div id="tncms-region-footer-col-one" class="tncms-region "><div id="tncms-block-1560666" class="tncms-block"><section id="block-1560666" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-1560666 ">
        <div class="block-title-inner">
            <h4>
                
                Contact Information
                
            </h4>
        </div>
    </div></div><address>
    <strong>meridianstar.com</strong><br>
    814 22nd Avenue<br>
    Meridian, MS 39302
    <br>
    
        <strong>Phone:</strong> 601-693-1551<br>
        <strong>Email:</strong> <a href="mailto:webmaster@themeridianstar.com">webmaster@themeridianstar.com</a><br>
    
</address></section></div><div id="tncms-block-1560665" class="tncms-block"><section id="block-1560665" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-1560665 ">
        <div class="block-title-inner">
            <h4>
                
                Services
                
            </h4>
        </div>
    </div></div></section></div></div>
        <div id="tncms-region-nav-footer-col-two-nav" class="tncms-region-nav"><ul id="footer-col-two-nav_menu" class="bullet-nav nav-list"><li>
                <a class="nav-link  tnt-section-about-us"  href="/site/about-us.html" >
                    <span class="nav-label">About Us</span>
                </a></li><li>
                <a class="nav-link  tnt-section-contact-us"  href="/site/contact-us.html" >
                    <span class="nav-label">Contact Us</span>
                </a></li><li>
                <a class="nav-link  tnt-section-advertise-with-us"  href="/site/advertise-with-us.html" >
                    <span class="nav-label">Advertise with Us</span>
                </a></li><li>
                <a class="nav-link  tnt-section-subscriber-services"  href="/subscriber-services/" >
                    <span class="nav-label">Subscriber Services</span>
                </a></li><li>
                <a class="nav-link  tnt-section-submission-forms"  href="/site/forms/" >
                    <span class="nav-label">Submission Forms</span>
                </a></li><li>
                <a class="nav-link  tnt-section-advertiser-index"  href="https://shop.cnhi.com/adindex/meridianstar.html"  target="_blank" rel="noopener">
                    <span class="nav-label">Advertiser Index</span>
                </a></li></ul></div>
    </div>
    <div id="footer-col-two" class="col-md-4 col-sm-4">
    <div id="tncms-region-footer-col-left" class="tncms-region "><div id="tncms-block-1560664" class="tncms-block"><section id="block-1560664" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-1560664 ">
        <div class="block-title-inner">
            <h4>
                
                Sections
                
            </h4>
        </div>
    </div></div></section></div></div>
    <div id="tncms-region-nav-footer-col-one-nav" class="tncms-region-nav"><ul id="footer-col-one-nav_menu" class="bullet-nav nav-list"><li>
                <a class="nav-link nav-home  tnt-section-home"  href="/" >
                    <span class="nav-icon fas tnt-home tnt-fw"></span> <span class="nav-label">Home</span>
                </a></li><li>
                <a class="nav-link  tnt-section-news"  href="/news/" >
                    <span class="nav-label">News</span>
                </a></li><li>
                <a class="nav-link  tnt-section-sports"  href="/sports/" >
                    <span class="nav-label">Sports</span>
                </a></li><li>
                <a class="nav-link  tnt-section-community"  href="/community/" >
                    <span class="nav-label">Community</span>
                </a></li><li>
                <a class="nav-link  tnt-section-opinion"  href="/opinion/" >
                    <span class="nav-label">Opinion</span>
                </a></li><li>
                <a class="nav-link  tnt-section-obituaries"  href="/obituaries/" >
                    <span class="nav-label">Obituaries</span>
                </a></li><li>
                <a class="nav-link  tnt-section-photos"  href="/gallery/" >
                    <span class="nav-label">Photos</span>
                </a></li><li>
                <a class="nav-link  tnt-section-video-gallery"  href="/multimedia/videos/" >
                    <span class="nav-label">Video Gallery</span>
                </a></li><li>
                <a class="nav-link  tnt-section-weather"  href="/weather/" >
                    <span class="nav-label">Weather</span>
                </a></li></ul></div>
     <div id="tncms-region-footer-col-two" class="tncms-region "><div id="tncms-block-1562866" class="tncms-block padding-bottom"><section id="block-1562866" class="block emphasis-h3   " ><div class="block"><a href="/" rel="nofollow" ><img 
            
            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
            data-srcset="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/custom/image/9d5f3f66-4984-11e8-80af-bbf49248abbc.png?resize=200%2C32 200w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/custom/image/9d5f3f66-4984-11e8-80af-bbf49248abbc.png?resize=300%2C49 300w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/custom/image/9d5f3f66-4984-11e8-80af-bbf49248abbc.png?resize=400%2C65 400w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/custom/image/9d5f3f66-4984-11e8-80af-bbf49248abbc.png?resize=540%2C87 540w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/custom/image/9d5f3f66-4984-11e8-80af-bbf49248abbc.png?resize=750%2C121 750w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/custom/image/9d5f3f66-4984-11e8-80af-bbf49248abbc.png 1200w" 
            data-sizes="auto" 
            class=" img-responsive lazyload tnt-prop-img"
            alt=""></a></div></section></div></div>
        
    </div>
    <div id="footer-col-three" class="col-md-4 col-sm-4">
        <div id="tncms-region-footer-col-three" class="tncms-region "><div id="tncms-block-1560667" class="tncms-block">
<div style="width:100%;text-align:center">
<a href="http://www.rtjgolf.com/" target="_blank"><img src="https://static.cnhionline.com/cnhi/images/rtj_ad.jpg" border="0" style="max-width:300px;" /></a>
</div>
</div></div>
        
    </div>
                </div>
                <div id="tncms-region-footer-bottom-col-full" class="tncms-region "></div>
                
<!-- DFP Floorboard Ad -->
<div id='floorboard'  style="position: fixed; z-index: 10001; width:100%; bottom:0; left:0; text-align:center;" class="hidden-xs hidden-sm">
<script type='text/javascript'>
AdBridg.cmd.push(function() { AdBridg.display('floorboard'); });
</script>
</div>
<!-- DFP New Wallpaper -->
<div id='div-gpt-ad-1409848272015-0' style='width:1px; height:1px;'>
<script type='text/javascript'>
AdBridg.cmd.push(function() { AdBridg.display('div-gpt-ad-1409848272015-0'); });
</script>
</div>
<!-- DFP New Wallpaper OOP -->
<div id='div-gpt-ad-1409848272015-0-oop'>
<script type='text/javascript'>
AdBridg.cmd.push(function() { AdBridg.display('div-gpt-ad-1409848272015-0-oop'); });
</script>
</div>
<!-- Mobile Banner BTF 300x50  -->
<div id="mobileBanner_btf_flex" style="padding:0px; background-color:#fff;position: fixed; z-index: 10001; width:100%; bottom:0; left:0; text-align:center" class="visible-xs visible-sm">
<script type='text/javascript'>
AdBridg.cmd.push(function() { AdBridg.display('mobileBanner_btf_flex'); });
</script>
</div>

            </footer>
        

        <div id="site-copyright-container" class="container">
            <div id="tncms-region-footer-copyright" class="tncms-region "><div id="tncms-block-1560669" class="tncms-block"><div id="site-copyright" class="row">
    <section id="block-1560669"><div class="col-md-7"><small>&copy; Copyright 2019 <a href="/">MeridianStar.com</a>, 814 22nd Avenue Meridian, MS</small><small>&nbsp;| <a href="/site/terms.html">Terms of Use</a></small><small>&nbsp;| <a href="/site/privacy.html">Privacy Policy</a></small></div>
        <div class="col-md-5"><small>Powered by <a href="https://bloxcms.com" title="BLOX Content Management System" target="_blank" rel="noopener">BLOX Content Management System</a> from <a href="https://townnews.com/" title="TownNews.com BLOX Newspaper Content Management" target="_blank" rel="noopener">TownNews.com</a>.</small></div>
    </section>
</div></div></div>
        </div>
    </div>
    
    
        </div><!-- / offcanvas close  -->
    

    
    
    <!-- / site-container close -->
    </div>
    
    
    <script>
window.__tnt || (window.__tnt = {});
__tnt.compatibility || (__tnt.compatibility = {});

__tnt.compatibility.status = "";
__tnt.compatibility.check = function(){
    var compatible = true;
    var status = "";

    if(typeof(__tnt.advertisements)=="undefined"){
        compatible = false;
        status += "FAIL: object 0 undefined "
    }

    __tnt.compatibility.status = status;
    return compatible;
}
__tnt.compatibility.notification = function(){
}

$(function(){
    if(!__tnt.compatibility.check()){
        if(window.ga){
            __tnt.trackEvent({'category':'subscription','action':'adblock','label':'adblock detected','value':'1'});
        }
        
        __tnt.compatibility.notification();
    }
});
</script>

    
    <script>
        jQuery(function() {
            if(typeof TNCMS.Tracking != 'undefined'){
                jQuery(TNCMS.Tracking.trackDeclarativeEvents);
            }
        });
    </script>
<script>
        __tnt.trackEvent = function(obj) {
            if( jQuery.type(obj) === 'object' ){
                 
                    if(obj.category && obj.action){
                        __tnt.googleEvent(obj);
                    } else if(obj.network && obj.socialAction){
                        __tnt.googleSocial(obj);
                    } else if(obj.url){
                        __tnt.googlePageView(obj);
                    }
                    if(typeof TNCMS.Tracking != 'undefined' && obj.metric){
                        TNCMS.Tracking.addEvent({
                            app: obj.app,
                            metric: obj.metric,
                            id: obj.uuid
                        });
                    }
                
            }
        }
        
        if(__tnt.trackEventLater.length > 0){
            jQuery(__tnt.trackEventLater).each(function(){
                __tnt.trackEvent($(this));
            });
        }
        jQuery('body').on(__tnt.client.clickEvent, '[data-track]', function(){
            var trkObj = jQuery(this).data('track');
            __tnt.trackEvent(trkObj);
        });
        jQuery('body').on(__tnt.client.clickEvent, '[data-tncms-track-event]', function(){
            var trkObj = jQuery(this).data('tncms-track-event');
            __tnt.trackEvent(trkObj);
        });
        jQuery('body').on(__tnt.client.clickEvent, '[data-tncms-track-dmp]', function(){
            var dmpData = jQuery(this).data('tncms-track-dmp');
            	_cc6893.add('act', dmpData);
	_cc6893.bcp();
});
    </script>
    
<script>/*<![CDATA[*/ 
                __tnt.googleEvent = function(obj) {
                    dataLayer.push({
                        'event': 'gaTriggerEvent',
                        'gaEventCategory': obj.category,
                        'gaEventAction': obj.action,
                        'gaEventLabel': obj.label,
                        'gaEventValue': obj.value
                    });
                    dataLayer.push({
                        'event': 'tncms.event.trigger',
                             'tncms.event.trigger.category': obj.category,
                             'tncms.event.trigger.action': obj.action,
                             'tncms.event.trigger.label': obj.label, 
                             'tncms.event.trigger.value': obj.value
                    });
                }
                __tnt.googleSocial = function(obj) {
                    dataLayer.push({
                        'event': 'socialEvent',
                        'socialNetwork': obj.network,
                        'socialAction': obj.socialAction,
                        'socialTarget': obj.url
                    });
                    
                    dataLayer.push({
                        'event': 'tncms.event.social',
                            'tncms.event.social.network': obj.network,
                            'tncms.event.social.action': obj.socialAction,
                            'tncms.event.social.target': obj.url
                    });
                }
                __tnt.googlePageView = function(obj) {
                    var sURL = obj.url.replace(/^.*\/\/[^\/]+/, '');
                    dataLayer.push({
                        'event': 'VirtualPageview',
                        'virtualPageURL': sURL,
                        'virtualPageTitle': obj.title
                    });
                    dataLayer.push({
                        'event': 'tncms.event.virtual_pageview',
                            'tncms.event.virtual_pageview.url': sURL,
                            'tncms.event.virtual_pageview.title': obj.title
                    });
                } /*]]>*/</script>
<script>/*<![CDATA[*/ !function(t,i,n){var e,a,s,o,c,d={init:function(){a=i.getElementById("site-navbar-container"),n.client.platform.ios?a.classList.add("affix-sticky"):(e=i.getElementById("main-body-container"),s=a.offsetHeight||a.clientHeight,o=!1,c=0,t.addEventListener("scroll",d.navPosition,!1),t.addEventListener("mousewheel",d.navPosition,!1))},navPosition:function(){o||(o=!0,setTimeout(function(){var n=a.getBoundingClientRect(),d=t.pageYOffset||i.documentElement.scrollTop,f=n.top+d;d>=f&&d>c?a.classList.contains("affix")||(c=f,a.classList.add("affix"),a.classList.remove("affix-top"),e.style.marginTop=s+"px"):a.classList.contains("affix-top")||(a.classList.remove("affix"),a.classList.add("affix-top"),e.style.marginTop="0px"),o=!1},25))}};"loading"==i.readyState?i.addEventListener("DOMContentLoaded",d.init,!1):d.init()}(window,document,__tnt); /*]]>*/</script>
<script src="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/owl.carousel.min.a23229b8d8ee5f1919a5a9663946b1f7.js"></script>
<script>/*<![CDATA[*/ jQuery(document).ready(function($){
                var gallery_ad_2627feff_1d89_5259_beb3_36f8996e46da_photo_modal = false;
                var gallery_changed_2627feff_1d89_5259_beb3_36f8996e46da_photo_modal = false;
                $('#gallery-items-2627feff-1d89-5259-beb3-36f8996e46da-photo-modal').owlCarousel({
                    items: 1,
                    autoHeight: true,
                    lazyLoad: true,
                    loop: false,
                    navRewind: true,
                    responsiveRefreshRate: 500,
                    
                    
                    dots : false,
                    
                    onTranslated:function(){
                        
                        
                        
                            __tnt.trackEvent($('#gallery-items-2627feff-1d89-5259-beb3-36f8996e46da-photo-modal .photo-container').eq(this._current).data('track-object'));
                        

                        
                        

                        

                    }
                });
                
                var owl = $('#gallery-items-2627feff-1d89-5259-beb3-36f8996e46da-photo-modal');
                owl.on('changed.owl.carousel', function(event) {if( !$('#gallery-items-2627feff-1d89-5259-beb3-36f8996e46da-photo-modal .photo-container').eq(event.item.index).hasClass('engagement-stage') ){
                        setTimeout(function(){
                            $("#gallery-items-2627feff-1d89-5259-beb3-36f8996e46da-photo-modal .owl-stage-outer").height( $('#carousel-2627feff-1d89-5259-beb3-36f8996e46da-photo-modal .owl-item.active').height() );
                        }, 300);
                    }
                 
                 
                        

                        
                            var currItem = $('#gallery-items-2627feff-1d89-5259-beb3-36f8996e46da-photo-modal .photo-container').eq(event.item.index).data('count');
                            if(currItem){
                                $('#carousel-2627feff-1d89-5259-beb3-36f8996e46da-photo-modal .current-count').html(currItem);
                            }
                            $('.modal.in, #carousel-2627feff-1d89-5259-beb3-36f8996e46da-photo-modal .item').removeClass('hover');
                        
                        
                });
                
                var photo_carousel_2627feff_1d89_5259_beb3_36f8996e46da_photo_modal = $('#gallery-items-2627feff-1d89-5259-beb3-36f8996e46da-photo-modal').data('owlCarousel');
                $('#carousel-2627feff-1d89-5259-beb3-36f8996e46da-photo-modal .photo-carousel-control.left').on(__tnt.client.clickEvent, function(e){
                    photo_carousel_2627feff_1d89_5259_beb3_36f8996e46da_photo_modal.prev();
                });
                $('#carousel-2627feff-1d89-5259-beb3-36f8996e46da-photo-modal .photo-carousel-control.right').on(__tnt.client.clickEvent, function(e){
                    photo_carousel_2627feff_1d89_5259_beb3_36f8996e46da_photo_modal.next();
                });
            }); /*]]>*/</script>
<script>/*<![CDATA[*/ 
                // open photo modal
                jQuery(document).ready(function($){
                    $('[data-photo-target]').on('click', function(e){
                        e.preventDefault();
                        var item_target = $(this).data('target');
                        // get item index
                        var item_index = $(item_target +' '+$(this).data('photo-target')).parent().index();
                        // get current instance of carousel
                        var carousel_instance = $(this).data('instance');
                        var carousel_instance_data = $(carousel_instance).data('owlCarousel');
                        // fix non explict widths at viewports less than 900.
                        if(carousel_instance_data.width() < 320 & carousel_instance_data.viewport() < 900){
                            carousel_instance_data.onThrottledResize();
                        }
                        // load item from index
                        carousel_instance_data.to(item_index, 100, true);
                        // open modal
                        $(item_target).modal({'show':true});
                        __tnt.trackEvent({'category':'tnt-lightbox','action':'carousel-open', 'label':'article', 'value':'1'});
                        return false;
                    });
                    $('.photo-carousel-caption-toggle').on(__tnt.client.clickEvent, function(e){
                        var item_instance = $(this).data('instance');
                        $(item_instance +' .photo-carousel-caption-toggle').find('[data-fa-i2svg]').attr('data-icon', $(item_instance +' .photo-carousel-caption-toggle').find('[data-fa-i2svg]').attr('data-icon') == 'minus-circle' ? 'plus-circle' : 'minus-circle');
                    });
                }); /*]]>*/</script>
<script>/*<![CDATA[*/ 
                        function dmpReactionData(){
                            var sReactionData = document.getElementById('hidden-type').value,
                                sReactionKeywords = "'Engage:Bob Luke','Engage:Downtown','Engage:Commerce','Engage:Economics','Engage:Vision','Engage:City Council','Engage:George Thomas','Engage:Fannie Johnson','Engage:Cost','Engage:Council Member'";	_cc6893.add('act', sReactionData, sReactionKeywords);
	_cc6893.bcp();
} /*]]>*/</script>
<script src="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/sticky-kit.5a0c90e6428107d0ebeb1959859217d1.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.regions.0f10872137baa3012000e3d8133cdbbd.js"></script>
<script>/*<![CDATA[*/ (function($){
                    $(window).load(function(){
                        __tnt.regions.stickySide.init($('#sticky-right-rail'), $('#sticky-right-rail-spacer'), 'siderail', '.row');
                    });
                })(jQuery); /*]]>*/</script>
<script>/*<![CDATA[*/ 
            if (window.location.hash){
                var hashSet = ['tncms_source','utm_source','utm_campaign','utm_medium','utm_content','utm_term'],
                    urlHash = window.location.hash.replace('#','').split('&');
                for (var i = 0; i < urlHash.length; i++) {
                    var data = urlHash[i].split('='),
                        param = data[0].replace('-','_');
                    if (hashSet.indexOf(param) != -1){
                        var dmpData = param + ': ' + data[1];
                        	_cc6893.add('act', dmpData);
	_cc6893.bcp();

                    }
                }
            }
         /*]]>*/</script></body>
</html>