
  






  
  
  
  
  
  
  
  
  
  



  



  



<!DOCTYPE html>
        <html lang="en">
        <head>
<base href="https://www.meridianstar.com/content/tncms/live/" />
<meta name="tncms-access-version" content="" />
<meta name="keywords" content="steakhouse, steak, food, catering, restaurant, diamond jim's, wrap, salad bar, fillet" />
<meta name="news_keywords" content="steakhouse, steak, food, catering, restaurant, diamond jim's, wrap, salad bar, fillet" />
<meta name="description" content="Local steak lovers will no longer have to travel to Alabama as a popular Livingston restaurant is expanding to Meridian." />
<meta name="author" content="D'Courtland Christian dchristian@themeridianstar.com" />
<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1, user-scalable=0, shrink-to-fit=no" />
<meta name="apple-mobile-web-app-capable" content="yes" />
<meta name="apple-mobile-web-app-status-bar-style" content="black-translucent" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.meridianstar.com/news/local_news/family-tradition-popular-steakhouse-expands-to-meridian/article_78352ec9-bf29-5878-a3df-8593459d9946.html" />
<meta property="og:image" content="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/2/df/2dfa7db8-3dbb-11ed-9d74-eb8dad246edb/6331d8388ebad.image.jpg?crop=1619%2C850%2C0%2C215&amp;resize=1200%2C630&amp;order=crop%2Cresize" />
<meta property="og:image:width" content="1200" />
<meta property="og:image:height" content="630" />
<meta property="og:title" content="FAMILY TRADITION: Popular steakhouse expands to Meridian" />
<meta property="og:description" content="Local steak lovers will no longer have to travel to Alabama as a popular Livingston restaurant is expanding to Meridian." />
<meta property="og:site_name" content="Meridian Star" />
<meta property="og:section" content="Local News" />
<meta property="fb:app_id" content="116012378495089" />
<meta property="article:publisher" content="https://www.facebook.com/meridianstar/" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@meridianstar" />
<meta name="twitter:image:alt" content="steak house 1" />
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/styles/bootstrap.min.c58a1beaa3640fa94c3db09673c4d95c.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/shared-content/art/tncms/templates/libraries/flex/components/themes/resources/styles/font-awesome.min.e5604f5bf47d3b8b5552d999180549d2.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/styles/layout.09e7f7119e41075ed44c163695847d91.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/shared-content/art/tncms/templates/libraries/flex/components/themes/resources/styles/theme-basic.6ee2c17f3ef34e32b5fa02524f5978e7.css"/>
<!--[if lt IE 9]><link rel="stylesheet" href="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/styles/ie.css"/><![endif]-->
<link rel="stylesheet" href="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/live/global/resources/styles/site.css?_dc=1503084367"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/shared-content/art/tncms/templates/libraries/flex/components/block/resources/styles/flex-card-promo-boxes.ed1a8e3c93ef8d80d23b903d016790fa.css"/>
<link rel="stylesheet" href="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/styles/owl.carousel.d631cca58a0d014854c4a6c1815f1da3.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/shared-content/art/tncms/templates/libraries/flex/components/block/resources/styles/flex-utility-promo-designer.a27bf5e332f0dd667184ad38b7bf1638.css"/>
<style>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</style>
<script type="text/javascript">(function(){var tnsrc=window.location.hash.match(/[&#]tncms-source=([^&]+)/);var dl = window.dataLayer = window.dataLayer || [];dl.push({"townnews":{"product":{"software":"BLOX","version":"1.63.2"},"crm":{"group_id":"13"}},"tncms":{"template":{"version":"3.155.0"},"page":{"grid":"centerpiece","style":"default","path":"\/news\/local_news","syndicated":"false","reaction":"true","app":"editorial","theme":"flex","skin":"flex-editorial","http_status":200},"subscription":{"required":"false"},"asset":{"type":"article","author":"D'Courtland Christian dchristian@themeridianstar.com","start_hour":"12","id":"78352ec9-bf29-5878-a3df-8593459d9946","app":"editorial","ga_page":"\/news\/local_news\/article_78352ec9-bf29-5878-a3df-8593459d9946.html"},"vendor":{"outbrain":"","taboola":""},"system":{"render_time":318},"client":{"is_bot":"no","is_gdpr":"no"}},"taxonomy_1":"news","taxonomy_2":"local_news","taxonomy_3":null,"taxonomy_4":null,"taxonomy_5":null,"blox_platform":"desktop","blox_page_type":"asset","blox_domain":"meridianstar.com","blox_skin":"flex-editorial","blox_application":"editorial","groups":{"content":"1","advertising":"2","utility":"3"},"content_group":"1","content_group_id":"news","blox_sections":"news,local_news","weather_temp":64,"weather_conditions":"Clear","asset_source":"local","blox_asset_type":"article","asset_section":"news\/local_news","asset_id":"78352ec9-bf29-5878-a3df-8593459d9946","asset_headline":"FAMILY TRADITION: Popular steakhouse expands to Meridian","asset_byline":"By D'Courtland Christian dchristian@themeridianstar.com","asset_pub_date":"09\/26\/2022","asset_pub_time":"12:01 pm","asset_canonical":"https:\/\/www.meridianstar.com\/news\/local_news\/family-tradition-popular-steakhouse-expands-to-meridian\/article_78352ec9-bf29-5878-a3df-8593459d9946.html","asset_tag_1":"steakhouse","asset_tag_2":"steak","asset_tag_3":"food","asset_tag_4":"catering","asset_tag_5":"restaurant","asset_tag_6":"diamond jim's","asset_tag_7":"wrap","asset_tag_8":"salad bar","asset_tag_9":"fillet","asset_flag_1":"centerpiece"});if (tnsrc && tnsrc[1]) {dl.push({'tncms.campaign.internal_source': tnsrc[1]});}window.addEventListener("DOMContentLoaded", function(oEvent) {var oTest = document.createElement('div');oTest.innerHTML = '&nbsp;';oTest.className = 'adsbox';document.body.appendChild(oTest);var nTimeoutID = window.setTimeout(function() {if (oTest.offsetHeight === 0) {dl.push({'event': 'tncms.ad.blocked'});}document.body.removeChild(oTest);window.clearTimeout(nTimeoutID);}, 100);});var nWidth=Math.max(document.documentElement.clientWidth, window.innerWidth || 0),aBPs=[[300,"Extra small: Most smartphones."],[768,"Small: Tablet devices."],[992,"Medium: Laptops & landscape tablets."],[1200,"Large: Desktop computers."]],i,c,aThisBP,aBP;for(i=0,c=aBPs.length;i<c;i++){aThisBP=aBPs[i];if(aBP===undefined||aThisBP[0]<=nWidth){aBP=aThisBP;}}if(aBP!==undefined){dl.push({'tncms.client.breakpoint':aBP[1]});}(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'tncms.start':new Date().getTime(),event:'tncms.start'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-PDQV3N');})();</script>
<script src="https://tags.crwdcntrl.net/c/6893/cc.js?ns=_cc6893" id="LOTCC_6893"></script>
<script>
	if(document.cookie.indexOf('tncms-dmp-id') != -1) {
		_cc6893.add('tp', 'TNNW');
		_cc6893.add('act', ' User Login');
		_cc6893.add('tpid', document.cookie.split( ';' ).map( function( x ) { return x.trim().split( '=' ); } ).reduce(function( a, b ) { a[ b[ 0 ] ] = b[ 1 ]; return a; }, {} )[ "tncms-dmp-id"]);
		document.cookie = 'tncms-dmp-id=;expires=Thu, 01 Jan 1970 00:00:01 GMT';
		sessionStorage.removeItem('tncms.behaviors');
		sessionStorage.removeItem('tncms.dmp.audiences');
	}
	_cc6893.add('med', 'flag: centerpiece');
	_cc6893.bcp();
</script>

<script type="module" async="async" src="/shared-content/art/tncms/api/access.js"></script>
<script src="/shared-content/art/tncms/api/access-legacy.js" defer="defer" nomodule="nomodule"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/shared-content/art/tncms/templates/libraries/flex/components/jquery/resources/scripts/jquery.min.d6d18fcf88750a16d256e72626e676a6.js"></script>
<script src="/shared-content/art/tncms/user/user.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/scripts/bootstrap.min.d457560d3dfbf1d56a225eb99d7b0702.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/common.08a61544f369cc43bf02e71b2d10d49f.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.cfb7b302c42616744a59428baa754111.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/application.81be8dcdc3040973d38ec593fcfe8805.js"></script>
<script src="https://polyfill.io/v3/polyfill.min.js?features=default,fetch,IntersectionObserver,NodeList.prototype.@@iterator,Element.prototype.classList|gated" nomodule="nomodule"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.navigation.accessibility.7a9170240d21440159b9bd59db72933b.js"></script>
<script async="async" src="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.dynamic.navigation.859e6044e28dfde43a7de7cd024102d0.js"></script>
<script async="async" src="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/shared-content/art/tncms/templates/libraries/flex/components/asset/resources/scripts/tnt.nextPrev.283bfb49ef55c073fceda15ffbf58de8.js"></script>
<script src="https://launch.inform.com/2/js/embed.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/shared-content/art/tncms/templates/libraries/flex/components/ads_blox/resources/scripts/tnt.ads.init.c2b9574823d0d16ffc6f20eef83f4232.js"></script>
<script async="async" src="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/shared-content/art/tncms/templates/libraries/flex/components/ads_blox/resources/scripts/tnt.ads.load.6a3c47703ee96f20ef132e36033ca1bc.js"></script>
<script src="/shared-content/art/tncms/tracking.js"></script>
<script src="/shared-content/art/tncms-ad-manager/admanager.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/ads/impressions.js?_dc=1664240711"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/ads/traffic.js?_dc=1664170511"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/ads/settings.js?_dc=1519930205"></script>
<script async="async" src="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/shared-content/art/tncms/templates/libraries/flex/components/search/resources/scripts/tnt.followed.notifications.6600e99595fd219e961e9882c796e61c.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/live/global/resources/scripts/biz.js?_dc=1468351486"></script>
<script>/*<![CDATA[*/ window.promo_design_config || (window.promo_design_config = []); window.promo_design_config.push({"button_size":"btn-lg","button_style":"success","button_text":"Sign-up","button_url":"https:\/\/bcp.crwdcntrl.net\/5\/c=6880\/b=65082672?https:\/\/visitor.r20.constantcontact.com\/d.jsp?llr=99oml49ab&p=oi&m=1128481045338&sit=s5fwgcwlb&f=e95c0a03-8db9-4d2a-98d3-7dffa92feef5","card_shape":"rounded_rectangle","content_text":"Sign up now to get our FREE breaking news coverage delivered right to your inbox.","display_again":"24","display_timer":"2","display_triggers":"visitor_enter","email_button_style":"primary","email_text_shadow":"disabled","heading_tag":"h2","heading_text_color":"light","headline_size":"medium","headline_text":"Get Breaking News","headline_text_color":"dark","lead_in":"Stay up to date on COVID-19","lead_text_color":"dark","overlay_action":"toaster_right","show_audience":"meridianstar_headlines_daily","sticker_color":"#cccccc","sticker_icon":"envelope","sticker_icon_color":"white","sticker_shape":"rounded","heading_bg_color":"","note":"","links_position":"top","display_width":"region","card_shadow":"enabled","bg_color":"","outline_color":"#ccc","border_width":"5","image_display":"medium","lead_text_shadow":"disabled","headline_shadow":"disabled","content_text_color":"dark","content_text_shadow":"disabled","info_text":"","info_text_color":"dark","info_text_shadow":"disabled","enable_email":"","require_user_account":"","signup_lists_only":"","list_ids":"","email_text_color":"dark","sign_up_text":"Sign up","manage_button_text":"Manage your lists","utm_tracking":"0","utm_source":"blox","utm_medium":"utility_promo_designer","utm_campaign":"pop_up","utm_campaign_content":"utility_promo_designer","utm_campaign_name":"utm_campaign_name","hide_audience":"","block_id":"2554840"}); /*]]>*/</script>
<script src="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/shared-content/art/tncms/templates/libraries/flex/components/ads/resources/scripts/tnt.ads.adverts.66a3812a7b5c12fde8cd998fd691ad7d.js"></script>
<script>/*<![CDATA[*/ __tnt.recentFive = {
    /*
     * Gets the data stored in 'tnt:recent:five'
     * Returns Array
     */
        get:function(){
            if(window.localStorage && localStorage.getItem('tnt:recent:five')!=null){
                try{ return JSON.parse(localStorage.getItem('tnt:recent:five')); } catch {}
            }

            return [];
        },

    /*
     * Sets the 'tnt:recent:five' localStorage item
     * Returns boolean
     */
        set:function(data){
            if(window.localStorage){
                try{ 
                    localStorage.setItem('tnt:recent:five', JSON.stringify(data));
                    return true;
                } catch {}
            }

            return false;
        },

    /*
     * Adds the most recent item, prunes any duplicates, and trims the array down to 5 items
     * Returns Array on success, false on fail 
     */
        add:function(asset){
            var assets = __tnt.recentFive.get();
            assets.unshift(asset);

            if(assets.length > 1){
                assets = assets.filter(function(item, index, a){ return a.indexOf(item) == index });

                while(assets.length>5){
                    assets.pop();
                }
            }

            if(__tnt.recentFive.set(assets)){ return assets; }
            return false;
        }
    }; /*]]>*/</script>

            
            <title>FAMILY TRADITION: Popular steakhouse expands to Meridian | Local News | meridianstar.com</title>  

<link rel="preconnect" href="https://fonts.googleapis.com">
<link rel="preconnect" href="https://fonts.gstatic.com" crossorigin>
<link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Open+Sans:300,400|PT+Serif&amp;display=swap"/>


            
    
    <style>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</style>
    
        <link rel="apple-touch-icon" href="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/custom/image/fd346ea2-8893-11e5-8ab3-a796975542f9.png" />
    
        <link rel="amphtml" href="https://www.meridianstar.com/news/local_news/family-tradition-popular-steakhouse-expands-to-meridian/article_78352ec9-bf29-5878-a3df-8593459d9946.amp.html" />
    <link rel="alternate" type="application/rss+xml" title="FAMILY TRADITION: Popular steakhouse expands to Meridian | Local News | meridianstar.com" href="http://www.meridianstar.com/search/?f=rss&amp;t=article&amp;c=news/local_news&amp;l=50&amp;s=start_time&amp;sd=desc" />
        <link rel="canonical" href="https://www.meridianstar.com/news/local_news/family-tradition-popular-steakhouse-expands-to-meridian/article_78352ec9-bf29-5878-a3df-8593459d9946.html" />
    
            <script defer src="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/fontawesome.dd9f72114a809f3dc0619831f68070f4.js"></script>
            <!--Use for site customizations that need to be inserted into the site's header.-->
<!-- Flipp Controller Tag -->
<script async 
src="https://cdn-gateflipp.flippback.com/tag/js/flipptag.js?site_id=1181297"></script>
<script>
window.flippxp = window.flippxp || {run: []};
if (document.documentElement.clientWidth < 767) {
  window.flippxp.run.push(function() {
     window.flippxp.registerSlot("#flipp-ux-slot-101g218", "CNHI", 1181297, [ 256024 ]);
  });
} else {
  window.flippxp.run.push(function() {
     window.flippxp.registerSlot("#flipp-ux-slot-68ce2f21", "CNHI", 1181297, [ 257467 ]);
  });
}
</script>
<!-- Admiral --><script>!(function(o,n,t){t=o.createElement(n),o=o.getElementsByTagName(n)[0],t.async=1,t.src="https://bandborder.com/v2/0/lkczIC9EJlH0TPQPjgtaMj7OCOcW3VnKcFkD5nNo12ai2jJCgixkMuS",o.parentNode.insertBefore(t,o)})(document,"script"),(function(o,n){o[n]=o[n]||function(){(o[n].q=o[n].q||[]).push(arguments)}})(window,"admiral");!(function(n,e,r,t){function o(){if((function o(t){try{return(t=localStorage.getItem("v4ac1eiZr0"))&&0<t.split(",")[4]}catch(n){}return!1})()){var t=n[e].pubads();typeof t.setTargeting===r&&t.setTargeting("admiral-engaged","true")}}(t=n[e]=n[e]||{}).cmd=t.cmd||[],typeof t.pubads===r?o():typeof t.cmd.unshift===r?t.cmd.unshift(o):t.cmd.push(o)})(window,"googletag","function");;;;!(function(t,n,i,u,e,o){var a=n[i];function r(t){if(t){var u=(t.data||{})[i+"Call"];u&&n[i](u.command,u.version,function(n,i){t.source.postMessage({__uspapiReturn:{returnValue:n,success:i,callId:u.callId}},"*")})}}if((function c(){if(!window.frames[u]){var n=t.body;if(n){var i=t.createElement("iframe");i.style.display="none",i.name=u,n.appendChild(i)}else setTimeout(c,5)}})(),"function"!=typeof a){var s={getUSPData:function(n,i){return n!==1?i&&i(null,!1):i&&i({version:null,uspString:null},!1)}};a=n[i]=function(n,i,t){return s[n](i,t)},n.addEventListener?n.addEventListener("message",r,!1):n.attachEvent&&n.attachEvent("onmessage",r)}o=t.createElement(e),t=t.getElementsByTagName(e)[0],o.src="https://bandborder.com/v2/0/fsi-op1dHgFYH3pSsOKKY6-JCKRt2M-eeMebE1jD8okp8ZBYkH6YV5nrFURnrS5SCM7sXD_dg",t.parentNode.insertBefore(o,t)})(document,window,"__uspapi","__uspapiLocator","script");</script>
<meta name="google-site-verification" content="ls7KGAcrGT19QTOEavGLY3ZRp0hRBXRPOdZKPZ0jCJY" />
<script async src='https://tag.simpli.fi/sifitag/d65091c0-4d8b-0136-49c4-067f653fa718'></script><!-- DFP Include -->
<!-- adb section targeting -->

<script>

window.AdBridg = window.AdBridg || { cmd: [] };
window.googletag = window.googletag || { cmd: [] };

window.AdBridg.cmd.push({
    action: "spa_pv_initialize",
    config: {
        adb_site: 'meridianstar',
        targeting: {
            section: 'news/local_news'
        }
    }
});
</script>

<!-- Links to adb library and GAM -->
<script async='async' src='https://securepubads.g.doubleclick.net/tag/js/gpt.js'></script>
<script async='async' src='https://prod.adspsp.com/adb.1710310.min.js'></script>


<script type="text/javascript" src="https://meridianstar-cnhi-pw.newsmemory.com?meter&v=4&amp;service=onstop" async></script>

<meta name="vf:container_id" content="78352ec9-bf29-5878-a3df-8593459d9946" />
<!-- APP Comments -->




<!--  Nativo JS Here-->
<script type="text/javascript" src="//s.ntv.io/serve/load.js" async></script>

<!--  End Nativo JS Here-->
<!-- Adds masthead back to articles -->
<script>
    document.addEventListener("DOMContentLoaded", function(){
        const tarHead = document.getElementById('site-header-container');
		tarHead.classList.remove('hidden-lg','hidden-md');
    });
</script>



        </head>
        <body class="app-editorial grid-centerpiece blox-asset uuid-78352ec9-bf29-5878-a3df-8593459d9946  section-news section-local-news type-article infinity-disabled" data-authors='[]' data-path="/news/local_news">
	<script type='text/javascript' src='/shared-content/art/stats/common/tracker.js'></script>
	<script type='text/javascript'>
	<!--
	if (typeof(TNStats_Tracker) !== 'undefined' && typeof(TNTracker) === 'undefined') { TNTracker = new TNStats_Tracker('www.meridianstar.com'); TNTracker.trackPageView(); }
	// -->
	</script>
	<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-PDQV3N&amp;townnews.product.software=BLOX&amp;townnews.product.version=1.63.2&amp;townnews.crm.group_id=13&amp;tncms.template.version=3.155.0&amp;tncms.page.grid=centerpiece&amp;tncms.page.style=default&amp;tncms.page.path=%2Fnews%2Flocal_news&amp;tncms.page.syndicated=false&amp;tncms.page.reaction=true&amp;tncms.page.app=editorial&amp;tncms.page.theme=flex&amp;tncms.page.skin=flex-editorial&amp;tncms.page.http_status=200&amp;tncms.subscription.required=false&amp;tncms.asset.type=article&amp;tncms.asset.author=D%27Courtland+Christian+dchristian%40themeridianstar.com&amp;tncms.asset.start_hour=12&amp;tncms.asset.id=78352ec9-bf29-5878-a3df-8593459d9946&amp;tncms.asset.app=editorial&amp;tncms.asset.ga_page=%2Fnews%2Flocal_news%2Farticle_78352ec9-bf29-5878-a3df-8593459d9946.html&amp;tncms.vendor.outbrain=&amp;tncms.vendor.taboola=&amp;tncms.system.render_time=318&amp;tncms.client.is_bot=no&amp;tncms.client.is_gdpr=no&amp;taxonomy_1=news&amp;taxonomy_2=local_news&amp;blox_platform=desktop&amp;blox_page_type=asset&amp;blox_domain=meridianstar.com&amp;blox_skin=flex-editorial&amp;blox_application=editorial&amp;groups.content=1&amp;groups.advertising=2&amp;groups.utility=3&amp;content_group=1&amp;content_group_id=news&amp;blox_sections=news%2Clocal_news&amp;weather_temp=64&amp;weather_conditions=Clear&amp;asset_source=local&amp;blox_asset_type=article&amp;asset_section=news%2Flocal_news&amp;asset_id=78352ec9-bf29-5878-a3df-8593459d9946&amp;asset_headline=FAMILY+TRADITION%3A+Popular+steakhouse+expands+to+Meridian&amp;asset_byline=By+D%27Courtland+Christian+dchristian%40themeridianstar.com&amp;asset_pub_date=09%2F26%2F2022&amp;asset_pub_time=12%3A01+pm&amp;asset_canonical=https%3A%2F%2Fwww.meridianstar.com%2Fnews%2Flocal_news%2Ffamily-tradition-popular-steakhouse-expands-to-meridian%2Farticle_78352ec9-bf29-5878-a3df-8593459d9946.html&amp;asset_tag_1=steakhouse&amp;asset_tag_2=steak&amp;asset_tag_3=food&amp;asset_tag_4=catering&amp;asset_tag_5=restaurant&amp;asset_tag_6=diamond+jim%27s&amp;asset_tag_7=wrap&amp;asset_tag_8=salad+bar&amp;asset_tag_9=fillet&amp;asset_flag_1=centerpiece&amp;tncms.client.noscript=yes" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
        <a href="#main-page-container" class="sr-only" onclick="document.getElementById('main-page-container').scrollIntoView(); return false">Skip to main content</a><div id="fb-root"></div>
        
        
        <!-- Google Tag Manager -->
        <script>
            var dataLayer = window.dataLayer || [];
            dataLayer.push(
                {'user_id': __tnt.user.screenName},
                {'user_state': __tnt.user.loggedIn ? 'logged in' : 'anonymous'},
                {'utm_label': __tnt.urlHash('utm_label')}
            );
        </script>
        <noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-52VL4R" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
        <script>
            (function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
            new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
            j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
            '//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
            })(window,document,'script','dataLayer','GTM-52VL4R');
        </script>
        <script>
            $(function(){
                var bloxServiceIDs = [];
                var bloxUserServiceIds = [];
                var dataLayer = window.dataLayer || [];

                

                if (__tnt.user.services){
                    var bloxUserServiceIDs = __tnt.user.services.replace('%2C',',').split(',');
                }

                // GTM tncms.subscription.paid_access_service_ids
                if(bloxServiceIDs){
                    dataLayer.push({'tncms':{'subscription':{'access_service_ids':bloxServiceIDs.toString()}}});
                }

                // GTM tncms.subscrption.user_service_ids
                if(bloxUserServiceIDs){
                    dataLayer.push({'tncms':{'subscription':{'user_service_ids':bloxUserServiceIDs.toString()}}});
                }
            });
        </script>
        
        <div id="site-container"><div id="asset-contribute-bar" class="asset-edit-bar hidden-print">
                <div class="asset-edit-icon"><i class="fas tnt-certificate tnt-fw"></i></div>
                <div class="asset-edit-message">You are the owner of this article.</div>
                <div class="asset-edit-btns">
                    <a class="btn btn-primary btn-sm" href="https://www.meridianstar.com/users/admin/contribute/article/?assetid=78352ec9-bf29-5878-a3df-8593459d9946&assettype=article"><i class="fas tnt-pencil-alt tnt-fw"></i> Edit Article</a>
                    
                        <a class="btn btn-danger btn-sm" href="https://www.meridianstar.com/users/admin/contribute/article/?from_section=/news/local_news"><i class="fas tnt-plus tnt-fw"></i> Add New Article</a>
                    
                    <button class="asset-edit-close btn btn-link btn-sm"><i class="fas tnt-times"></i><span class="sr-only">Close</span></button>
                </div>
            </div><div id="asset-admin-bar" class="asset-edit-bar hidden-print">
                <div class="asset-edit-icon"><i class="fas tnt-lock-open tnt-fw"></i></div>
                <div class="asset-edit-message">You have permission to edit this article.</div>
                <div class="asset-edit-btns">
                    <a class="btn btn-primary btn-sm" target="_blank" rel="noopener" href="https://www.meridianstar.com/tncms/admin/editorial-asset/?edit=78352ec9-bf29-5878-a3df-8593459d9946"><i class="fas tnt-pencil-alt tnt-fw"></i> Edit</a>
                    <button class="asset-edit-close btn btn-link btn-sm"><i class="fas tnt-times"></i><span class="sr-only">Close</span></button>
                </div>
            </div>
        
    
        
            <aside class="hidden-print offcanvas-drawer offcanvas-drawer-left" aria-label="Left Main Menu" aria-expanded="false" tabindex="-1" >
                <div id="tncms-region-mobile-nav-top-left-region" class="tncms-region "><div id="tncms-block-2574964" class="tncms-block in-drawer"><div id="site-logo-2574964" class="site-logo-container text-left" ><div class="logo-middle">
            <a  href="/" aria-label="Home page"><img 
            
            src="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/media/b/95/b95756fe-eda4-11ec-b338-cf296972574f/62ab7aac26818.image.png?resize=200%2C32" 
            srcset="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/media/b/95/b95756fe-eda4-11ec-b338-cf296972574f/62ab7aac26818.image.png?resize=150%2C24 150w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/media/b/95/b95756fe-eda4-11ec-b338-cf296972574f/62ab7aac26818.image.png?resize=200%2C32 200w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/media/b/95/b95756fe-eda4-11ec-b338-cf296972574f/62ab7aac26818.image.png?resize=225%2C36 225w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/media/b/95/b95756fe-eda4-11ec-b338-cf296972574f/62ab7aac26818.image.png?resize=300%2C48 300w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/media/b/95/b95756fe-eda4-11ec-b338-cf296972574f/62ab7aac26818.image.png?resize=400%2C65 400w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/media/b/95/b95756fe-eda4-11ec-b338-cf296972574f/62ab7aac26818.image.png?resize=540%2C87 540w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/media/b/95/b95756fe-eda4-11ec-b338-cf296972574f/62ab7aac26818.image.png?resize=640%2C103 640w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/media/b/95/b95756fe-eda4-11ec-b338-cf296972574f/62ab7aac26818.image.png 750w"
            sizes="100vw"
            
            class=" img-responsive lazyload tnt-prop-img"
            width="750"
            height="121"
            alt="site-logo"
            ></a>
        </div></div></div><div id="tncms-block-2574961" class="tncms-block in-drawer social-links"><div class="follow-links-2574961 follow-links default">
    
    <section id="block-2574961" class="block emphasis-h3   " ><ul class="list-inline">
        
        
        
        
        
        
        
        
        
        
        
            <li>
                <a href="mailto:https%3A%2F%2Fvisitor.r20.constantcontact.com%2Fd.jsp%3Fllr%3D99oml49ab%26p%3Doi%26m%3D1128481045338%26sit%3Ds5fwgcwlb%26f%3De95c0a03-8db9-4d2a-98d3-7dffa92feef5" title="Email" target="_blank" rel="noopener" class="btn btn-xs btn-link em" data-toggle="tooltip" data-placement="bottom">
                    <i class="fas tnt-envelope"></i>
                    <span class="sr-only">Email</span>
                </a>
            </li>
        
        
        
        
        
        
        
    </ul>
    </section>
</div>
<script type="application/ld+json">
{ "@context" : "https://schema.org",
  "@type" : "Organization",
  "url" : "http://www.meridianstar.com",
  "sameAs" : [,"https://visitor.r20.constantcontact.com/d.jsp?llr=99oml49ab&p=oi&m=1128481045338&sit=s5fwgcwlb&f=e95c0a03-8db9-4d2a-98d3-7dffa92feef5"]
}
</script>
<div class="clearfix"></div></div><div id="tncms-block-2574952" class="tncms-block hidden-md hidden-lg"><section id="block-2574952" class="block emphasis-h3   " >
    <div class="clearfix"></div>
    <div id="search-form-2574952" class="search-form-container card clearfix text-center well">
    <form id="site-search-2574952" action="/search/" method="GET" >
    <input type="hidden" name="l" value="25">
    <input type="hidden" name="sd" value="desc">
    <input type="hidden" name="s" value="start_time">
    <input type="hidden" name="f" value="html">
    <input type="hidden" name="app" value="editorial">
    <div class="site-search-form input-group default normal ">
        <input id="site-search-2574952-term" name="q" type="text" placeholder="Search..." class="form-control" autocomplete="off">
        <input type="submit" class="hide" value="Search">
        <span class="input-group-btn">
            <button id="site-search-2574952-btn" class="btn btn-default" type="submit">
                <span class="hidden-xs hidden-sm">Search</span>
            </button>
        </span>
    </div>
    <input type="hidden" name="nsa" value="eedition">
    <div class="clearfix"></div>
</form>
        
        
        <div class="clearfix"></div>
    </div>
    </section><style>
    #site-search-2574952 .search-spinner { position: absolute; }
    #site-search-2574952 .input-group-btn:last-child>.btn, .input-group-btn:last-child>.btn-group {margin-left: 0;}
    

    
</style> 

<script>
    $('#site-search-2574952-btn').on(__tnt.client.clickEvent, function(){
        $('#site-search-2574952').submit();
        return false;
    });

    $('#site-search-2574952').on('submit', function(){
        if( $('#site-search-2574952-term').val() ){
            $('#site-search-2574952-btn .fa').removeClass('fa-search').addClass('fa-spinner fa-spin');
            return true;
        }else{
            return false;
        }
    });</script></div></div>
                <div id="tncms-region-nav-mobile-nav-left" class="tncms-region-nav"><div id="mobile-nav-left_menu" class="panel-group nav navbar-nav" role="tablist"><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="javascript:var onclick=ta_account();" id="ta_account_button"  class="nav-link tnt-section-login">Login</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="/"  class="nav-link tnt-section-span-class-fas-tnt-home-span"><span class="fas tnt-home"></span></a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-3" data-target="#mobile-nav-left_menu-child-3">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/news/"  class="nav-link tnt-section-news">News</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-3" class="collapse nav navbar-nav"><li>
                                    <a href="/news/local_news/"  class="nav-link tnt-section-local-news">Local News</a>
                                </li><li>
                                    <a href="/news/business"  class="nav-link tnt-section-business">Business</a>
                                </li><li>
                                    <a href="/news/lifestyles/"  class="nav-link tnt-section-lifestyles">Lifestyles</a>
                                </li><li>
                                    <a href="/news/state_news/"  class="nav-link tnt-section-state-news">State News</a>
                                </li><li>
                                    <a href="/news/nation_and_world/"  class="nav-link tnt-section-nation-world">Nation & World</a>
                                </li><li>
                                    <a href="/news/max/"  class="nav-link tnt-section-max">MAX</a>
                                </li><li>
                                    <a href="/multimedia"  class="nav-link tnt-section-video">Video</a>
                                </li><li>
                                    <a href="https://meridianstar.com/bestof"  target="_blank" rel="noopener" class="nav-link tnt-section-readers-choice-contest">Readers Choice Contest</a>
                                </li><li>
                                    <a href="/homestyle/"  class="nav-link tnt-section-home-style-magazine">Home & Style Magazine</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-4" data-target="#mobile-nav-left_menu-child-4">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a   class="nav-link tnt-section-puzzles-comics-games">Puzzles, Comics & Games</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-4" class="collapse nav navbar-nav"><li>
                                    <a href="/comics-kingdom"  class="nav-link tnt-section-comics">Comics</a>
                                </li><li>
                                    <a href="/puzzles-palace"  class="nav-link tnt-section-puzzles">Puzzles</a>
                                </li><li>
                                    <a href=" https://games.cnhinews.com/?arkpromo=Menu_TheMeridianStar "  class="nav-link tnt-section-games">Games</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="/covid-19/"  class="nav-link tnt-section-covid-19-news">COVID-19 News</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="/magazines/"  class="nav-link tnt-section-magazines">Magazines</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="/multimedia/photos/"  class="nav-link tnt-section-photo-galleries">Photo Galleries</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-8" data-target="#mobile-nav-left_menu-child-8">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/sports/"  class="nav-link tnt-section-sports">Sports</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-8" class="collapse nav navbar-nav"><li>
                                    <a href="/sports/local_sports/"  class="nav-link tnt-section-local-sports">Local Sports</a>
                                </li><li>
                                    <a href="/sports/national_sports/"  class="nav-link tnt-section-national-sports">National Sports</a>
                                </li><li>
                                    <a href="/sports/state_sports/"  class="nav-link tnt-section-state-sports">State Sports</a>
                                </li><li>
                                    <a href="/sports/outdoors/"  class="nav-link tnt-section-outdoors">Outdoors</a>
                                </li><li>
                                    <a href="/sports/premierpreps/"  class="nav-link tnt-section-premier-preps">Premier Preps</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-9" data-target="#mobile-nav-left_menu-child-9">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/opinion/"  class="nav-link tnt-section-opinion">Opinion</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-9" class="collapse nav navbar-nav"><li>
                                    <a href="/opinion/columns/"  class="nav-link tnt-section-columns">Columns</a>
                                </li><li>
                                    <a href="/opinion/editorials/"  class="nav-link tnt-section-editorials">Editorials</a>
                                </li><li>
                                    <a href="/opinion/letters_to_the_editor/"  class="nav-link tnt-section-letters-to-the-editor">Letters to the Editor</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-10" data-target="#mobile-nav-left_menu-child-10">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/community/"  class="nav-link tnt-section-community">Community</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-10" class="collapse nav navbar-nav"><li>
                                    <a href="/community/anniversary/"  class="nav-link tnt-section-anniversary">Anniversary</a>
                                </li><li>
                                    <a href="/community/engagements"  class="nav-link tnt-section-engagements">Engagements</a>
                                </li><li>
                                    <a href="/community/weddings"  class="nav-link tnt-section-weddings">Weddings</a>
                                </li><li>
                                    <a href="http://www.meridianstar.com/community/births/"  target="_blank" rel="noopener" class="nav-link tnt-section-births">Births</a>
                                </li><li>
                                    <a href="/community/celebrations/"  class="nav-link tnt-section-celebrations">Celebrations</a>
                                </li><li>
                                    <a href="/multimedia/photos/"  class="nav-link tnt-section-photos">Photos</a>
                                </li><li>
                                    <a href="/community/religion/"  class="nav-link tnt-section-religion">Religion</a>
                                </li><li>
                                    <a href="/community/education/"  class="nav-link tnt-section-education">Education</a>
                                </li><li>
                                    <a href="/homestyle"  class="nav-link tnt-section-meridian-home-style">Meridian Home & Style</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="http://celebrations.meridianstar.com/"  target="_blank" rel="noopener" class="nav-link tnt-section-celebrations">Celebrations</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="/obituaries"  class="nav-link tnt-section-obituaries">Obituaries</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-13" data-target="#mobile-nav-left_menu-child-13">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/classifieds"  class="nav-link tnt-section-classifieds">Classifieds</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-13" class="collapse nav navbar-nav"><li>
                                    <a href="/monster"  class="nav-link tnt-section-jobs">Jobs</a>
                                </li><li>
                                    <a href="Autos"  class="nav-link tnt-section-autos">Autos</a>
                                </li><li>
                                    <a href="/homes"  class="nav-link tnt-section-homes">Homes</a>
                                </li><li>
                                    <a href="/placeanad"  class="nav-link tnt-section-place-an-ad">Place An Ad</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="/e-edition"  class="nav-link tnt-section-e-paper">E-Paper</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="/app-downloads"  class="nav-link tnt-section-app">App</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="http://notices.meridianstar.com/"  target="_blank" rel="noopener" class="nav-link tnt-section-public-notices">Public Notices</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-17" data-target="#mobile-nav-left_menu-child-17">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/site/contact-us.html"  class="nav-link tnt-section-contact-us">Contact Us</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-17" class="collapse nav navbar-nav"><li>
                                    <a href="/site/forms/online_services/letter/"  class="nav-link tnt-section-submit-a-letter-to-the-editor">Submit a Letter to the Editor</a>
                                </li><li>
                                    <a href="/site/forms/online_services/submit_news/"  class="nav-link tnt-section-submit-a-news-tip">Submit a News Tip</a>
                                </li><li>
                                    <a href="http://obituaries.meridianstar.com/select-notice-type"  target="_blank" rel="noopener" class="nav-link tnt-section-place-an-obituary">Place an Obituary</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-18" data-target="#mobile-nav-left_menu-child-18">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/subscriptions"  class="nav-link tnt-section-subscribe">Subscribe</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-18" class="collapse nav navbar-nav"><li>
                                    <a href="/subscriptions"  class="nav-link tnt-section-start-a-subscription">Start a Subscription</a>
                                </li><li>
                                    <a href="/subscriber-services"  class="nav-link tnt-section-manage-my-subscription">Manage My Subscription</a>
                                </li><li>
                                    <a href="/e-edition"  class="nav-link tnt-section-e-paper">E-Paper</a>
                                </li><li>
                                    <a href="/app-downloads"  class="nav-link tnt-section-app-downloads">App Downloads</a>
                                </li><li>
                                    <a href="https://visitor.r20.constantcontact.com/d.jsp?llr=99oml49ab&amp;p=oi&amp;m=1128481045338&amp;sit=s5fwgcwlb&amp;f=e95c0a03-8db9-4d2a-98d3-7dffa92feef5"  target="_blank" rel="noopener" class="nav-link tnt-section-newsletter">Newsletter</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-19" data-target="#mobile-nav-left_menu-child-19">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a   class="nav-link tnt-section-shop">Shop</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-19" class="collapse nav navbar-nav"><li>
                                    <a href="/coupondeals"  class="nav-link tnt-section-coupons">Coupons</a>
                                </li><li>
                                    <a href="/weeklyads"  class="nav-link tnt-section-weekly-ads">Weekly Ads</a>
                                </li><li>
                                    <a href="http://newspaperads.meridianstar.com/"  target="_blank" rel="noopener" class="nav-link tnt-section-newspaper-ads">Newspaper Ads</a>
                                </li></ul></div></div></div>
                
                
                <div id="tncms-region-mobile-nav-bottom-left-region" class="tncms-region "></div>
            </aside>
        
        

        <div class="offcanvas-inner">
            <div class="offcanvas-close-btn"></div>
    
    
    
        
            <div id="site-navbar-container" class="hidden-print affix-top">
                
                <nav id="main-navigation" aria-label="Main" class="navbar yamm navbar-default navbar-dynamic">
                    <div class="navbar-header">
                        
                        <button type="button" class="hamburger-desktop navbar-toggle pull-left" data-toggle="offcanvas" data-target="left" aria-label="Left Main Menu">
                            <i class="fas tnt-bars tnt-fw"></i>
                        </button>

                        
                            <div class="navbar-brand pos_left_menu_right_search">
                                
                                    <div id="tncms-region-main-nav-brand" class="tncms-region "><div id="tncms-block-2554867" class="tncms-block"><section id="block-2554867" class="block emphasis-h3   " ><div class="block"><a href="/" rel="nofollow"  >
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/custom/image/8a5ebc34-4984-11e8-90b1-c74aa99c9885.png?resize=150%2C24 150w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/custom/image/8a5ebc34-4984-11e8-90b1-c74aa99c9885.png?resize=200%2C32 200w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/custom/image/8a5ebc34-4984-11e8-90b1-c74aa99c9885.png?resize=225%2C36 225w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/custom/image/8a5ebc34-4984-11e8-90b1-c74aa99c9885.png?resize=300%2C49 300w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/custom/image/8a5ebc34-4984-11e8-90b1-c74aa99c9885.png?resize=400%2C65 400w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/custom/image/8a5ebc34-4984-11e8-90b1-c74aa99c9885.png?resize=540%2C87 540w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/custom/image/8a5ebc34-4984-11e8-90b1-c74aa99c9885.png?resize=640%2C104 640w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/custom/image/8a5ebc34-4984-11e8-90b1-c74aa99c9885.png?resize=750%2C121 750w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/custom/image/8a5ebc34-4984-11e8-90b1-c74aa99c9885.png 990w" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                width="958"
                height="155"
                alt=""
                aria-hidden="true"></a></div></section></div></div>
                                
                            </div>
                        

                        
                            <ul class="hidden-md hidden-lg nav navbar-nav pull-right site-search-full-mobile">
                                <li class="search-form-dropdown dropdown yamm-fw">
                                    <a class="dropdown-toggle" data-toggle="dropdown" aria-label="Search">
                                        <span class="fas tnt-search"></span>
                                    </a>
                                    <ul class="dropdown-menu">
                                        <li>
                                            <form action="/search/" method="GET" class="yamm-content">
                                                <input type="hidden" name="l" value="25">
                                                <input type="hidden" name="sd" value="desc">
                                                <input type="hidden" name="s" value="start_time">
                                                <input type="hidden" name="f" value="html">
                                                <input type="hidden" name="t" value="article,video,youtube,collection">
                                                <div class="input-group">
                                                    <input name="q" type="text" placeholder="Search..." title="Site Search" class="form-control" autocomplete="off">
                                                    <input type="submit" class="hide" value="Search">
                                                    <span class="input-group-btn">
                                                        <button class="btn btn-default site-search-btn" type="submit">
                                                            Search
                                                        </button>
                                                    </span>
                                                </div>
                                                <div class="clearfix"></div>
                                            </form>
                                        </li>
                                    </ul>
                                </li>
                            </ul>
                            <script>
                                $('.site-search-full-mobile button[type="submit"]').on(__tnt.client.clickEvent, function(){
                                    $('.site-search-full-mobile form').submit();
                                    return false;
                                });
                            </script>
                        
                    </div>

                    
                        <div id="navbar-collapse" class="navbar-collapse collapse">
                            
                                <div class="pull-right">
                                    <div id="tncms-region-main-nav-right-region" class="tncms-region "></div>
                                    <div id="tncms-region-nav-main-nav-right-nav" class="tncms-region-nav"><ul id="main-nav-right-nav_menu" class="nav navbar-nav"><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-contact-us"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/site/contact-us.html" >
                    <span class="nav-label ">Contact Us</span>
                </a><ul id="main-nav-right-nav_menu-child-1" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-submit-a-letter-to-the-editor"  href="/site/forms/online_services/letter/" >
                    <span class="nav-label ">Submit a Letter to the Editor</span>
                </a></li><li>
                <a class="nav-link  tnt-section-submit-a-news-tip"  href="/site/forms/online_services/submit_news/" >
                    <span class="nav-label ">Submit a News Tip</span>
                </a></li><li>
                <a class="nav-link  tnt-section-place-an-obituary"  href="http://obituaries.meridianstar.com/select-notice-type"  target="_blank" rel="noopener">
                    <span class="nav-label ">Place an Obituary</span>
                </a></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-subscribe"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/subscriptions" >
                    <span class="nav-label ">Subscribe</span>
                </a><ul id="main-nav-right-nav_menu-child-2" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-start-a-subscription"  href="/subscriptions" >
                    <span class="nav-label ">Start a Subscription</span>
                </a></li><li>
                <a class="nav-link  tnt-section-manage-my-subscription"  href="/subscriber-services" >
                    <span class="nav-label ">Manage My Subscription</span>
                </a></li><li>
                <a class="nav-link  tnt-section-e-paper"  href="/e-edition" >
                    <span class="nav-label ">E-Paper</span>
                </a></li><li>
                <a class="nav-link  tnt-section-app-downloads"  href="/app-downloads" >
                    <span class="nav-label ">App Downloads</span>
                </a></li><li>
                <a class="nav-link  tnt-section-newsletter"  href="https://visitor.r20.constantcontact.com/d.jsp?llr=99oml49ab&p=oi&m=1128481045338&sit=s5fwgcwlb&f=e95c0a03-8db9-4d2a-98d3-7dffa92feef5"  target="_blank" rel="noopener">
                    <span class="nav-label ">Newsletter</span>
                </a></li></ul></li><li>
                <a class="nav-link  tnt-section-login"  href="javascript:var onclick=ta_account();" id="ta_account_button2" >
                    <span class="nav-label ">Login</span>
                </a></li></ul></div>
                                </div>
                            
                            <div class="navbar-left">
                                <div id="tncms-region-nav-main-nav" class="tncms-region-nav"><ul id="main-nav_menu" class="nav navbar-nav"><li class="dropdown">
                <a class="nav-link nav-home dropdown-toggle  tnt-section-span-class-fas-tnt-home-span"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/" >
                    <span class="nav-icon fas tnt-home tnt-fw"></span> <span class="nav-label sr-only"><span class="fas tnt-home"></span></span>
                </a><ul id="main-nav_menu-child-1" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-about-us"  href="/site/about-us.html" >
                    <span class="nav-label ">About Us</span>
                </a></li><li>
                <a class="nav-link  tnt-section-contact-us"  href="/site/contact-us.html" >
                    <span class="nav-label ">Contact Us</span>
                </a></li><li>
                <a class="nav-link  tnt-section-advertise-with-us"  href="/site/advertise-with-us.html" >
                    <span class="nav-label ">Advertise with Us</span>
                </a></li><li>
                <a class="nav-link  tnt-section-readers-choice-contest"  href="https://meridianstar.com/bestof"  target="_blank" rel="noopener">
                    <span class="nav-label ">Readers Choice Contest</span>
                </a></li></ul></li><li>
                <a class="nav-link  tnt-section-e-paper"  href="/e-edition" >
                    <span class="nav-label ">E-Paper</span>
                </a></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-local-events"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/events" >
                    <span class="nav-label ">Local Events</span>
                </a><ul id="main-nav_menu-child-3" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-see-all-events"  href="/events" >
                    <span class="nav-label ">See All Events</span>
                </a></li><li>
                <a class="nav-link  tnt-section-add-your-event"  href="https://portal.cityspark.com/EventEntry/EventEntry/meridianstar "  target="_blank" rel="noopener">
                    <span class="nav-label ">Add Your Event</span>
                </a></li></ul></li><li>
                <a class="nav-link  tnt-section-classifieds"  href="/classifieds/" >
                    <span class="nav-label ">Classifieds</span>
                </a></li><li>
                <a class="nav-link  tnt-section-celebrations"  href="http://celebrations.meridianstar.com/"  target="_blank" rel="noopener">
                    <span class="nav-label ">Celebrations</span>
                </a></li><li>
                <a class="nav-link  tnt-section-obituaries"  href="/obituaries/" >
                    <span class="nav-label ">Obituaries</span>
                </a></li><li>
                <a class="nav-link  tnt-section-public-notices"  href="http://notices.meridianstar.com"  target="_blank" rel="noopener">
                    <span class="nav-label ">Public Notices</span>
                </a></li><li>
                <a class="nav-link  tnt-section-magazines"  href="/magazines/" >
                    <span class="nav-label ">Magazines</span>
                </a></li></ul></div>
                            </div>
                        </div>

                        
                            <div id="navbar-asset-header">
                                <div class="title hidden-xs">
                                    FAMILY TRADITION: Popular steakhouse expands to Meridian
                                </div>
                                <div class="share-header">
                                     
                                        <div class="share-label pull-left">
                                            Share this
                                        </div>
                                        <div class="share-container">
                                            
                                        </div>
                                    
                                </div>
                            </div>
                        
                    
                </nav>
                
            </div>
            
        
    
    
    
    

    

    
        <div id="site-header-container" class="hidden-sm hidden-xs hidden-print hidden-md hidden-lg">
            <header id="site-header" class="container" role="banner">
                <!-- tecnavia no esc -->

<script type="text/javascript">
document.onkeydown = function (e) {             
        var e = e || window.event;         
        var keyCode = (e.which) ? e.which : e.keyCode;                                                        
     if(keyCode == 27){
                alert("ESC key not allowed!");
                return false;                                   
        }
}                                                     
</script>



<script type="text/javascript" src="https://meridianstar-cnhi-pw.newsmemory.com?meter&v=4" async></script>

                <div class="row">
                    <div id="masthead-full-top" class="col-lg-12"><div id="tncms-region-masthead-full-top" class="tncms-region "></div></div>
                </div>
                <div class="row">
                    
                    <div id="masthead-col-one" class="col-md-4 col-sm-4"><div id="tncms-region-masthead-col-one" class="tncms-region "><div id="tncms-block-2554873" class="tncms-block cnhi-weather-widget"><div id="weather-2554873" class="weather-current size-small pull-left">
    <ul class="list-unstyled">
        <li class="current-conditions dropdown">
            <a href="/weather/?weather_zip=39302" class="dropdown-toggle" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250" aria-label="Weather">
                <span class="icon pull-left">
                    
                        <span class="pull-left btn btn-xs btn-danger weather-alert-btn" data-toggle="tooltip" data-placement="right" title="Weather Alert"><i class="fas tnt-exclamation-triangle"></i></span>
                    
                    <span class="fas tnt-wi-night-clear"></span>
                </span>
                <span class="pull-left temp-desc small">
                    <span class="temp">64&deg;</span>
                    
                </span>
                <span class="clearfix"></span>
            </a>
            
                <ul class="dropdown-menu" role="menu">
                    <li role="presentation">
                        <div class="weather-expanded">
                            <form action="/weather/" class="zip-update-form form-inline" method="get">
                                <input type="text" class="zip-update form-control" name="weather_zip" title="Weather Zip Code" value="39302">
                                <input class="btn btn-primary" type="submit" value="GO">
                            </form>

                            <a id="weather_zip_toggle_2554873" class="pull-right zip-update-link" aria-label="weather_zip_toggle"><span class="fas tnt-cog"></span></a><h4 class="city-title"><i class="fas tnt-map-marker-alt"></i>
                                
                                    Meridian, MS
                                
                                <small>(39302)</small>
                            </h4><h5>Today</h5>
                                <p>Mostly clear. Low 52F. Winds light and variable..
                                </p>
                                <h5>Tonight</h5>
                                <p>Mostly clear. Low 52F. Winds light and variable.</p>
                                <p class="text-center"><small><i class="fas tnt-info-circle"></i> Updated: September 26, 2022 @ 8:19 pm</small></p></div>
                    </li>
                    <li role="separator" class="divider"></li>
                    <li role="menuitem" class="forecast-link text-center">
                        <a href="/weather/?weather_zip=39302"><i class="fas tnt-caret-right"></i> Full Forecast</a>
                    </li>
                </ul>
            
        </li>
    </ul>
</div>

    <div class="clearfix"></div>
</div><div id="tncms-block-2554870" class="tncms-block"><!-- weather button atf -->
<div id='adb_weather_atf'></div></div></div></div>
    <div id="masthead-col-two" class="col-md-4 col-sm-4"><div id="tncms-region-masthead-col-two" class="tncms-region "><div id="tncms-block-2574946" class="tncms-block"><div id="site-logo-2574946" class="site-logo-container text-center" ><div class="logo-middle">
            <a  href="/" aria-label="Home page"><img 
            
            src="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/media/b/95/b95756fe-eda4-11ec-b338-cf296972574f/62ab7aac26818.image.png?resize=200%2C32" 
            srcset="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/media/b/95/b95756fe-eda4-11ec-b338-cf296972574f/62ab7aac26818.image.png?resize=150%2C24 150w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/media/b/95/b95756fe-eda4-11ec-b338-cf296972574f/62ab7aac26818.image.png?resize=200%2C32 200w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/media/b/95/b95756fe-eda4-11ec-b338-cf296972574f/62ab7aac26818.image.png?resize=225%2C36 225w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/media/b/95/b95756fe-eda4-11ec-b338-cf296972574f/62ab7aac26818.image.png?resize=300%2C48 300w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/media/b/95/b95756fe-eda4-11ec-b338-cf296972574f/62ab7aac26818.image.png?resize=400%2C65 400w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/media/b/95/b95756fe-eda4-11ec-b338-cf296972574f/62ab7aac26818.image.png?resize=540%2C87 540w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/media/b/95/b95756fe-eda4-11ec-b338-cf296972574f/62ab7aac26818.image.png?resize=640%2C103 640w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/media/b/95/b95756fe-eda4-11ec-b338-cf296972574f/62ab7aac26818.image.png 750w"
            sizes="(min-width: 1200px) 380px, calc(33.33vw - 30px)"
            
            class=" img-responsive lazyload tnt-prop-img"
            width="750"
            height="121"
            alt="site-logo"
            ></a>
        </div><div class="logo-bottom"><div class="logo-date">
                Monday, September 26, 2022
            </div>
        <ul class="list-inline block-links pos-bottom ">
            
                
                    <li><a href="/e-edition" class="">E-Paper</a></li>
                
            
            
        </ul></div></div></div></div></div>
    <div id="masthead-col-three" class="col-md-4 col-sm-4"><div id="tncms-region-masthead-col-three" class="tncms-region "><div id="tncms-block-2554879" class="tncms-block"><div class="follow-links-2554879 pull-right">
    
    <section id="block-2554879" class="block emphasis-h3   " ><ul class="list-inline">
    
            <li>
                <a href="https://visitor.r20.constantcontact.com/d.jsp?llr=99oml49ab&p=oi&m=1128481045338&sit=s5fwgcwlb&f=e95c0a03-8db9-4d2a-98d3-7dffa92feef5" title="newsletter" target="_blank" class="btn btn-md btn-link fs">
                    <i class="fas tnt-envelope"></i>
                    <span class="sr-only">Newsletter</span>
                </a>
            </li>
        
        
        
        
        
        
        
        
        
        
        
    </ul>
    </section>
</div>
<script type="application/ld+json">
{ "@context" : "http://schema.org",
  "@type" : "Organization",
  "url" : "http://www.meridianstar.com",
  "sameAs" : ["https://visitor.r20.constantcontact.com/d.jsp?llr=99oml49ab&p=oi&m=1128481045338&sit=s5fwgcwlb&f=e95c0a03-8db9-4d2a-98d3-7dffa92feef5"] 
}
</script>
<div class="clearfix"></div>
    <script>
        jQuery(document).ready(function(){
            $('.follow-links-2554879 li a').tooltip({
                placement:'bottom'
            });
        });
    </script>
</div><div id="tncms-block-2554876" class="tncms-block cnhi-search"><section id="block-2554876" class="block emphasis-h3   " >
    <div class="clearfix"></div>
    <div id="search-form-2554876" class="search-form-container card clearfix text-center ">
    <form id="site-search-2554876" action="/search/" method="GET" >
    <input type="hidden" name="l" value="25">
    <input type="hidden" name="sd" value="desc">
    <input type="hidden" name="s" value="start_time">
    <input type="hidden" name="f" value="html">
    <input type="hidden" name="app" value="editorial">
    <div class="site-search-form input-group pull-right normal form-control">
        <input id="site-search-2554876-term" name="q" type="text" placeholder="Search..." class="form-control" autocomplete="off">
        <input type="submit" class="hide" value="Search">
        <span class="input-group-btn">
            <button id="site-search-2554876-btn" class="btn btn-link" type="submit">
                
            </button>
        </span>
    </div>
    <input type="hidden" name="nsa" value="eedition">
    <div class="clearfix"></div>
</form>
        
        
        <div class="clearfix"></div>
    </div>
    </section><style>
    #site-search-2554876 .search-spinner { position: absolute; }
    #site-search-2554876 .input-group-btn:last-child>.btn, .input-group-btn:last-child>.btn-group {margin-left: 0;}#search-form-2554876 { margin-bottom:0; }
        #site-search-2554876 .site-search-form { padding:0; }
        #site-search-2554876 #site-search-2554876-btn {
            outline: none;}
        #site-search-2554876 #site-search-2554876-term { border:0; box-shadow: none; }
    
    

    
</style> 

<script>
    $('#site-search-2554876-btn').on(__tnt.client.clickEvent, function(){
        $('#site-search-2554876').submit();
        return false;
    });

    $('#site-search-2554876').on('submit', function(){
        if( $('#site-search-2554876-term').val() ){
            $('#site-search-2554876-btn .fa').removeClass('fa-search').addClass('fa-spinner fa-spin');
            return true;
        }else{
            return false;
        }
    });</script></div><div id="tncms-block-2554882" class="tncms-block"><div class="viafoura cnhi-viafoura cnhi-viafoura-top">
 <vf-tray-trigger></vf-tray-trigger>
</div></div></div></div>
                </div>
                <div class="row">
                    <div id="masthead-full-bottom" class="col-lg-12"><div id="tncms-region-masthead-full-bottom" class="tncms-region "><div id="tncms-block-2574853" class="tncms-block hidden-xs">

<!-- leaderboard mid -->
<div class="clear" style="padding-top:10px"></div>
<div id='adb_leaderboard_mid' style="width:100%;text-align:center"></div>
<div class="clear" style="padding-bottom:10px"></div>

</div><div id="tncms-block-2574949" class="tncms-block pediment"><section id="block-2574949" class="block emphasis-h3    tnt-no-margin-bottom" ><div class="promo-box image-md">
        
            
            <article id="card-showcase-492ad90f-8dec-5ec5-8c98-b4104552cde7" class="clearfix tnt-asset-type-article card showcase position-0 odd tnt-flag-featured  tnt-section-news tnt-sub-section-local-news">
            <div class="card-container"><div class="card-image ">
                <div class="media-preview-492ad90f-8dec-5ec5-8c98-b4104552cde7 media-preview article-asset " data-aspect="16:9"><figure class="photo layout-horizontal letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/news/local_news/group-looks-to-preserve-e-f-young-hotel-signs/article_492ad90f-8dec-5ec5-8c98-b4104552cde7.html" class="tnt-asset-link"  aria-label="Group looks to preserve E.F. Young Hotel signs">
                
                
                
                
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAABAAAAAJCAQAAACRI2S5AAAAEklEQVR42mM8U8+AFzCOKgADAHdUC60wg0dkAAAAAElFTkSuQmCC"
                            alt="Group looks to preserve E.F. Young Hotel signs"
                            class="img-responsive lazyload full default"
                            width="800"
                            height="450"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/8/3e/83ee5154-83d5-5580-a486-abae04b4acde/6331d71e92550.image.jpg?crop=800%2C450%2C0%2C42&resize=150%2C84&order=crop%2Cresize 150w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/8/3e/83ee5154-83d5-5580-a486-abae04b4acde/6331d71e92550.image.jpg?crop=800%2C450%2C0%2C42&resize=200%2C113&order=crop%2Cresize 200w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/8/3e/83ee5154-83d5-5580-a486-abae04b4acde/6331d71e92550.image.jpg?crop=800%2C450%2C0%2C42&resize=225%2C127&order=crop%2Cresize 225w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/8/3e/83ee5154-83d5-5580-a486-abae04b4acde/6331d71e92550.image.jpg?crop=800%2C450%2C0%2C42&resize=300%2C169&order=crop%2Cresize 300w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/8/3e/83ee5154-83d5-5580-a486-abae04b4acde/6331d71e92550.image.jpg?crop=800%2C450%2C0%2C42&resize=400%2C225&order=crop%2Cresize 400w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/8/3e/83ee5154-83d5-5580-a486-abae04b4acde/6331d71e92550.image.jpg?crop=800%2C450%2C0%2C42&resize=540%2C304&order=crop%2Cresize 540w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/8/3e/83ee5154-83d5-5580-a486-abae04b4acde/6331d71e92550.image.jpg?crop=800%2C450%2C0%2C42&resize=640%2C360&order=crop%2Cresize 640w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/8/3e/83ee5154-83d5-5580-a486-abae04b4acde/6331d71e92550.image.jpg?crop=800%2C450%2C0%2C42&resize=750%2C422&order=crop%2Cresize 750w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/8/3e/83ee5154-83d5-5580-a486-abae04b4acde/6331d71e92550.image.jpg?crop=800%2C450%2C0%2C42&resize=800%2C450&order=crop%2Cresize 990w" />
                </a>
                
            </div>
            
        </figure></div>
            </div><div class="card-body">
        <div class="card-headline"><h3 class="tnt-headline ">
        
             <a href="/news/local_news/group-looks-to-preserve-e-f-young-hotel-signs/article_492ad90f-8dec-5ec5-8c98-b4104552cde7.html" class="tnt-asset-link" aria-label="Group looks to preserve E.F. Young Hotel signs">
        

        
            Group looks to preserve E.F. Young Hotel signs</a></h3></div>
    
                    </div>
            </div>
            <div class="clearfix"></div>
        </article>
            
        
            
            <article id="card-showcase-4411b3c3-08cb-5882-9871-10b47978c97d" class="clearfix tnt-asset-type-article card showcase position-1 even tnt-flag-featured  tnt-section-sports tnt-sub-section-local-sports">
            <div class="card-container"><div class="card-image ">
                <div class="media-preview-4411b3c3-08cb-5882-9871-10b47978c97d media-preview article-asset " data-aspect="16:9"><figure class="photo layout-horizontal letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/sports/local_sports/parker-leads-west-lauderdale-over-philadelphia-58-21/article_4411b3c3-08cb-5882-9871-10b47978c97d.html" class="tnt-asset-link"  aria-label="Parker leads West Lauderdale over Philadelphia 58-21">
                
                
                
                
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAABAAAAAJCAQAAACRI2S5AAAAEklEQVR42mM8U8+AFzCOKgADAHdUC60wg0dkAAAAAElFTkSuQmCC"
                            alt="Parker leads West Lauderdale over Philadelphia 58-21"
                            class="img-responsive lazyload full default"
                            width="800"
                            height="450"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/2/8f/28f69894-29d8-50b1-bf69-c04761a9a78a/6331c5a16d653.image.jpg?crop=800%2C450%2C0%2C63&resize=150%2C84&order=crop%2Cresize 150w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/2/8f/28f69894-29d8-50b1-bf69-c04761a9a78a/6331c5a16d653.image.jpg?crop=800%2C450%2C0%2C63&resize=200%2C113&order=crop%2Cresize 200w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/2/8f/28f69894-29d8-50b1-bf69-c04761a9a78a/6331c5a16d653.image.jpg?crop=800%2C450%2C0%2C63&resize=225%2C127&order=crop%2Cresize 225w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/2/8f/28f69894-29d8-50b1-bf69-c04761a9a78a/6331c5a16d653.image.jpg?crop=800%2C450%2C0%2C63&resize=300%2C169&order=crop%2Cresize 300w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/2/8f/28f69894-29d8-50b1-bf69-c04761a9a78a/6331c5a16d653.image.jpg?crop=800%2C450%2C0%2C63&resize=400%2C225&order=crop%2Cresize 400w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/2/8f/28f69894-29d8-50b1-bf69-c04761a9a78a/6331c5a16d653.image.jpg?crop=800%2C450%2C0%2C63&resize=540%2C304&order=crop%2Cresize 540w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/2/8f/28f69894-29d8-50b1-bf69-c04761a9a78a/6331c5a16d653.image.jpg?crop=800%2C450%2C0%2C63&resize=640%2C360&order=crop%2Cresize 640w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/2/8f/28f69894-29d8-50b1-bf69-c04761a9a78a/6331c5a16d653.image.jpg?crop=800%2C450%2C0%2C63&resize=750%2C422&order=crop%2Cresize 750w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/2/8f/28f69894-29d8-50b1-bf69-c04761a9a78a/6331c5a16d653.image.jpg?crop=800%2C450%2C0%2C63&resize=800%2C450&order=crop%2Cresize 990w" />
                </a>
                
            </div>
            
        </figure></div>
            </div><div class="card-body">
        <div class="card-headline"><h3 class="tnt-headline ">
        
             <a href="/sports/local_sports/parker-leads-west-lauderdale-over-philadelphia-58-21/article_4411b3c3-08cb-5882-9871-10b47978c97d.html" class="tnt-asset-link" aria-label="Parker leads West Lauderdale over Philadelphia 58-21">
        

        
            Parker leads West Lauderdale over Philadelphia 58-21</a></h3></div>
    
                    </div>
            </div>
            <div class="clearfix"></div>
        </article>
            
        
            
            <article id="card-showcase-ecd03ecf-6c97-53f7-ba8d-51d109de25d2" class="clearfix tnt-asset-type-article card showcase position-2 odd tnt-flag-featured  tnt-section-news tnt-sub-section-local-news">
            <div class="card-container"><div class="card-image ">
                <div class="media-preview-ecd03ecf-6c97-53f7-ba8d-51d109de25d2 media-preview article-asset " data-aspect="16:9"><figure class="photo layout-horizontal letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/news/local_news/william-carey-university-to-host-alumni-rally-at-the-max/article_ecd03ecf-6c97-53f7-ba8d-51d109de25d2.html" class="tnt-asset-link"  aria-label="William Carey University to host alumni rally at the MAX">
                
                
                
                
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAABAAAAAJCAQAAACRI2S5AAAAEklEQVR42mM8U8+AFzCOKgADAHdUC60wg0dkAAAAAElFTkSuQmCC"
                            alt="William Carey University to host alumni rally at the MAX"
                            class="img-responsive lazyload full default"
                            width="1600"
                            height="900"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/0/88/088fab85-67ce-5d5c-9032-980155a0a58f/6331c1fe5622c.image.jpg?crop=1600%2C900%2C0%2C84&resize=150%2C84&order=crop%2Cresize 150w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/0/88/088fab85-67ce-5d5c-9032-980155a0a58f/6331c1fe5622c.image.jpg?crop=1600%2C900%2C0%2C84&resize=200%2C113&order=crop%2Cresize 200w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/0/88/088fab85-67ce-5d5c-9032-980155a0a58f/6331c1fe5622c.image.jpg?crop=1600%2C900%2C0%2C84&resize=225%2C127&order=crop%2Cresize 225w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/0/88/088fab85-67ce-5d5c-9032-980155a0a58f/6331c1fe5622c.image.jpg?crop=1600%2C900%2C0%2C84&resize=300%2C169&order=crop%2Cresize 300w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/0/88/088fab85-67ce-5d5c-9032-980155a0a58f/6331c1fe5622c.image.jpg?crop=1600%2C900%2C0%2C84&resize=400%2C225&order=crop%2Cresize 400w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/0/88/088fab85-67ce-5d5c-9032-980155a0a58f/6331c1fe5622c.image.jpg?crop=1600%2C900%2C0%2C84&resize=540%2C304&order=crop%2Cresize 540w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/0/88/088fab85-67ce-5d5c-9032-980155a0a58f/6331c1fe5622c.image.jpg?crop=1600%2C900%2C0%2C84&resize=640%2C360&order=crop%2Cresize 640w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/0/88/088fab85-67ce-5d5c-9032-980155a0a58f/6331c1fe5622c.image.jpg?crop=1600%2C900%2C0%2C84&resize=750%2C422&order=crop%2Cresize 750w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/0/88/088fab85-67ce-5d5c-9032-980155a0a58f/6331c1fe5622c.image.jpg?crop=1600%2C900%2C0%2C84&resize=990%2C557&order=crop%2Cresize 990w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/0/88/088fab85-67ce-5d5c-9032-980155a0a58f/6331c1fe5622c.image.jpg?crop=1600%2C900%2C0%2C84&resize=1035%2C582&order=crop%2Cresize 1035w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/0/88/088fab85-67ce-5d5c-9032-980155a0a58f/6331c1fe5622c.image.jpg?crop=1600%2C900%2C0%2C84&resize=1200%2C675&order=crop%2Cresize 1200w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/0/88/088fab85-67ce-5d5c-9032-980155a0a58f/6331c1fe5622c.image.jpg?crop=1600%2C900%2C0%2C84&resize=1333%2C750&order=crop%2Cresize 1333w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/0/88/088fab85-67ce-5d5c-9032-980155a0a58f/6331c1fe5622c.image.jpg?crop=1600%2C900%2C0%2C84&resize=1476%2C830&order=crop%2Cresize 1476w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/0/88/088fab85-67ce-5d5c-9032-980155a0a58f/6331c1fe5622c.image.jpg?crop=1600%2C900%2C0%2C84&resize=1600%2C900&order=crop%2Cresize 2008w" />
                </a>
                
            </div>
            
        </figure></div>
            </div><div class="card-body">
        <div class="card-headline"><h3 class="tnt-headline ">
        
             <a href="/news/local_news/william-carey-university-to-host-alumni-rally-at-the-max/article_ecd03ecf-6c97-53f7-ba8d-51d109de25d2.html" class="tnt-asset-link" aria-label="William Carey University to host alumni rally at the MAX">
        

        
            William Carey University to host alumni rally a&hellip;</a></h3></div>
    
                    </div>
            </div>
            <div class="clearfix"></div>
        </article>
            
        
            
            <article id="card-showcase-c907d098-5c19-5c43-8a8c-6bae56c7bec4" class="clearfix tnt-asset-type-article card showcase position-3 even tnt-flag-ap tnt-flag-featured  tnt-section-news tnt-sub-section-nation-and-world">
            <div class="card-container"><div class="card-image ">
                <div class="media-preview-c907d098-5c19-5c43-8a8c-6bae56c7bec4 media-preview article-asset " data-aspect="16:9"><figure class="photo layout-horizontal letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/news/nation_and_world/texts-favre-also-sought-welfare-money-for-football-facility/article_c907d098-5c19-5c43-8a8c-6bae56c7bec4.html" class="tnt-asset-link"  aria-label="Texts: Favre also sought welfare money for football facility">
                
                
                
                
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAABAAAAAJCAQAAACRI2S5AAAAEklEQVR42mM8U8+AFzCOKgADAHdUC60wg0dkAAAAAElFTkSuQmCC"
                            alt="Texts: Favre also sought welfare money for football facility"
                            class="img-responsive lazyload ap-photo full default"
                            width="1763"
                            height="992"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/4/ea/4ea11cf5-8696-535e-9c53-c0a90fca12f3/63220a265b48f.image.jpg?crop=1763%2C992%2C0%2C91&resize=150%2C84&order=crop%2Cresize 150w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/4/ea/4ea11cf5-8696-535e-9c53-c0a90fca12f3/63220a265b48f.image.jpg?crop=1763%2C992%2C0%2C91&resize=200%2C113&order=crop%2Cresize 200w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/4/ea/4ea11cf5-8696-535e-9c53-c0a90fca12f3/63220a265b48f.image.jpg?crop=1763%2C992%2C0%2C91&resize=225%2C127&order=crop%2Cresize 225w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/4/ea/4ea11cf5-8696-535e-9c53-c0a90fca12f3/63220a265b48f.image.jpg?crop=1763%2C992%2C0%2C91&resize=300%2C169&order=crop%2Cresize 300w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/4/ea/4ea11cf5-8696-535e-9c53-c0a90fca12f3/63220a265b48f.image.jpg?crop=1763%2C992%2C0%2C91&resize=400%2C225&order=crop%2Cresize 400w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/4/ea/4ea11cf5-8696-535e-9c53-c0a90fca12f3/63220a265b48f.image.jpg?crop=1763%2C992%2C0%2C91&resize=540%2C304&order=crop%2Cresize 540w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/4/ea/4ea11cf5-8696-535e-9c53-c0a90fca12f3/63220a265b48f.image.jpg?crop=1763%2C992%2C0%2C91&resize=640%2C360&order=crop%2Cresize 640w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/4/ea/4ea11cf5-8696-535e-9c53-c0a90fca12f3/63220a265b48f.image.jpg?crop=1763%2C992%2C0%2C91&resize=750%2C422&order=crop%2Cresize 750w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/4/ea/4ea11cf5-8696-535e-9c53-c0a90fca12f3/63220a265b48f.image.jpg?crop=1763%2C992%2C0%2C91&resize=990%2C557&order=crop%2Cresize 990w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/4/ea/4ea11cf5-8696-535e-9c53-c0a90fca12f3/63220a265b48f.image.jpg?crop=1763%2C992%2C0%2C91&resize=1035%2C582&order=crop%2Cresize 1035w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/4/ea/4ea11cf5-8696-535e-9c53-c0a90fca12f3/63220a265b48f.image.jpg?crop=1763%2C992%2C0%2C91&resize=1200%2C675&order=crop%2Cresize 1200w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/4/ea/4ea11cf5-8696-535e-9c53-c0a90fca12f3/63220a265b48f.image.jpg?crop=1763%2C992%2C0%2C91&resize=1333%2C750&order=crop%2Cresize 1333w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/4/ea/4ea11cf5-8696-535e-9c53-c0a90fca12f3/63220a265b48f.image.jpg?crop=1763%2C992%2C0%2C91&resize=1476%2C830&order=crop%2Cresize 1476w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/4/ea/4ea11cf5-8696-535e-9c53-c0a90fca12f3/63220a265b48f.image.jpg?crop=1763%2C992%2C0%2C91&resize=1763%2C992&order=crop%2Cresize 2008w" />
                </a>
                
            </div>
            
        </figure></div>
            </div><div class="card-body">
        <div class="card-headline"><h3 class="tnt-headline ">
        
             <a href="/news/nation_and_world/texts-favre-also-sought-welfare-money-for-football-facility/article_c907d098-5c19-5c43-8a8c-6bae56c7bec4.html" class="tnt-asset-link" aria-label="Texts: Favre also sought welfare money for football facility">
        

        
            Texts: Favre also sought welfare money for foot&hellip;</a></h3></div>
    
                    </div>
            </div>
            <div class="clearfix"></div>
        </article>
            
        
    </div></section></div></div></div>
                </div>
                
            </header>
        </div>
    

    
    <div id="main-body-container">
    <section id="main-top-container" class="container-fullscreen-region container-fluid">
        
        <div class="fullscreen-region"><div id="tncms-region-global-container-top-fullscreen" class="tncms-region "><div id="tncms-block-2574940" class="tncms-block padding-top padding-bottom"></div><div id="tncms-block-2578534" class="tncms-block"><section id="block-2578534" class="block emphasis-   " ><div class="clearfix"></div>


<div class="weather-alert-2578534 breaking row ">
    <div class="card card-panel panel">
        <div class="col-md-2">
            <div class="breaking-label"><h4><i style="margin-right: 5px;" class="fas tnt-exclamation-triangle"></i>Weather Alert</h4></div>
        </div>
        <div class="col-md-10">
            <div id="weather-alert-2578534">
                
                    
                        <div class="weather-alert">
                            <a style="cursor: pointer" data-toggle="modal" data-target=".alert-modal-02578534">
                                <h4>Fire Weather Watch from WED 9:00 AM CDT until WED 8:00 PM CDT</h4>
                            </a>
                        </div>
                    
                
            </div>
        </div>
    <div class="clearfix"></div>
    </div>
    </div>
    <div class="alert-modal-02578534 modal fade">
        <div class="modal-dialog modal-lg">
            <div class="modal-content">
                <div class="modal-header">
                    <button type="button" class="close" data-dismiss="modal" aria-hidden="true">
                    <span class="fas tnt-times-circle"></span>
                    </button>
                    <h4 class="modal-title">Weather Alert</h4>
                </div>
                <div class="modal-body">
                    <pre>...FIRE WEATHER WATCH IN EFFECT FROM 9 AM CDT WEDNESDAY MORNING
THROUGH 8 PM CDT WEDNESDAY EVENING FOR PORTIONS OF FAR SOUTHEAST
ARKANSAS, NORTHEAST LOUISIANA, AND THE STATE OF MISSISSIPPI...

The National Weather Service in Jackson has issued a Fire Weather
Watch, which is in effect from Wednesday morning through
Wednesday evening.

* AFFECTED AREA...In Arkansas...Ashley and Chicot Counties. In
Louisiana...Morehouse, West Carroll, East Carroll, Richland,
Madison, Franklin, Catahoula, Tensas, and Concordia Parishes. In
Mississippi...Bolivar, Sunflower, Leflore, Grenada, Carroll,
Montgomery, Webster, Clay, Lowndes, Choctaw, Oktibbeha,
Washington, Humphreys, Holmes, Attala, Winston, Noxubee,
Issaquena, Sharkey, Yazoo, Madison, Leake, Neshoba, Kemper,
Warren, Hinds, Rankin, Scott, Newton, Lauderdale, Claiborne,
Copiah, Simpson, Smith, Jasper, Clarke, Jefferson, Adams,
Franklin, Lincoln, Lawrence, Jefferson Davis, Covington, Jones,
Marion, Lamar, and Forrest Counties.

* WIND...Northeast at 15 to 20 mph with gusts up to 30 mph.

* HUMIDITY...As low as 20 to 25 percent.

* IMPACTS...Any fires that develop will likely spread rapidly.
Outdoor burning is not recommended.

PRECAUTIONARY/PREPAREDNESS ACTIONS...

A Fire Weather Watch means that critical fire weather conditions
are forecast to occur. Listen for later forecasts and possible
Red Flag Warnings.

&&

</pre>
                </div>
            </div>
        </div>
    </div>

</section>
</div></div></div>
    </section>
    <section id="main-page-container" class="container">
        <div class="row">
                <div id="asset-container-top" class="col-md-12"><div id="tncms-region-asset_container_top" class="tncms-region hidden-print"></div></div>
            
            <div class="col-md-12"><div id="tncms-region-global-container-top" class="tncms-region "><div id="tncms-block-2574829" class="tncms-block visible-xs"><!-- Mobile Banner ATF  -->

<div id="adb_mobileBanner_atf_flex" style="width:100%;text-align:center" class="visible-xs visible-sm"></div>
<div class="clear" style="padding-bottom:10px"></div>
</div><div id="tncms-block-2574826" class="tncms-block"></div></div></div>
        </div><div class="modal fullscreen" id="photo-carousel-78352ec9-bf29-5878-a3df-8593459d9946" tabindex="-1" role="dialog" aria-labelledby="photo-carousel-78352ec9-bf29-5878-a3df-8593459d9946" aria-hidden="true">
        <div class="modal-dialog modal-lg">
            <div class="modal-content">
                <div class="modal-body">
                    <button type="button" class="close" data-dismiss="modal">
                        <span aria-hidden="true" class="control-left fas tnt-times-circle"></span>
                        <span class="sr-only">Close</span>
                    </button>
                    
    <div id="carousel-78352ec9-bf29-5878-a3df-8593459d9946-photo-modal" class="card photo-carousel    subscriber-hide letterbox-style-default">
            
            <div class="photo-carousel-control-container">
                    <span class="photo-count">
                        <span class="current-count">1</span> of 2
                    </span>
                    <a class="photo-carousel-control left noselect hidden-print"><span class="control-left fas tnt-chevron-left"></span></a>
                    <a class="photo-carousel-control right noselect hidden-print"><span class="control-left fas tnt-chevron-right"></span></a>
            </div>
            
            <div id="gallery-items-78352ec9-bf29-5878-a3df-8593459d9946-photo-modal" class="carousel-inner"><div  class="item photo-2dfa7db8-3dbb-11ed-9d74-eb8dad246edb">
                            <div class="item-container">
                                <div data-track-object='{"title":"FAMILY TRADITION: Popular steakhouse expands to Meridian","url":"/news/local_news/family-tradition-popular-steakhouse-expands-to-meridian/article_78352ec9-bf29-5878-a3df-8593459d9946.html","uuid":"78352ec9-bf29-5878-a3df-8593459d9946","app":"editorial","metric":""}'  data-count="1"  class="photo-container layout-horizontal"><div class="loading-slide text-center"><i class="fas tnt-spinner tnt-spin"></i></div>
                                        
                                        
                                        
                                        
                <img
                    src="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/2/df/2dfa7db8-3dbb-11ed-9d74-eb8dad246edb/6331d8388ebad.image.jpg?resize=632%2C500"
                    
                    alt="steak house 1"
                    class="img-responsive owl-first-image owl-lazy default"
                    width="1619"
                    height="1280"
                    data-src="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/2/df/2dfa7db8-3dbb-11ed-9d74-eb8dad246edb/6331d8388ebad.image.jpg?resize=632%2C500" />
                                        
                                        
                                </div>
        <div class="caption-container">
                <span class="pull-right photo-carousel-caption-toggle" data-toggle="collapse" data-instance="#carousel-78352ec9-bf29-5878-a3df-8593459d9946-photo-modal" data-target=".caption-inner-78352ec9-bf29-5878-a3df-8593459d9946-photo-modal">
                    <i class="fas tnt-minus-circle"></i>
                </span>
            <div class="caption-inner-78352ec9-bf29-5878-a3df-8593459d9946-photo-modal collapse in"><div class="caption-text"><p>Photos by D'Courtland Christian / The Meridian Star</p><p>Owner Blake Dial stands in front of the new location for Diamond Jim’s &amp; Mrs. Donna’s Ole Farm Beef House, which is set to open on Oct. 19.</p></div><div class="card-meta">
                        <ul class="list-inline">
                                    
                                    
                                
                            
                        </ul>
                    </div>
                    <div class="photo-share">
                        
                    </div>
            </div>
        </div>
    <div class="clearfix"></div>
                            </div>
                        </div><div  class="item photo-5ce10a70-3dbb-11ed-9ff4-739c2efd1b3b">
                            <div class="item-container">
                                <div data-track-object='{"title":"FAMILY TRADITION: Popular steakhouse expands to Meridian","url":"/news/local_news/family-tradition-popular-steakhouse-expands-to-meridian/article_78352ec9-bf29-5878-a3df-8593459d9946.html","uuid":"78352ec9-bf29-5878-a3df-8593459d9946","app":"editorial","metric":""}'  data-count="2"  class="photo-container layout-horizontal"><div class="loading-slide text-center"><i class="fas tnt-spinner tnt-spin"></i></div>
                                        
                                        
                                        
                                        
                <img
                    src="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/5/ce/5ce10a70-3dbb-11ed-9ff4-739c2efd1b3b/6331d88b69449.image.jpg?resize=709%2C500"
                    
                    alt="steak 2"
                    class="img-responsive owl-first-image owl-lazy default"
                    width="1714"
                    height="1209"
                    data-src="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/5/ce/5ce10a70-3dbb-11ed-9ff4-739c2efd1b3b/6331d88b69449.image.jpg?resize=709%2C500" />
                                        
                                        
                                </div>
        <div class="caption-container">
                <span class="pull-right photo-carousel-caption-toggle" data-toggle="collapse" data-instance="#carousel-78352ec9-bf29-5878-a3df-8593459d9946-photo-modal" data-target=".caption-inner-78352ec9-bf29-5878-a3df-8593459d9946-photo-modal">
                    <i class="fas tnt-minus-circle"></i>
                </span>
            <div class="caption-inner-78352ec9-bf29-5878-a3df-8593459d9946-photo-modal collapse in"><div class="caption-text"><p><span>Remodeling for the Diamond Jim’s &amp; Mrs. Donna’s Ole Farm Beef House continues as opening day is set for Oct. 19.</span></p></div><div class="card-meta">
                        <ul class="list-inline">
                                    
                                    
                                
                            
                        </ul>
                    </div>
                    <div class="photo-share">
                        
                    </div>
            </div>
        </div>
    <div class="clearfix"></div>
                            </div>
                        </div>
            </div>
        </div>
                    <div class="clearfix"></div>
                </div>
            </div>
        </div>
    </div><article itemscope itemtype="https://schema.org/Article" id="asset-78352ec9-bf29-5878-a3df-8593459d9946" class="asset article-default"  data-url="https://www.meridianstar.com/news/local_news/family-tradition-popular-steakhouse-expands-to-meridian/article_78352ec9-bf29-5878-a3df-8593459d9946.html">
    <span itemscope itemtype="http://schema.org/SpeakableSpecification">
        <meta itemprop="cssSelector" content=".asset-header .headline" />
        <meta itemprop="cssSelector" content=".asset-content p:first-of-type" />
    </span>
    <meta itemprop="description" content="Local steak lovers will no longer have to travel to Alabama as a popular Livingston restaurant is expanding to Meridian. "/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
        <div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="url" content="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/2/df/2dfa7db8-3dbb-11ed-9d74-eb8dad246edb/6331d8388ebad.image.jpg?crop=1619%2C850%2C0%2C215&resize=1200%2C630&order=crop%2Cresize">
            <meta itemprop="width" content="1200">
            <meta itemprop="height" content="630">
        </div>
        <meta itemprop="name" content="meridianstar.com">
    </div>
    <link itemprop="mainEntityOfPage" href="https://www.meridianstar.com/news/local_news/family-tradition-popular-steakhouse-expands-to-meridian/article_78352ec9-bf29-5878-a3df-8593459d9946.html" />
    <div class="asset-paging-container hidden-print" data-settings='{"assetType":"article","hasPageBreak":false,"isObit":false,"nextUrl":"https:\/\/www.meridianstar.com\/tncms\/search\/mlt\/?origin=78352ec9-bf29-5878-a3df-8593459d9946&app=editorial&preview=1&type=article%2Ccollection%2Cvideo%2Cyoutube","uuid":"78352ec9-bf29-5878-a3df-8593459d9946","isFluid":false,"isAdminVenue":false}'>
            <div id="asset-paging-78352ec9-bf29-5878-a3df-8593459d9946" class="asset-paging">
                <div id="paging-prev-78352ec9-bf29-5878-a3df-8593459d9946" class="paging-link prev offset"></div>
                <div id="paging-next-78352ec9-bf29-5878-a3df-8593459d9946" class="paging-link next offset"></div>
                <div class="clearfix"></div>
            </div>
        </div>
        <template id="asset-paging-template">
            <a class="animate arrow text-center">
                <span class=""></span>
                <span class="animate direction hidden-sm hidden-xs text-primary"></span>
            </a>
            <div class="animate item">
                <div class="dismiss" onclick="document.body.classList.add('trigger-disabled'); document.body.classList.remove('trigger-next'); return false;">
                    <span class="tnt-stack" aria-hidden="true">
                        <i class="fas tnt-circle tnt-inverse tnt-stack-1x"></i>
                        <i class="fas tnt-times-circle tnt-stack-1x"></i>
                    </span>
                </div>
                <div class="inner">
                    <a class="overlay">
                        <span class="sr-only"></span>
                    </a>
                    <div class="head text-uppercase">
                        <small></small>
                    </div>
                    <div class="media">
                        <div class="media-body">
                            <h6 class="media-heading"></h6>
                            <p class="hidden-xs"></p>
                        </div>
                    </div>
                    <div class="clearfix"></div>
                </div>
            </div>
        </template><div class="asset-masthead ">
        <header class="asset-header">
    <div class="tow-wrapper has-flags">
        
            <div class="asset-label-flags has-work">
                <span class="tnt-flag label label-flag label-flag-default label-flag-centerpiece">centerpiece</span> 
            </div>
        
        
    </div>
    <h1 itemprop="headline" class="headline">
        <span>
            
            FAMILY TRADITION: Popular steakhouse expands to Meridian
        </span>
    </h1>
    <div class="meta">
        <span>
            <ul class="list-inline">
        <li><span id="author-popup-a4029950-f6f8-11ec-88f9-2793ac029710-asset-78352ec9-bf29-5878-a3df-8593459d9946" class="tnt-byline asset-byline" rel="popover" itemprop="author"><a href="https://www.meridianstar.com/users/profile/dchristian">By D'Courtland Christian dchristian@themeridianstar.com</a></span>
                
                    <div id="author-popup-a4029950-f6f8-11ec-88f9-2793ac029710-asset-78352ec9-bf29-5878-a3df-8593459d9946-content" class="hide">
                        <article class="clearfix card author popup-content card-author-a4029950-f6f8-11ec-88f9-2793ac029710">
                <div class="card-container">
                    <div class="media-list">
                        <div class="media">
                            
                                <div class="avatar-box pull-left hidden-print">
                                    <a href="https://www.meridianstar.com/users/profile/dchristian" class="tnt-user-profile-link user-profile-link card-image media-object" rel="author">
                                        <img alt="dchristian" src="https://secure.gravatar.com/avatar/a95bf10c54ad55c5a917189fdd020731?s=100&d=mm&r=g" width="200" height="200" loading="lazy" class="img-responsive lazyload tnt-user-avatar" />
                                    </a>
                                </div>
                            

                            <div class="media-body ">
                                <h4 class="media-heading">
                                    <a href="https://www.meridianstar.com/users/profile/dchristian" rel="author" class="tnt-user-profile-link tnt-user-name">dchristian</a>
                                </h4>
    
        <ul class="list-inline social-links hidden-print">
            <li>
                <a href="mailto:dchristian@themeridianstar.com" title="Email">
                    <span class="sr-only">Author email</span>
                    <span class="tnt-stack">
                        
                        <i class="fas tnt-envelope tnt-stack-1x"></i>
                    </span>
                </a>
            </li>
    </ul></div>
                        </div>
                    </div>
                </div>
            </article>
                    </div>
                    <script>
                        $('#author-popup-a4029950-f6f8-11ec-88f9-2793ac029710-asset-78352ec9-bf29-5878-a3df-8593459d9946').popover({
                            content: $('#author-popup-a4029950-f6f8-11ec-88f9-2793ac029710-asset-78352ec9-bf29-5878-a3df-8593459d9946-content').html(),
                            container: 'body',
                            html:true,
                            sanitize: false,
                            trigger:'hover',
                            placement:'top',
                            delay:{ show:100, hide:200 }
                        });
                    </script>
                </li>
        
        
            <li class="visible-print">
        <time datetime="2022-09-26T12:01:00-05:00" class="tnt-date asset-date text-muted">
            Sep 26, 2022
        </time></li>
            <li class="hidden-print">
        <time datetime="2022-09-26T12:01:00-05:00" class="tnt-date asset-date text-muted">8 hrs ago</time></li>
        
        
            <li class="hidden-print"></li>
        
        
    </ul>
        </span>
    </div>
    <meta itemprop="dateCreated" content="2022-09-26T12:01:00-05:00">
    <meta itemprop="datePublished" content="2022-09-26T12:01:00-05:00">
    <meta itemprop="dateModified" content="2022-09-26T12:01:00-05:00">
</header>
        
        
            <div class="share-container headline-right pull-right hidden-xs" data-subscription-required-remove></div>
        
    </div>

    

    <div class="row">
        <div class="main-content col-lg-8 col-md-7 has-sidebar"><div class="main-content-wrap">
            <div id="tncms-region-article_top" class="tncms-region hidden-print"></div>
            
            

            <div id="tncms-region-article_top_content" class="tncms-region hidden-print"></div>

            <div id="asset-content" data-asset-uuid="78352ec9-bf29-5878-a3df-8593459d9946">
                

                <div class="row">
                    <div class="col-lg-12 col-md-12 col-sm-12" data-subscription-required-class="col-xs-12">
                        
                        <div class="asset-body" data-subscription-required-class="asset-body">
                            
                                <div class="share-container content-above" data-subscription-required-remove></div>
                            

                            

<div class="viafoura cnhi-viafoura"><vf-tray-trigger></vf-tray-trigger></div>

<div style="margin-bottom:20px">
  <a href="https://www.facebook.com/sharer/sharer.php?u=https://www.meridianstar.com/news/local_news/family-tradition-popular-steakhouse-expands-to-meridian/article_78352ec9-bf29-5878-a3df-8593459d9946.html" class="popup"
    style="padding:10px;text-decoration:none" data-toggle="new-window" data-new-window-width="500"
    data-new-window-height="300" title="Facebook">
    <span class="rrssb-icon">
      <svg xmlns="http://www.w3.org/2000/svg" width="20" height="20" viewBox="0 0 29 29">
        <path
          d="M26.4 0H2.6C1.714 0 0 1.715 0 2.6v23.8c0 .884 1.715 2.6 2.6 2.6h12.393V17.988h-3.996v-3.98h3.997v-3.062c0-3.746 2.835-5.97 6.177-5.97 1.6 0 2.444.173 2.845.226v3.792H21.18c-1.817 0-2.156.9-2.156 2.168v2.847h5.045l-.66 3.978h-4.386V29H26.4c.884 0 2.6-1.716 2.6-2.6V2.6c0-.885-1.716-2.6-2.6-2.6z" />
        </svg>
    </span>
  </a>
  <a href="https://twitter.com/intent/tweet?text=https://www.meridianstar.com/news/local_news/family-tradition-popular-steakhouse-expands-to-meridian/article_78352ec9-bf29-5878-a3df-8593459d9946.html%20%7C%20FAMILY TRADITION: Popular steakhouse expands to Meridian"
    class="popup" style="padding:10px;text-decoration:none" data-toggle="new-window" data-new-window-width="500"
    data-new-window-height="300" title="Twitter">
    <span class="rrssb-icon">
      <svg xmlns="http://www.w3.org/2000/svg" width="20" height="20" viewBox="0 0 28 28">
        <path
          d="M24.253 8.756C24.69 17.08 18.297 24.182 9.97 24.62a15.093 15.093 0 0 1-8.86-2.32c2.702.18 5.375-.648 7.507-2.32a5.417 5.417 0 0 1-4.49-3.64c.802.13 1.62.077 2.4-.154a5.416 5.416 0 0 1-4.412-5.11 5.43 5.43 0 0 0 2.168.387A5.416 5.416 0 0 1 2.89 4.498a15.09 15.09 0 0 0 10.913 5.573 5.185 5.185 0 0 1 3.434-6.48 5.18 5.18 0 0 1 5.546 1.682 9.076 9.076 0 0 0 3.33-1.317 5.038 5.038 0 0 1-2.4 2.942 9.068 9.068 0 0 0 3.02-.85 5.05 5.05 0 0 1-2.48 2.71z" />
        </svg>
    </span>
  </a>
  <a href="http://www.linkedin.com/shareArticle?mini=true&amp;url=https://www.meridianstar.com/news/local_news/family-tradition-popular-steakhouse-expands-to-meridian/article_78352ec9-bf29-5878-a3df-8593459d9946.html&amp;summary=FAMILY TRADITION: Popular steakhouse expands to Meridian"
    class="popup" style="padding:10px;text-decoration:none" data-toggle="new-window" data-new-window-width="500"
    data-new-window-height="300" title="LinkedIn">
    <span class="rrssb-icon">
      <svg xmlns="http://www.w3.org/2000/svg" width="20" height="20" viewBox="0 0 28 28">
        <path
          d="M25.424 15.887v8.447h-4.896v-7.882c0-1.98-.71-3.33-2.48-3.33-1.354 0-2.158.91-2.514 1.802-.13.315-.162.753-.162 1.194v8.216h-4.9s.067-13.35 0-14.73h4.9v2.087c-.01.017-.023.033-.033.05h.032v-.05c.65-1.002 1.812-2.435 4.414-2.435 3.222 0 5.638 2.106 5.638 6.632zM5.348 2.5c-1.676 0-2.772 1.093-2.772 2.54 0 1.42 1.066 2.538 2.717 2.546h.032c1.71 0 2.77-1.132 2.77-2.546C8.056 3.593 7.02 2.5 5.344 2.5h.005zm-2.48 21.834h4.896V9.604H2.867v14.73z" />
        </svg>
    </span>
  </a>
  <a href="http://pinterest.com/pin/create/button/?url=https://www.meridianstar.com/news/local_news/family-tradition-popular-steakhouse-expands-to-meridian/article_78352ec9-bf29-5878-a3df-8593459d9946.html&amp;media=https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/2/df/2dfa7db8-3dbb-11ed-9d74-eb8dad246edb/6331d8388ebad.image.jpg?resize=760%2C601&amp;description=FAMILY TRADITION: Popular steakhouse expands to Meridian"
    style="padding:10px;text-decoration:none" data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" title="Pinterest">
    <span class="rrssb-icon">
      <svg xmlns="http://www.w3.org/2000/svg" width="20" height="20" viewBox="0 0 28 28">
        <path
          d="M14.02 1.57c-7.06 0-12.784 5.723-12.784 12.785S6.96 27.14 14.02 27.14c7.062 0 12.786-5.725 12.786-12.785 0-7.06-5.724-12.785-12.785-12.785zm1.24 17.085c-1.16-.09-1.648-.666-2.558-1.22-.5 2.627-1.113 5.146-2.925 6.46-.56-3.972.822-6.952 1.462-10.117-1.094-1.84.13-5.545 2.437-4.632 2.837 1.123-2.458 6.842 1.1 7.557 3.71.744 5.226-6.44 2.924-8.775-3.324-3.374-9.677-.077-8.896 4.754.19 1.178 1.408 1.538.49 3.168-2.13-.472-2.764-2.15-2.683-4.388.132-3.662 3.292-6.227 6.46-6.582 4.008-.448 7.772 1.474 8.29 5.24.58 4.254-1.815 8.864-6.1 8.532v.003z" />
        </svg>
    </span>
  </a>
  <a href="mailto:?subject=FAMILY TRADITION: Popular steakhouse expands to Meridian&amp;body=https://www.meridianstar.com/news/local_news/family-tradition-popular-steakhouse-expands-to-meridian/article_78352ec9-bf29-5878-a3df-8593459d9946.html" style="padding:10px;text-decoration:none" title="E-mail">
    <span class="rrssb-icon">
      <svg xmlns="http://www.w3.org/2000/svg" width="20" height="20" viewBox="0 0 28 28">
        <path
          d="M20.11 26.147c-2.335 1.05-4.36 1.4-7.124 1.4C6.524 27.548.84 22.916.84 15.284.84 7.343 6.602.45 15.4.45c6.854 0 11.8 4.7 11.8 11.252 0 5.684-3.193 9.265-7.398 9.3-1.83 0-3.153-.934-3.347-2.997h-.077c-1.208 1.986-2.96 2.997-5.023 2.997-2.532 0-4.36-1.868-4.36-5.062 0-4.75 3.503-9.07 9.11-9.07 1.713 0 3.7.4 4.6.972l-1.17 7.203c-.387 2.298-.115 3.3 1 3.4 1.674 0 3.774-2.102 3.774-6.58 0-5.06-3.27-8.994-9.304-8.994C9.05 2.87 3.83 7.545 3.83 14.97c0 6.5 4.2 10.2 10 10.202 1.987 0 4.09-.43 5.647-1.245l.634 2.22zM16.647 10.1c-.31-.078-.7-.155-1.207-.155-2.572 0-4.596 2.53-4.596 5.53 0 1.5.7 2.4 1.9 2.4 1.44 0 2.96-1.83 3.31-4.088l.592-3.72z" />
        </svg>
    </span>
  </a>
</div>
<div id="tncms-region-article_body_top" class="tncms-region hidden-print"></div>

                            <div id="article-body"  itemprop="articleBody" class="asset-content  subscriber-premium">
                                <meta itemprop="isAccessibleForFree" content="true"/>
                                
        <style>#inform-video-player-1 .inform-embed { margin-top: 10px; margin-bottom: 20px; }</style>
        <div class="inform-container inform-video-player-1">
            <div class="inform-embed"
                 data-placement-id="inform-video-player-1"
                 data-tracking-group="92122"
                 data-width="100%"
                 data-aspect-ratio="16:9"
                 ></div>
            <script>var _informq = _informq || [];_informq.push(['embed']);</script>
        </div>
                                
        <style>#inform-video-player-2 .inform-embed { margin-top: 10px; margin-bottom: 20px; }</style>
        <div class="inform-container inform-video-player-2">
            <div class="inform-embed"
                 data-placement-id="inform-video-player-2"
                 data-tracking-group="92122"
                 data-width="100%"
                 data-aspect-ratio="16:9"
                 ></div>
            <script>var _informq = _informq || [];_informq.push(['embed']);</script>
        </div>
                                <div class="inline-asset inline-image layout-horizontal  subscriber-hide  tnt-inline-asset tnt-inline-relcontent tnt-inline-image tnt-inline-relation-child tnt-inline-presentation-default tnt-inline-width-full"><figure class="photo layout-horizontal hover-expand letterbox-style-default"><span class="expand hidden-print"
               
               data-toggle="modal"
                
                    data-photo-target=".photo-2dfa7db8-3dbb-11ed-9d74-eb8dad246edb" 
                    data-instance="#gallery-items-78352ec9-bf29-5878-a3df-8593459d9946-photo-modal" 
                    data-target="#photo-carousel-78352ec9-bf29-5878-a3df-8593459d9946">
                       <span class="fas tnt-expand"></span>
                   </span>
            
            <div class="image" 
                 
                    data-toggle="modal" 
                     
                    data-photo-target=".photo-2dfa7db8-3dbb-11ed-9d74-eb8dad246edb" 
                    data-instance="#gallery-items-78352ec9-bf29-5878-a3df-8593459d9946-photo-modal" 
                    data-target="#photo-carousel-78352ec9-bf29-5878-a3df-8593459d9946">
                
                
                
                
        <div itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="width" content="1619">
            <meta itemprop="height" content="1280">
            <meta itemprop="contentUrl" content="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/2/df/2dfa7db8-3dbb-11ed-9d74-eb8dad246edb/6331d8388ebad.image.jpg?resize=1200%2C949">
            <meta itemprop="url" content="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/2/df/2dfa7db8-3dbb-11ed-9d74-eb8dad246edb/6331d8388ebad.image.jpg?resize=1200%2C949">
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                            alt="steak house 1"
                            class="img-responsive lazyload full default"
                            width="1619"
                            height="1280"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/2/df/2dfa7db8-3dbb-11ed-9d74-eb8dad246edb/6331d8388ebad.image.jpg?resize=150%2C119 150w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/2/df/2dfa7db8-3dbb-11ed-9d74-eb8dad246edb/6331d8388ebad.image.jpg?resize=200%2C158 200w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/2/df/2dfa7db8-3dbb-11ed-9d74-eb8dad246edb/6331d8388ebad.image.jpg?resize=225%2C178 225w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/2/df/2dfa7db8-3dbb-11ed-9d74-eb8dad246edb/6331d8388ebad.image.jpg?resize=300%2C237 300w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/2/df/2dfa7db8-3dbb-11ed-9d74-eb8dad246edb/6331d8388ebad.image.jpg?resize=400%2C316 400w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/2/df/2dfa7db8-3dbb-11ed-9d74-eb8dad246edb/6331d8388ebad.image.jpg?resize=540%2C427 540w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/2/df/2dfa7db8-3dbb-11ed-9d74-eb8dad246edb/6331d8388ebad.image.jpg?resize=640%2C506 640w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/2/df/2dfa7db8-3dbb-11ed-9d74-eb8dad246edb/6331d8388ebad.image.jpg?resize=750%2C593 750w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/2/df/2dfa7db8-3dbb-11ed-9d74-eb8dad246edb/6331d8388ebad.image.jpg?resize=990%2C783 990w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/2/df/2dfa7db8-3dbb-11ed-9d74-eb8dad246edb/6331d8388ebad.image.jpg?resize=1035%2C818 1035w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/2/df/2dfa7db8-3dbb-11ed-9d74-eb8dad246edb/6331d8388ebad.image.jpg?resize=1200%2C949 1200w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/2/df/2dfa7db8-3dbb-11ed-9d74-eb8dad246edb/6331d8388ebad.image.jpg?resize=1333%2C1054 1333w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/2/df/2dfa7db8-3dbb-11ed-9d74-eb8dad246edb/6331d8388ebad.image.jpg?resize=1476%2C1167 1476w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/2/df/2dfa7db8-3dbb-11ed-9d74-eb8dad246edb/6331d8388ebad.image.jpg?resize=1619%2C1280 2008w" />
            </div>
                
                
            </div>
            
                
                
                    <figcaption class="caption">
                            
                                <span class="caption-text">
                                    <p>Photos by D'Courtland Christian / The Meridian Star</p><p>Owner Blake Dial stands in front of the new location for Diamond Jim’s &amp; Mrs. Donna’s Ole Farm Beef House, which is set to open on Oct. 19.</p>
                                </span>
                            
                        
                            
                        
                        <span class="clearfix"></span>
                    </figcaption>
                
            
        </figure></div><p>Local steak lovers will no longer have to travel to Alabama as a popular Livingston restaurant is expanding to Meridian.</p><p>With the blessing from his family, Blake Dial is excited to bring Diamond Jim’s &amp; Mrs. Donna’s Ole Farm Beef House to the city. </p><script type="text/javascript">
TNCMS.AdManager.init
({
  domain: "www.meridianstar.com",
  secureDomain: "meridianstar.com",
  virtualregion: {
            popup: __tnt.ads.popup
        },
  callback: {
            expandable: __tnt.ads.expandable,
            html: __tnt.ads.html,
            image: __tnt.ads.image,
            pagecurl: __tnt.ads.curl,
            text: __tnt.ads.text,
            video: __tnt.ads.video
        }
});
</script>

        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-big-ad-top-asset","id":"fixed-big-ad-top-asset","pos":"fixed-big-ad-top-asset, atf","fold":"above","include_domain":"cnhi\/meridianstar","size":"[300,250]","height":"250","width":"300","mobile":false,"js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/meridianstar.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":null,"index_slug":null,"url":"\/news\/local_news","refresh":false}' style="display:none;"></div><div id="tncms-region-article_instory_top" class="tncms-region hidden-print"></div><p>The new restaurant, which is expected to open Oct. 19, is located in the renovated Ole Farm Beef House on Hwy. 39. </p><p>For Dial, his new venture follows a family tradition of good food and excellent service. </p><p>“My grandparents raised us in the restaurant since I was eight years old,” Dial said. “They gave us a great work ethic and the business mindset to take on the world.”</p><p>“We all just fell in love with it, obviously, and it's been really great to us and has been very successful as well,” he added.</p><p>After receiving his degree from Mississippi State, Dial said he wanted to branch out with Diamond Jim’s.</p><p>Sure enough, his vision would come to life with an opportunity available at the former Ole Farm Beef House, which closed its doors a few months ago.</p>
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-big-ad-middle-asset","id":"fixed-big-ad-middle-asset","pos":"fixed-big-ad-middle-asset, stf","fold":"span","include_domain":"cnhi\/meridianstar","size":"[300,250]","height":"250","width":"300","mobile":false,"js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/meridianstar.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":null,"index_slug":null,"url":"\/news\/local_news","refresh":false}' style="display:none;"></div><div id="tncms-region-article_instory_middle" class="tncms-region hidden-print"></div><p>“I was contacted by the owner and was given a great deal that I couldn't really turn down, but of course, I wanted to run the idea past my family,” Dial said. I had a very serious conversation with my grandfather, and with his blessing and my grandmother's, I was ready to get to work.”</p><p>“I know my family is behind me 100%, and we're going to not only make ourselves happy but hopefully the community of Meridian," he added. "They've been asking us for years to expand, but by the grace of the good Lord here we are,” he added.</p><p>Dial plans to offer the same quality of steaks that are popular at Diamond Jim’s.</p><p>“I believe people love eating at Diamond Jim’s because of our consistency,” Dial said. “We understand what it's like to have good meat and how important it is for the taste to be just right.”</p><p>“You can expect one of the best home-cooked steaks over a charcoal grill that you can put your hands on in a restaurant,” he emphasized. “I've been eating steaks all over the country, and there's honestly no better place to get one than through these doors.”</p><div class="inline-asset inline-image layout-horizontal  subscriber-hide  tnt-inline-asset tnt-inline-relcontent tnt-inline-image tnt-inline-relation-child tnt-inline-presentation-default tnt-inline-width-full"><figure class="photo layout-horizontal hover-expand letterbox-style-default"><span class="expand hidden-print"
               
               data-toggle="modal"
                
                    data-photo-target=".photo-5ce10a70-3dbb-11ed-9ff4-739c2efd1b3b" 
                    data-instance="#gallery-items-78352ec9-bf29-5878-a3df-8593459d9946-photo-modal" 
                    data-target="#photo-carousel-78352ec9-bf29-5878-a3df-8593459d9946">
                       <span class="fas tnt-expand"></span>
                   </span>
            
            <div class="image" 
                 
                    data-toggle="modal" 
                     
                    data-photo-target=".photo-5ce10a70-3dbb-11ed-9ff4-739c2efd1b3b" 
                    data-instance="#gallery-items-78352ec9-bf29-5878-a3df-8593459d9946-photo-modal" 
                    data-target="#photo-carousel-78352ec9-bf29-5878-a3df-8593459d9946">
                
                
                
                
        <div itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="width" content="1714">
            <meta itemprop="height" content="1209">
            <meta itemprop="contentUrl" content="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/5/ce/5ce10a70-3dbb-11ed-9ff4-739c2efd1b3b/6331d88b69449.image.jpg?resize=1200%2C846">
            <meta itemprop="url" content="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/5/ce/5ce10a70-3dbb-11ed-9ff4-739c2efd1b3b/6331d88b69449.image.jpg?resize=1200%2C846">
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                            alt="steak 2"
                            class="img-responsive lazyload full default"
                            width="1714"
                            height="1209"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/5/ce/5ce10a70-3dbb-11ed-9ff4-739c2efd1b3b/6331d88b69449.image.jpg?resize=150%2C106 150w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/5/ce/5ce10a70-3dbb-11ed-9ff4-739c2efd1b3b/6331d88b69449.image.jpg?resize=200%2C141 200w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/5/ce/5ce10a70-3dbb-11ed-9ff4-739c2efd1b3b/6331d88b69449.image.jpg?resize=225%2C159 225w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/5/ce/5ce10a70-3dbb-11ed-9ff4-739c2efd1b3b/6331d88b69449.image.jpg?resize=300%2C212 300w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/5/ce/5ce10a70-3dbb-11ed-9ff4-739c2efd1b3b/6331d88b69449.image.jpg?resize=400%2C282 400w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/5/ce/5ce10a70-3dbb-11ed-9ff4-739c2efd1b3b/6331d88b69449.image.jpg?resize=540%2C381 540w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/5/ce/5ce10a70-3dbb-11ed-9ff4-739c2efd1b3b/6331d88b69449.image.jpg?resize=640%2C451 640w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/5/ce/5ce10a70-3dbb-11ed-9ff4-739c2efd1b3b/6331d88b69449.image.jpg?resize=750%2C529 750w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/5/ce/5ce10a70-3dbb-11ed-9ff4-739c2efd1b3b/6331d88b69449.image.jpg?resize=990%2C698 990w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/5/ce/5ce10a70-3dbb-11ed-9ff4-739c2efd1b3b/6331d88b69449.image.jpg?resize=1035%2C730 1035w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/5/ce/5ce10a70-3dbb-11ed-9ff4-739c2efd1b3b/6331d88b69449.image.jpg?resize=1200%2C846 1200w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/5/ce/5ce10a70-3dbb-11ed-9ff4-739c2efd1b3b/6331d88b69449.image.jpg?resize=1333%2C940 1333w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/5/ce/5ce10a70-3dbb-11ed-9ff4-739c2efd1b3b/6331d88b69449.image.jpg?resize=1476%2C1041 1476w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/5/ce/5ce10a70-3dbb-11ed-9ff4-739c2efd1b3b/6331d88b69449.image.jpg?resize=1714%2C1209 2008w" />
            </div>
                
                
            </div>
            
                
                
                    <figcaption class="caption">
                            
                                <span class="caption-text">
                                    <p><span>Remodeling for the Diamond Jim’s &amp; Mrs. Donna’s Ole Farm Beef House continues as opening day is set for Oct. 19.</span></p>
                                </span>
                            
                        
                            
                        
                        <span class="clearfix"></span>
                    </figcaption>
                
            
        </figure></div><p>A few items that locals can look forward to are Diamond Jim’s world-class premium beef of the 16/18 oz ribeye, the porterhouse t-bone, 14/16 oz New York strip, and bacon wraps center fillets.</p><p>Dial also plans to incorporate the salad bar and soup station along with a brand new bar.</p><p>“The previous steak house didn’t serve alcohol here, so we’re looking to change that,” he said. “To anybody fresh off work looking to unwind from the week, can swing down to Diamond Jim's and get their cocktail with a steak of their choice and seafood or barbecue.”</p>
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-big-ad-bottom-asset","id":"fixed-big-ad-bottom-asset","pos":"fixed-big-ad-bottom-asset, btf","fold":"below","include_domain":"cnhi\/meridianstar","size":"[300,250]","height":"250","width":"300","mobile":false,"js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/meridianstar.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":null,"index_slug":null,"url":"\/news\/local_news","refresh":false}' style="display:none;"></div><div id="tncms-region-article_instory_bottom" class="tncms-region hidden-print"></div>
                                <div id="tncms-region-article_bottom_content" class="tncms-region hidden-print"><div id="tncms-block-2554705" class="tncms-block cnhi-sub-block-message">
<div id= "sub_message"></div>
<script>
function ta_paywallLoaded(){
	var loginStatus = ta_isUserLoggedIn();
	if (loginStatus == true) {
		var subMessage = document.createElement('div');
    subMessage.id = 'sub-message-top';
    subMessage.class = 'panel panel-default';
    subMessage.style.backgroundColor = '#eee';
    subMessage.style.borderRadius = '5px';
    subMessage.style.padding = '10px';
    subMessage.style.marginTop = '25px';
    subMessage.style.marginBottom = '25px';
    subMessage.innerHTML =
      '<div id="sub-message-mid" class="panel-body text-center"><div id="sub-message" style="margin:0px"><h3 style="font-family: Georgia,Times,Times New Roman,serif;">Thank you for supporting local journalism.</h3><p style="color:#999;margin-bottom:0px;font-family: Georgia,Times,Times New Roman,serif;">Get the most out of your subscription by signing up for <a style="text-decoration:underline" href="https://visitor.r20.constantcontact.com/d.jsp?llr=99oml49ab&p=oi&m=1128481045338&sit=s5fwgcwlb&f=e95c0a03-8db9-4d2a-98d3-7dffa92feef5" target="_blank">email newsletters</a> and downloading <a style="text-decoration:underline" href="/app-downloads">our app</a>.</p></div></div>';
    var element = document.getElementById("sub_message");
    element.appendChild(subMessage);
    console.log("Code Loaded!");  
 	} else {
    var subMessage = document.createElement('div');
    subMessage.id = 'sub-message-top';
    subMessage.class = 'panel panel-default';
    subMessage.style.backgroundColor = '#eee';
    subMessage.style.borderRadius = '5px';
    subMessage.style.padding = '10px';
    subMessage.style.marginTop = '25px';
    subMessage.style.marginBottom = '25px';
    subMessage.innerHTML =
      '<div id="sub-message-mid" class="panel-body text-center"><div id="sub-message" style="margin:0px"><h3 style="font-family: Georgia,Times,Times New Roman,serif;">Support local journalism.</h3><p style="color:#999;font-family: Georgia,Times,Times New Roman,serif;">We are making critical coverage of the coronavirus available for free. Please consider subscribing so we can continue to bring you the latest news and information on this developing story.</p><a role="button" class="btn btn-lg btn-success" style="border-radius:7px;text-decoration:none;color:#fff" href="/subscriptions" target="_blank">Subscribe Today</a>';
    var element = document.getElementById("sub_message");
    element.appendChild(subMessage);
    console.log("Code Loaded!");  
}
}
</script>
</div></div>
                                
        <style>#inform-video-player-3 .inform-embed { margin-top: 10px; margin-bottom: 20px; }</style>
        <div class="inform-container inform-video-player-3">
            <div class="inform-embed"
                 data-placement-id="inform-video-player-3"
                 data-tracking-group="92122"
                 data-width="100%"
                 data-aspect-ratio="16:9"
                 ></div>
            <script>var _informq = _informq || [];_informq.push(['embed']);</script>
        </div>
                            </div>

                            

                              
<!-- code here -->

    
        
            
                <div id="reaction-wrap" class="reaction-wrapper hidden-print reaction-78352ec9-bf29-5878-a3df-8593459d9946 anonymous">
                    <div id="reaction">
                        
                            <h4>React to this story:</h4>
                        
                        
                        <div id="reaction-form-wrapper">
                            
                            <form id="reaction-form" onsubmit="return" data-uuid="78352ec9-bf29-5878-a3df-8593459d9946" method="post" action="/tncms/counter/editorial/78352ec9-bf29-5878-a3df-8593459d9946/?">
                                <input type="hidden" name="subkey" value="reaction">
                                <input type="hidden" name="action" value="add" id="action">
                                <input type="hidden" name="type" value="" id="hidden-type">
                                <input type="hidden" name="id" value="78352ec9-bf29-5878-a3df-8593459d9946" id="asset-id" />
                                <div class="form-icons love" data-user-reaction-emotion="love">
                                               <label class="love-icon reaction-name" data-user-reaction-emotion="love">
                                                   <span class="emotion-name" data-user-reaction-emotion="love">Love</span>
                                                   
                                               </label>
                                               <div class="emotion-container" data-user-reaction-emotion="love">
                                                   <div class="love-icon form-emoji" data-user-reaction-emotion="love"></div>
                                                   <div id="reaction-love-count" 
                                                        class="reaction-count count-love" 
                                                        data-user-reaction-count="5" 
                                                        data-user-reaction-emotion="love">5</div>
                                               </div>
                                           </div><div class="form-icons funny" data-user-reaction-emotion="funny">
                                               <label class="funny-icon reaction-name" data-user-reaction-emotion="funny">
                                                   <span class="emotion-name" data-user-reaction-emotion="funny">Funny</span>
                                                   
                                               </label>
                                               <div class="emotion-container" data-user-reaction-emotion="funny">
                                                   <div class="funny-icon form-emoji" data-user-reaction-emotion="funny"></div>
                                                   <div id="reaction-funny-count" 
                                                        class="reaction-count count-funny" 
                                                        data-user-reaction-count="1" 
                                                        data-user-reaction-emotion="funny">1</div>
                                               </div>
                                           </div><div class="form-icons wow" data-user-reaction-emotion="wow">
                                               <label class="wow-icon reaction-name" data-user-reaction-emotion="wow">
                                                   <span class="emotion-name" data-user-reaction-emotion="wow">Wow</span>
                                                   
                                               </label>
                                               <div class="emotion-container" data-user-reaction-emotion="wow">
                                                   <div class="wow-icon form-emoji" data-user-reaction-emotion="wow"></div>
                                                   <div id="reaction-wow-count" 
                                                        class="reaction-count count-wow" 
                                                        data-user-reaction-count="0" 
                                                        data-user-reaction-emotion="wow">0</div>
                                               </div>
                                           </div><div class="form-icons sad" data-user-reaction-emotion="sad">
                                               <label class="sad-icon reaction-name" data-user-reaction-emotion="sad">
                                                   <span class="emotion-name" data-user-reaction-emotion="sad">Sad</span>
                                                   
                                               </label>
                                               <div class="emotion-container" data-user-reaction-emotion="sad">
                                                   <div class="sad-icon form-emoji" data-user-reaction-emotion="sad"></div>
                                                   <div id="reaction-sad-count" 
                                                        class="reaction-count count-sad" 
                                                        data-user-reaction-count="0" 
                                                        data-user-reaction-emotion="sad">0</div>
                                               </div>
                                           </div><div class="form-icons angry" data-user-reaction-emotion="angry">
                                               <label class="angry-icon reaction-name" data-user-reaction-emotion="angry">
                                                   <span class="emotion-name" data-user-reaction-emotion="angry">Angry</span>
                                                   
                                               </label>
                                               <div class="emotion-container" data-user-reaction-emotion="angry">
                                                   <div class="angry-icon form-emoji" data-user-reaction-emotion="angry"></div>
                                                   <div id="reaction-angry-count" 
                                                        class="reaction-count count-angry" 
                                                        data-user-reaction-count="0" 
                                                        data-user-reaction-emotion="angry">0</div>
                                               </div>
                                           </div>
                            </form>
                        </div>
                    </div>
                    <div id="reaction-form-message" class="hide">
                        <p></p>
                    </div>
                </div>
        
    


                            
                                <div class="share-container content-below" data-subscription-required-remove></div>
                            
                        </div>
                        
                    </div></div><!-- /asset-content -->

                <div id="asset-below">
                    

                    

                    

                    

                    

                    
                        <div class="asset-tags hidden-print">
                            <h4>Tags</h4>
                            <ul class="list-inline"><li>
                    <a href="/search/?k=%22steakhouse%22#tncms-source=keyword" class="tag-steakhouse label label-default" data-tncms-track-dmp='search: steakhouse' rel="nofollow">Steakhouse</a>
                </li> <li>
                    <a href="/search/?k=%22steak%22#tncms-source=keyword" class="tag-steak label label-default" data-tncms-track-dmp='search: steak' rel="nofollow">Steak</a>
                </li> <li>
                    <a href="/search/?k=%22food%22#tncms-source=keyword" class="tag-food label label-default" data-tncms-track-dmp='search: food' rel="nofollow">Food</a>
                </li> <li>
                    <a href="/search/?k=%22catering%22#tncms-source=keyword" class="tag-catering label label-default" data-tncms-track-dmp='search: catering' rel="nofollow">Catering</a>
                </li> <li>
                    <a href="/search/?k=%22restaurant%22#tncms-source=keyword" class="tag-restaurant label label-default" data-tncms-track-dmp='search: restaurant' rel="nofollow">Restaurant</a>
                </li> <li>
                    <a href="/search/?k=%22diamond%20jim%27s%22#tncms-source=keyword" class="tag-diamond-jims label label-default" data-tncms-track-dmp='search: diamond-jims' rel="nofollow">Diamond Jim's</a>
                </li> <li>
                    <a href="/search/?k=%22wrap%22#tncms-source=keyword" class="tag-wrap label label-default" data-tncms-track-dmp='search: wrap' rel="nofollow">Wrap</a>
                </li> <li>
                    <a href="/search/?k=%22salad%20bar%22#tncms-source=keyword" class="tag-salad-bar label label-default" data-tncms-track-dmp='search: salad-bar' rel="nofollow">Salad Bar</a>
                </li> <li>
                    <a href="/search/?k=%22fillet%22#tncms-source=keyword" class="tag-fillet label label-default" data-tncms-track-dmp='search: fillet' rel="nofollow">Fillet</a>
                </li> </ul>
                        </div>
                    

                    

                    
<!-- Article Recipe Block -->
<div class="ahm-tvx" style="margin-top:20px;margin-bottom:20px">

<div class='block-title title-'>
<div class='blox-title-inner text-muted'>
<h4 class='text-muted block-title-inner'>Trending Video</h4>
</div>
</div>


<!-- CNHI; TVX InContent Trending Video Exchange -->
<div style="min-width: 300px;width: 100%"><div id="ahm-vidya-2" style="display: inline-block; vertical-align: top;width: calc( 100% - 310px ); min-width: 300px;"></div><div style="display: inline-block; margin: 0 5px 0 0;"><div style="vertical-align: top;width: 300px; min-height: 50px;" id="_snup-tvx-ldgr1"></div></div></div>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-MNNWDH2');</script>
</div>
<div id="nativo-article-bottom" class="nativo-article"></div>
<!-- livefyre code * -->



<div class="viafoura cnhi-viafoura-conv">
  <vf-conversations></vf-conversations>
</div>



<!-- Article Calendar -->
<div class="row">
<div class="col-lg-6 col-md-12" style="margin-bottom:20px;text-align:center">
<div data-cswidget="1488"> </div>
    <script type="text/javascript" async defer src="//cdn.cityspark.com/wid/get.js"> </script>
</div>
<div class="col-lg-6 col-md-12" style="margin-bottom:20px;text-align:center">
<!-- mediumRectangle btf2 -->
    <div id='adb_mediumRectangle_btf2_flex' style="text-align:center"></div>
</div>
</div>



                    
                        
                            <div class="asset-author">
                                <article class="clearfix card author  card-author-a4029950-f6f8-11ec-88f9-2793ac029710">
                <div class="card-container">
                    <div class="media-list">
                        <div class="media">
                            
                                <div class="avatar-box pull-left hidden-print">
                                    <a href="https://www.meridianstar.com/users/profile/dchristian" class="tnt-user-profile-link user-profile-link card-image media-object" rel="author">
                                        <img alt="dchristian" src="https://secure.gravatar.com/avatar/a95bf10c54ad55c5a917189fdd020731?s=100&d=mm&r=g" width="200" height="200" loading="lazy" class="img-responsive lazyload tnt-user-avatar" />
                                    </a>
                                </div>
                            

                            <div class="media-body ">
                                <h4 class="media-heading">
                                    <a href="https://www.meridianstar.com/users/profile/dchristian" rel="author" class="tnt-user-profile-link tnt-user-name">dchristian</a>
                                </h4>
    
        <ul class="list-inline social-links hidden-print">
            <li>
                <a href="mailto:dchristian@themeridianstar.com" title="Email">
                    <span class="sr-only">Author email</span>
                    <span class="tnt-stack">
                        
                        <i class="fas tnt-envelope tnt-stack-1x"></i>
                    </span>
                </a>
            </li>
    </ul><div class="followed-notify-link hidden-print"><button id="follow-author-a4029950-f6f8-11ec-88f9-2793ac029710" class="followed-notify-btn btn btn-success btn-sm" disabled data-params="?a=a4029950-f6f8-11ec-88f9-2793ac029710&amp;s=start_time&amp;sd=desc" data-subject="dchristian" data-description="Whenever dchristian posts new content, you'll get an email delivered to your inbox with a link." data-name="dchristian notification" data-author-id="a4029950-f6f8-11ec-88f9-2793ac029710" data-user-url="https://www.meridianstar.com/users/">
        <i class="fas tnt-star"></i> Follow dchristian
    </button><template id="follow-this-modal-logged-in">
            <div class="modal-dialog">
                <div class="modal-content">
                    <div class="modal-header">
                        <button class="close" type="button" data-dismiss="modal">
                            <i class="fas tnt-times-circle"></i>
                            <span class="sr-only">Close</span>
                        </button>
                        <h4 class="modal-title">Get email notifications on {{subject}} daily!</h4>
                    </div>
                    <div class="modal-body">
                        <div class="alert alert-success" style="display:none;">
                            Your notification has been saved.
                        </div>
                        <div class="alert alert-danger" style="display:none;">
                            There was a problem saving your notification.
                        </div>
                        <p class="notification-description">{{description}}</p>
                        <p>Email notifications are only sent once a day, and only if there are new matching items.</p>
                        <form id="follow-notify-form" class="follow-notify-form" action="{{action}}" method="post">
                            <input class="input-notification-name" type="hidden" name="title" value="{{title}}">
                            <div class="row">
                                <div class="col-sm-6">
                                    <button class="btn btn-success btn-block follow-btn" data-tncms-track-dmp='is_followed_notifications_user'>
                                        <i class="fas tnt-spinner tnt-pulse" style="display:none;"></i> Save
                                    </button>
                                </div>
                                <div class="col-sm-6">
                                    <a class="btn btn-default btn-block" href="https://www.meridianstar.com/users/admin/savedsearch/">Manage followed notifications</a>
                                </div>
                            </div>
                        </form>
                    </div>
                </div>
            </div>
        </template>

        <template id="follow-this-modal-logged-out">
            <div class="modal-dialog modal-sm">
                <div class="modal-content">
                    <div class="modal-header">
                        <button class="close" type="button" data-dismiss="modal">
                            <i class="fas tnt-times-circle"></i>
                            <span class="sr-only">Close</span>
                        </button>
                        <h4 class="modal-title">Followed notifications</h4>
                    </div>
                    <div class="modal-body">
                        <div class="user-login padding-bottom">
                            <h4>Please log in to use this feature</h4>
                            <a class="btn btn-block btn-primary" href="https://www.meridianstar.com/users/login/?referer_url=https%3A%2F%2Fwww.meridianstar.com%2Fnews%2Flocal_news%2Ffamily-tradition-popular-steakhouse-expands-to-meridian%2Farticle_78352ec9-bf29-5878-a3df-8593459d9946.html" rel="nofollow">Log In</a>
                        </div>
                        <div class="user-signup">
                            <strong>Don't have an account?</strong> <a href="https://www.meridianstar.com/users/signup/?referer_url=https%3A%2F%2Fwww.meridianstar.com%2Fnews%2Flocal_news%2Ffamily-tradition-popular-steakhouse-expands-to-meridian%2Farticle_78352ec9-bf29-5878-a3df-8593459d9946.html" rel="nofollow">Sign Up Today</a>
                        </div>
                    </div>
                </div>
            </div>
        </template>

        <div id="follow-this-modal" class="modal fade follow-this-modal">
            <div class="modal-dialog"></div>
        </div></div></div>
                        </div>
                    </div>
                </div>
            </article>
                            </div>
                        
                    

                    <div id="tncms-region-article_bottom" class="tncms-region hidden-print"><div id="tncms-block-2580130" class="tncms-block"><div id="flipp-ux-slot-68ce2f21">
<h4 class='flipp-ux-header title mb-0' class="text-muted block-title-inner"style='padding: 0px 0px 10px 0px; display: none;'>Featured Local Savings</h4>
</div></div></div>

                    <div class="asset-comments hidden-print"></div>
                    
                    <div id="tncms-region-article_container_bottom" class="tncms-region hidden-print"></div></div>
            </div>

            

            </div>
        </div><div class="main-sidebar col-lg-4 col-md-5 hidden-print">
                <div class="main-sidebar-wrap">
                    <div id="tncms-region-article_side_top" class="tncms-region hidden-print"></div>  

<div class="row">
    <div class="col-md-12"><div id="tncms-region-option-rail-top-one" class="tncms-region "></div></div>
</div>

<div class="row">
    <div class="col-md-12"><div id="tncms-region-option-rail-top-two" class="tncms-region "></div></div>
</div>

<div class="row">
    <div class="col-md-12"><div id="tncms-region-option-rail-top-three" class="tncms-region "></div></div>
</div>

<div class="row">
    <div class="col-md-12"><div id="tncms-region-option-rail-top-four" class="tncms-region "></div></div>
</div>

<div id="tncms-region-asset_side_top" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-primary" class="tncms-region "><div id="tncms-block-2574859" class="tncms-block hidden-xs"><!-- mediumRectangle atf -->
<div id='adb_mediumRectangle_atf' style="text-align:center"></div>
<div class="clear" style="padding-bottom:10px"></div></div><div id="tncms-block-2574862" class="tncms-block visible-xs"><!-- Mobile Rectangle ATF 300x250 Section-->



</div><div id="tncms-block-2574865" class="tncms-block">


<a href="/coupondeals" type="button" class="btn btn-default btn-lg side-bar-block-title" style="width:100%;margin-bottom:5px;border-color:#999999;border-radius:5px;color:#993133">COUPON DEALS</a>




<div class="panel panel-default" style="background-color:#eeeeee;border-radius:5px !important;box-shadow: 0px 0px 0px rgba(0,0,0,0);overflow:hidden">
    <div style="width:100%;text-align:center;padding-top:5px;">

        <a href="http://newspaperads.meridianstar.com"" class="side-bar-block-title" style="color:#033265;font-size: 18px;font-weight: bold;">NEWSPAPER ADS</a>


    </div>



    <div style="margin-top:5px; padding-left:10px; width:100%;margin-top:10px;margin-bottom:10px;height:125px !important">
        <script src="https://d1gzrgn7m19oq9.cloudfront.net/widget/retailadvertiser?hostname=newspaperads.meridianstar.com">
        </script>
    </div>
    
    
    
</div>
</div><div id="tncms-block-2574871" class="tncms-block ahm-tvx hidden-sm"><div style="margin-top:20px;margin-bottom:20px" class="cnhi-ahm-rail">
<!-- CNHI (Id #10223); Right Rail TRX -->


<div class='block-title title-'>
<div class='blox-title-inner'>
<h3 class='text-muted block-title-inner'>Trending Recipes</h3>
</div>
</div>

<div id="_snup-target1"></div><div id="_snup-dug-ldgr0"></div><script src="https://japfg-trending-content.appspot.com/widgey-dug.php?s=10223&v=1&q=3&i=1"></script><script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start': new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0], j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src= 'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f); })(window,document,'script','dataLayer','GTM-MNNWDH2');</script>
</div></div><div id="tncms-block-2574868" class="tncms-block"><!-- wishabi widget -->
<div class="block-title title-1303790 ">
        <div class="block-title-inner ">
            <h4 class="text-muted block-title-inner">
                This Week's Circulars
            </h4>
        </div>
    </div>
<!-- Flipp Anchor Tag-->
<div style="margin-top:10px">
<div id="flipp-ux-slot-101g218"></div>
</div>
<div style="margin-top:10px !important">
<div id="circularhub_module_15592"></div>
<script src="//api.circularhub.com/15592/18e2ba61244fbc50/circularhub_module.js"></script>
</div></div></div>  

<div class="row">
    <div class="col-md-12"><div id="tncms-region-option-rail-middle-one" class="tncms-region "></div></div>
</div>

<div class="row">
    <div class="col-md-12"><div id="tncms-region-option-rail-middle-two" class="tncms-region "></div></div>
</div>

<div class="row">
    <div class="col-md-12"><div id="tncms-region-option-rail-middle-three" class="tncms-region "></div></div>
</div>

<div class="row">
    <div class="col-md-12"><div id="tncms-region-option-rail-middle-four" class="tncms-region "></div></div>
</div>

<div id="tncms-region-asset_side_middle" class="tncms-region hidden-print"></div><div id="tncms-region-article_side_middle" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-secondary" class="tncms-region hidden-print"><div id="tncms-block-2574937" class="tncms-block div-lines more-button overflow-scroll"><section id="block-2574937" class="block emphasis-h3   " ><div class="clearfix">
    
    <div class="block-title title-2574937 ">
        <div class="block-title-inner">
            <h3>
                
                    <a href="/obituaries">
                
                Obituaries
                
                    </a>
                
            </h3>
        </div>
    </div></div>
    
    <div class="card-img-sm card-compact">
        
                
                <article id="card-summary-2574937-f0d161d6-8c16-525e-bc01-d3115e287171" class="tnt-asset-type-link clearfix card summary inherit letterbox-style-default  tnt-section-obituaries">
            <div class="card-container">
                
                <div class="card-body">
        <div class="card-headline"><h4 class="tnt-headline ">
        
             <a href="https://obituaries.meridianstar.com/obituary/janette-morris-1086301230" class="tnt-asset-link" aria-label="Morris, Janette">
        

        
            Morris, Janette</a></h4></div>
    <div class="card-meta">
            <ul class="list-inline"><li class="card-asset-icons text-muted"><i class="fas tnt-external-link-alt tnt-fw" title="Link"></i></li></ul>
        </div>
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
            
                
                <article id="card-summary-2574937-c10bb428-45b8-5c5a-8207-448595d856b3" class="tnt-asset-type-link clearfix card summary inherit letterbox-style-default  tnt-section-obituaries">
            <div class="card-container">
                
                <div class="card-body">
        <div class="card-headline"><h4 class="tnt-headline ">
        
             <a href="https://obituaries.meridianstar.com/obituary/alma-davidson-1086300933" class="tnt-asset-link" aria-label="DAVIDSON, Alma May 5, 1947 - Sep 24, 2022">
        

        
            DAVIDSON, Alma May 5, 1947 - Sep 24, 2022</a></h4></div>
    <div class="card-meta">
            <ul class="list-inline"><li class="card-asset-icons text-muted"><i class="fas tnt-external-link-alt tnt-fw" title="Link"></i></li></ul>
        </div>
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
            
                
                <article id="card-summary-2574937-a0e0eee1-2cc4-5a4d-bb07-dcbda34a03a9" class="tnt-asset-type-link clearfix card summary has-image image-right inherit letterbox-style-default  tnt-section-obituaries">
            <div class="card-container"><div class="card-image ">
                        <div class="media-preview-a0e0eee1-2cc4-5a4d-bb07-dcbda34a03a9 media-preview link-asset " data-aspect="original"><figure class="photo layout-vertical letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="https://obituaries.meridianstar.com/obituary/sue-thompson-1086300964" class="tnt-asset-link"  aria-label="THOMPSON, Sue May 27, 1936 - Sep 24, 2022">
                
                
                    <div class="asset-icon"><i class="fas tnt-external-link-alt tnt-fw" title="Link"></i></div>
                
                
                <img
                    alt="THOMPSON, Sue May 27, 1936 - Sep 24, 2022"
                    src="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/a/0e/a0e0eee1-2cc4-5a4d-bb07-dcbda34a03a9/633211b42682c.preview.jpg?resize=156%2C200"
                    class="img-responsive  letterbox default"
                    loading="lazy"
                    width="1024"
                    height="1317" />
                </a>
                
            </div>
            
        </figure></div>
                    </div>
                
                <div class="card-body">
        <div class="card-headline"><h4 class="tnt-headline ">
        
             <a href="https://obituaries.meridianstar.com/obituary/sue-thompson-1086300964" class="tnt-asset-link" aria-label="THOMPSON, Sue May 27, 1936 - Sep 24, 2022">
        

        
            THOMPSON, Sue May 27, 1936 - Sep 24, 2022</a></h4></div>
    
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
            
                
                <article id="card-summary-2574937-81bc5680-03db-53c3-84cb-34728965fa39" class="tnt-asset-type-link clearfix card summary inherit letterbox-style-default  tnt-section-obituaries">
            <div class="card-container">
                
                <div class="card-body">
        <div class="card-headline"><h4 class="tnt-headline ">
        
             <a href="https://obituaries.meridianstar.com/obituary/bonnie-therrell-1086277148" class="tnt-asset-link" aria-label="THERRELL, Bonnie Feb 9, 1935 - Sep 22, 2022">
        

        
            THERRELL, Bonnie Feb 9, 1935 - Sep 22, 2022</a></h4></div>
    <div class="card-meta">
            <ul class="list-inline"><li class="card-asset-icons text-muted"><i class="fas tnt-external-link-alt tnt-fw" title="Link"></i></li></ul>
        </div>
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
            
                
                <article id="card-summary-2574937-31589914-e255-576a-aa6d-b45282f01b13" class="tnt-asset-type-link clearfix card summary has-image image-right inherit letterbox-style-default  tnt-section-obituaries">
            <div class="card-container"><div class="card-image ">
                        <div class="media-preview-31589914-e255-576a-aa6d-b45282f01b13 media-preview link-asset " data-aspect="original"><figure class="photo layout-vertical letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="https://obituaries.meridianstar.com/obituary/bryan-harper-jr-1086276988" class="tnt-asset-link"  aria-label="HARPER JR., Bryan Nov 24, 1944 - Aug 25, 2022">
                
                
                    <div class="asset-icon"><i class="fas tnt-external-link-alt tnt-fw" title="Link"></i></div>
                
                
                <img
                    alt="HARPER JR., Bryan Nov 24, 1944 - Aug 25, 2022"
                    src="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/3/15/31589914-e255-576a-aa6d-b45282f01b13/632e11eff1b64.preview.jpg?resize=155%2C200"
                    class="img-responsive  letterbox default"
                    loading="lazy"
                    width="192"
                    height="247" />
                </a>
                
            </div>
            
        </figure></div>
                    </div>
                
                <div class="card-body">
        <div class="card-headline"><h4 class="tnt-headline ">
        
             <a href="https://obituaries.meridianstar.com/obituary/bryan-harper-jr-1086276988" class="tnt-asset-link" aria-label="HARPER JR., Bryan Nov 24, 1944 - Aug 25, 2022">
        

        
            HARPER JR., Bryan Nov 24, 1944 - Aug 25, 2022</a></h4></div>
    
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
            
                
                <article id="card-summary-2574937-e8a667cf-8969-533f-aae3-5ab08c9c86a8" class="tnt-asset-type-link clearfix card summary inherit letterbox-style-default  tnt-section-obituaries">
            <div class="card-container">
                
                <div class="card-body">
        <div class="card-headline"><h4 class="tnt-headline ">
        
             <a href="https://obituaries.meridianstar.com/obituary/lyman-rasberry-1086252574" class="tnt-asset-link" aria-label="Rasberry, Lyman">
        

        
            Rasberry, Lyman</a></h4></div>
    <div class="card-meta">
            <ul class="list-inline"><li class="card-asset-icons text-muted"><i class="fas tnt-external-link-alt tnt-fw" title="Link"></i></li></ul>
        </div>
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
            
                
                <article id="card-summary-2574937-641d7e87-c6fb-577a-86bb-51a684a23dc8" class="tnt-asset-type-link clearfix card summary inherit letterbox-style-default  tnt-section-obituaries">
            <div class="card-container">
                
                <div class="card-body">
        <div class="card-headline"><h4 class="tnt-headline ">
        
             <a href="https://obituaries.meridianstar.com/obituary/dora-bane-1086252553" class="tnt-asset-link" aria-label="Bane, Dora">
        

        
            Bane, Dora</a></h4></div>
    <div class="card-meta">
            <ul class="list-inline"><li class="card-asset-icons text-muted"><i class="fas tnt-external-link-alt tnt-fw" title="Link"></i></li></ul>
        </div>
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
            </div>
        <ul class="list-inline block-links pos-bottom ">
            
                
                    <li><a href="/obituaries" class="">More Obituaries</a></li>
                
            
            
        </ul></section></div><div id="tncms-block-2574775" class="tncms-block"><!-- Mobile 300x250 between obits and most pop -->

<div id="adb_mobileBanner_obits_pop" style="width:100%;text-align:center" class="visible-xs visible-sm"></div>
<div class="clear" style="padding-bottom:10px"></div>
</div><div id="tncms-block-2574832" class="tncms-block"><section id="block-2574832" class="block emphasis-h3   " ><div class="clearfix">
    
    <div class="block-title title-2574832 ">
        <div class="block-title-inner">
            <h3>
                
                Most Popular
                
            </h3>
        </div>
    </div></div><div class="most-popular">
    <ul class="nav nav-tabs nav-tabs-popular">
        
            <li class="active">
                <a href="#articles-2574832" data-toggle="tab"><i class="far tnt-file-alt" title="Articles"></i><span class="tab-text"> Articles</span></a>
            </li>
        
        
            <li >
                <a href="#images-2574832" data-toggle="tab"><i class="far tnt-image" title="images"></i><span class="tab-text"> Images</span></a>
            </li>
        
        
            <li >
                <a href="#videos-2574832" data-toggle="tab"><i class="fas tnt-play-circle" title="Videos"></i><span class="tab-text"> Videos</span></a>
            </li>
        
        
        
        
            <li >
                <a href="#commented-2574832" data-toggle="tab"><i class="far tnt-comments" title="Commented"></i><span class="tab-text"> Commented</span></a>
            </li>
        
    </ul>
    <div class="tab-content">
        
            <div id="articles-2574832" class="tab-pane tab-pane-articles fade in active">
                <h4 class="tab-content-heading">Articles</h4><ul class="tab-content-list bullet-disc "><li><a href="/news/local_news/family-tradition-popular-steakhouse-expands-to-meridian/article_78352ec9-bf29-5878-a3df-8593459d9946.html">FAMILY TRADITION: Popular steakhouse expands to Meridian</a></li><li><a href="/city-issues-boil-water-notice-for-residents-north-of-20th-st/article_bfa57804-390f-11ed-9293-0f274be4cbc3.html">City issues boil water notice for residents north of 20th St.</a></li><li><a href="/news/local_news/update-city-lifts-boil-water-notice/article_338b37d7-f7bf-5091-8fb3-d8d808f86702.html">UPDATE: City lifts boil water notice</a></li><li><a href="/news/local_news/chapel-hart-comes-to-msu-riley-center-dec-16/article_60c27235-e4d4-519f-b5fc-f89ad7cf392c.html">Chapel Hart comes to MSU Riley Center Dec. 16</a></li><li><a href="/news/local_news/mpd-chief-responds-to-grand-jury-report/article_e5334fbc-6d15-5720-886f-51054016ef66.html">MPD chief responds to grand jury report</a></li><li><a href="/news/local_news/veterans-memorial-dedication-set-for-tuesday/article_4efa0d4d-0794-5300-b914-f3b9db38670e.html">Veterans memorial dedication set for Tuesday</a></li><li><a href="/news/local_news/law-enforcement-reports-for-sept-23/article_d0173271-7507-5320-a89b-ba257161fa3c.html">Law enforcement reports for Sept. 23</a></li><li><a href="/sports/local_sports/christian-knox-named-the-meridian-star-sports-editor/article_fb18b230-9fe4-5d10-a678-a13617dc3c52.html">Christian Knox named The Meridian Star sports editor</a></li><li><a href="/news/local_news/new-sheriffs-office-nears-completion/article_4d378ac0-ad13-5833-b624-16c3f34597d4.html">New sheriff's office nears completion</a></li><li><a href="/news/local_news/on-the-go-rose-hill-costumed-tour-set-for-saturday/article_ea30935b-b22f-57e3-9757-f53766d0da83.html">ON THE GO: Rose Hill Costumed Tour set for Saturday</a></li></ul></div>
        
        
            <div id="images-2574832" class="tab-pane tab-pane-images fade in ">
                <h4 class="tab-content-heading">Images</h4><ul class="tab-content-list">
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/news/nation_and_world/knock-knock-jehovahs-witnesses-resume-door-to-door-work/image_2ee60287-8110-5bca-a3ce-cd98cb902e98.html" class="tnt-asset-link"  aria-label="Knock, knock: Jehovah's Witnesses resume door-to-door work">
                
                
                
                
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Knock, knock: Jehovah's Witnesses resume door-to-door work"
                            class="img-responsive lazyload ap-photo full default"
                            width="1192"
                            height="1192"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/2/ee/2ee60287-8110-5bca-a3ce-cd98cb902e98/63121c0a9966c.image.jpg?crop=1192%2C1192%2C273%2C0&resize=150%2C150&order=crop%2Cresize 150w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/2/ee/2ee60287-8110-5bca-a3ce-cd98cb902e98/63121c0a9966c.image.jpg?crop=1192%2C1192%2C273%2C0&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/2/ee/2ee60287-8110-5bca-a3ce-cd98cb902e98/63121c0a9966c.image.jpg?crop=1192%2C1192%2C273%2C0&resize=225%2C225&order=crop%2Cresize 225w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/2/ee/2ee60287-8110-5bca-a3ce-cd98cb902e98/63121c0a9966c.image.jpg?crop=1192%2C1192%2C273%2C0&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/2/ee/2ee60287-8110-5bca-a3ce-cd98cb902e98/63121c0a9966c.image.jpg?crop=1192%2C1192%2C273%2C0&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/2/ee/2ee60287-8110-5bca-a3ce-cd98cb902e98/63121c0a9966c.image.jpg?crop=1192%2C1192%2C273%2C0&resize=540%2C540&order=crop%2Cresize 540w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/2/ee/2ee60287-8110-5bca-a3ce-cd98cb902e98/63121c0a9966c.image.jpg?crop=1192%2C1192%2C273%2C0&resize=640%2C640&order=crop%2Cresize 640w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/2/ee/2ee60287-8110-5bca-a3ce-cd98cb902e98/63121c0a9966c.image.jpg?crop=1192%2C1192%2C273%2C0&resize=750%2C750&order=crop%2Cresize 750w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/2/ee/2ee60287-8110-5bca-a3ce-cd98cb902e98/63121c0a9966c.image.jpg?crop=1192%2C1192%2C273%2C0&resize=990%2C990&order=crop%2Cresize 990w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/2/ee/2ee60287-8110-5bca-a3ce-cd98cb902e98/63121c0a9966c.image.jpg?crop=1192%2C1192%2C273%2C0&resize=1035%2C1035&order=crop%2Cresize 1035w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/2/ee/2ee60287-8110-5bca-a3ce-cd98cb902e98/63121c0a9966c.image.jpg?crop=1192%2C1192%2C273%2C0&resize=1192%2C1192&order=crop%2Cresize 1200w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/news/local_news/chapel-hart-comes-to-msu-riley-center-dec-16/image_6229901c-5079-5bf7-a0a1-b022a6e29078.html" class="tnt-asset-link"  aria-label="Chapel Hart comes to MSU Riley Center Dec. 16">
                
                
                
                
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Chapel Hart comes to MSU Riley Center Dec. 16"
                            class="img-responsive lazyload full default"
                            width="501"
                            height="501"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/6/22/6229901c-5079-5bf7-a0a1-b022a6e29078/6328c6be98878.image.jpg?crop=501%2C501%2C149%2C0&resize=150%2C150&order=crop%2Cresize 150w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/6/22/6229901c-5079-5bf7-a0a1-b022a6e29078/6328c6be98878.image.jpg?crop=501%2C501%2C149%2C0&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/6/22/6229901c-5079-5bf7-a0a1-b022a6e29078/6328c6be98878.image.jpg?crop=501%2C501%2C149%2C0&resize=225%2C225&order=crop%2Cresize 225w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/6/22/6229901c-5079-5bf7-a0a1-b022a6e29078/6328c6be98878.image.jpg?crop=501%2C501%2C149%2C0&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/6/22/6229901c-5079-5bf7-a0a1-b022a6e29078/6328c6be98878.image.jpg?crop=501%2C501%2C149%2C0&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/6/22/6229901c-5079-5bf7-a0a1-b022a6e29078/6328c6be98878.image.jpg?crop=501%2C501%2C149%2C0&resize=501%2C501&order=crop%2Cresize 540w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/news/nation_and_world/live-updates-french-president-sends-condolences-to-pm-truss/image_cc627687-4837-50d3-a33f-fa3b977f08c2.html" class="tnt-asset-link"  aria-label="Live updates: French president sends condolences to PM Truss">
                
                
                
                
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Live updates: French president sends condolences to PM Truss"
                            class="img-responsive lazyload ap-photo full default"
                            width="1202"
                            height="1202"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/c/c6/cc627687-4837-50d3-a33f-fa3b977f08c2/631ca843ca29f.image.jpg?crop=1202%2C1202%2C261%2C0&resize=150%2C150&order=crop%2Cresize 150w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/c/c6/cc627687-4837-50d3-a33f-fa3b977f08c2/631ca843ca29f.image.jpg?crop=1202%2C1202%2C261%2C0&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/c/c6/cc627687-4837-50d3-a33f-fa3b977f08c2/631ca843ca29f.image.jpg?crop=1202%2C1202%2C261%2C0&resize=225%2C225&order=crop%2Cresize 225w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/c/c6/cc627687-4837-50d3-a33f-fa3b977f08c2/631ca843ca29f.image.jpg?crop=1202%2C1202%2C261%2C0&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/c/c6/cc627687-4837-50d3-a33f-fa3b977f08c2/631ca843ca29f.image.jpg?crop=1202%2C1202%2C261%2C0&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/c/c6/cc627687-4837-50d3-a33f-fa3b977f08c2/631ca843ca29f.image.jpg?crop=1202%2C1202%2C261%2C0&resize=540%2C540&order=crop%2Cresize 540w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/c/c6/cc627687-4837-50d3-a33f-fa3b977f08c2/631ca843ca29f.image.jpg?crop=1202%2C1202%2C261%2C0&resize=640%2C640&order=crop%2Cresize 640w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/c/c6/cc627687-4837-50d3-a33f-fa3b977f08c2/631ca843ca29f.image.jpg?crop=1202%2C1202%2C261%2C0&resize=750%2C750&order=crop%2Cresize 750w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/c/c6/cc627687-4837-50d3-a33f-fa3b977f08c2/631ca843ca29f.image.jpg?crop=1202%2C1202%2C261%2C0&resize=990%2C990&order=crop%2Cresize 990w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/c/c6/cc627687-4837-50d3-a33f-fa3b977f08c2/631ca843ca29f.image.jpg?crop=1202%2C1202%2C261%2C0&resize=1035%2C1035&order=crop%2Cresize 1035w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/c/c6/cc627687-4837-50d3-a33f-fa3b977f08c2/631ca843ca29f.image.jpg?crop=1202%2C1202%2C261%2C0&resize=1200%2C1200&order=crop%2Cresize 1200w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/c/c6/cc627687-4837-50d3-a33f-fa3b977f08c2/631ca843ca29f.image.jpg?crop=1202%2C1202%2C261%2C0&resize=1202%2C1202&order=crop%2Cresize 1333w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/news/local_news/fun-at-fork-fete/image_db8a3dd6-f992-5265-a5f5-651767faaab3.html" class="tnt-asset-link"  aria-label="Fun at 'Fork &amp; Fete'">
                
                
                
                
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Fun at 'Fork &amp; Fete'"
                            class="img-responsive lazyload full default"
                            width="533"
                            height="533"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/d/b8/db8a3dd6-f992-5265-a5f5-651767faaab3/631f57b417b24.image.jpg?crop=533%2C533%2C133%2C0&resize=150%2C150&order=crop%2Cresize 150w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/d/b8/db8a3dd6-f992-5265-a5f5-651767faaab3/631f57b417b24.image.jpg?crop=533%2C533%2C133%2C0&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/d/b8/db8a3dd6-f992-5265-a5f5-651767faaab3/631f57b417b24.image.jpg?crop=533%2C533%2C133%2C0&resize=225%2C225&order=crop%2Cresize 225w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/d/b8/db8a3dd6-f992-5265-a5f5-651767faaab3/631f57b417b24.image.jpg?crop=533%2C533%2C133%2C0&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/d/b8/db8a3dd6-f992-5265-a5f5-651767faaab3/631f57b417b24.image.jpg?crop=533%2C533%2C133%2C0&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/d/b8/db8a3dd6-f992-5265-a5f5-651767faaab3/631f57b417b24.image.jpg?crop=533%2C533%2C133%2C0&resize=533%2C533&order=crop%2Cresize 540w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/news/local_news/class-of-2022-top-20-under-40-honored-in-meridian/image_9d0fb548-94e4-585b-bc4e-5fd2e9575c4f.html" class="tnt-asset-link"  aria-label="CLASS OF 2022: Top 20 Under 40 honored in Meridian">
                
                
                
                
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="CLASS OF 2022: Top 20 Under 40 honored in Meridian"
                            class="img-responsive lazyload full default"
                            width="600"
                            height="600"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/9/d0/9d0fb548-94e4-585b-bc4e-5fd2e9575c4f/631a8c92676e5.image.jpg?crop=600%2C600%2C100%2C0&resize=150%2C150&order=crop%2Cresize 150w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/9/d0/9d0fb548-94e4-585b-bc4e-5fd2e9575c4f/631a8c92676e5.image.jpg?crop=600%2C600%2C100%2C0&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/9/d0/9d0fb548-94e4-585b-bc4e-5fd2e9575c4f/631a8c92676e5.image.jpg?crop=600%2C600%2C100%2C0&resize=225%2C225&order=crop%2Cresize 225w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/9/d0/9d0fb548-94e4-585b-bc4e-5fd2e9575c4f/631a8c92676e5.image.jpg?crop=600%2C600%2C100%2C0&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/9/d0/9d0fb548-94e4-585b-bc4e-5fd2e9575c4f/631a8c92676e5.image.jpg?crop=600%2C600%2C100%2C0&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/9/d0/9d0fb548-94e4-585b-bc4e-5fd2e9575c4f/631a8c92676e5.image.jpg?crop=600%2C600%2C100%2C0&resize=540%2C540&order=crop%2Cresize 540w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/9/d0/9d0fb548-94e4-585b-bc4e-5fd2e9575c4f/631a8c92676e5.image.jpg?crop=600%2C600%2C100%2C0&resize=600%2C600&order=crop%2Cresize 640w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/news/nation_and_world/florida-texas-escalate-flights-buses-to-move-migrants/image_4210ed82-6ddc-5a55-8672-451012e0fc16.html" class="tnt-asset-link"  aria-label="Florida, Texas escalate flights, buses to move migrants">
                
                
                
                
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Florida, Texas escalate flights, buses to move migrants"
                            class="img-responsive lazyload ap-photo full default"
                            width="225"
                            height="225"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/4/21/4210ed82-6ddc-5a55-8672-451012e0fc16/6323cba20b994.image.jpg?crop=225%2C225%2C87%2C0&resize=150%2C150&order=crop%2Cresize 150w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/4/21/4210ed82-6ddc-5a55-8672-451012e0fc16/6323cba20b994.image.jpg?crop=225%2C225%2C87%2C0&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/4/21/4210ed82-6ddc-5a55-8672-451012e0fc16/6323cba20b994.image.jpg?crop=225%2C225%2C87%2C0&resize=225%2C225&order=crop%2Cresize 225w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/region/schools-are-going-online-in-disasters-worsening-disruption/image_1f8a3ff5-55d1-5a27-9d02-a33bc883e395.html" class="tnt-asset-link"  aria-label="Schools are going online in disasters, worsening disruption">
                
                
                
                
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Schools are going online in disasters, worsening disruption"
                            class="img-responsive lazyload ap-photo full default"
                            width="1175"
                            height="1175"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/1/f8/1f8a3ff5-55d1-5a27-9d02-a33bc883e395/6322f8b550bb1.image.jpg?crop=1175%2C1175%2C294%2C0&resize=150%2C150&order=crop%2Cresize 150w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/1/f8/1f8a3ff5-55d1-5a27-9d02-a33bc883e395/6322f8b550bb1.image.jpg?crop=1175%2C1175%2C294%2C0&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/1/f8/1f8a3ff5-55d1-5a27-9d02-a33bc883e395/6322f8b550bb1.image.jpg?crop=1175%2C1175%2C294%2C0&resize=225%2C225&order=crop%2Cresize 225w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/1/f8/1f8a3ff5-55d1-5a27-9d02-a33bc883e395/6322f8b550bb1.image.jpg?crop=1175%2C1175%2C294%2C0&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/1/f8/1f8a3ff5-55d1-5a27-9d02-a33bc883e395/6322f8b550bb1.image.jpg?crop=1175%2C1175%2C294%2C0&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/1/f8/1f8a3ff5-55d1-5a27-9d02-a33bc883e395/6322f8b550bb1.image.jpg?crop=1175%2C1175%2C294%2C0&resize=540%2C540&order=crop%2Cresize 540w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/1/f8/1f8a3ff5-55d1-5a27-9d02-a33bc883e395/6322f8b550bb1.image.jpg?crop=1175%2C1175%2C294%2C0&resize=640%2C640&order=crop%2Cresize 640w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/1/f8/1f8a3ff5-55d1-5a27-9d02-a33bc883e395/6322f8b550bb1.image.jpg?crop=1175%2C1175%2C294%2C0&resize=750%2C750&order=crop%2Cresize 750w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/1/f8/1f8a3ff5-55d1-5a27-9d02-a33bc883e395/6322f8b550bb1.image.jpg?crop=1175%2C1175%2C294%2C0&resize=990%2C990&order=crop%2Cresize 990w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/1/f8/1f8a3ff5-55d1-5a27-9d02-a33bc883e395/6322f8b550bb1.image.jpg?crop=1175%2C1175%2C294%2C0&resize=1035%2C1035&order=crop%2Cresize 1035w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/1/f8/1f8a3ff5-55d1-5a27-9d02-a33bc883e395/6322f8b550bb1.image.jpg?crop=1175%2C1175%2C294%2C0&resize=1175%2C1175&order=crop%2Cresize 1200w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/west-lauderdale-v-newton-county-3-jpg/image_fcc814fa-27ab-11ed-b5e7-ebc03c5f3f52.html" class="tnt-asset-link"  aria-label="West Lauderdale v newton county-3.JPG">
                
                
                
                
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="West Lauderdale v newton county-3.JPG"
                            class="img-responsive lazyload full default"
                            width="1199"
                            height="1199"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/f/cc/fcc814fa-27ab-11ed-b5e7-ebc03c5f3f52/630cd5ab37c11.image.jpg?crop=1199%2C1199%2C265%2C0&resize=150%2C150&order=crop%2Cresize 150w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/f/cc/fcc814fa-27ab-11ed-b5e7-ebc03c5f3f52/630cd5ab37c11.image.jpg?crop=1199%2C1199%2C265%2C0&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/f/cc/fcc814fa-27ab-11ed-b5e7-ebc03c5f3f52/630cd5ab37c11.image.jpg?crop=1199%2C1199%2C265%2C0&resize=225%2C225&order=crop%2Cresize 225w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/f/cc/fcc814fa-27ab-11ed-b5e7-ebc03c5f3f52/630cd5ab37c11.image.jpg?crop=1199%2C1199%2C265%2C0&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/f/cc/fcc814fa-27ab-11ed-b5e7-ebc03c5f3f52/630cd5ab37c11.image.jpg?crop=1199%2C1199%2C265%2C0&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/f/cc/fcc814fa-27ab-11ed-b5e7-ebc03c5f3f52/630cd5ab37c11.image.jpg?crop=1199%2C1199%2C265%2C0&resize=540%2C540&order=crop%2Cresize 540w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/f/cc/fcc814fa-27ab-11ed-b5e7-ebc03c5f3f52/630cd5ab37c11.image.jpg?crop=1199%2C1199%2C265%2C0&resize=640%2C640&order=crop%2Cresize 640w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/f/cc/fcc814fa-27ab-11ed-b5e7-ebc03c5f3f52/630cd5ab37c11.image.jpg?crop=1199%2C1199%2C265%2C0&resize=750%2C750&order=crop%2Cresize 750w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/f/cc/fcc814fa-27ab-11ed-b5e7-ebc03c5f3f52/630cd5ab37c11.image.jpg?crop=1199%2C1199%2C265%2C0&resize=990%2C990&order=crop%2Cresize 990w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/f/cc/fcc814fa-27ab-11ed-b5e7-ebc03c5f3f52/630cd5ab37c11.image.jpg?crop=1199%2C1199%2C265%2C0&resize=1035%2C1035&order=crop%2Cresize 1035w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/f/cc/fcc814fa-27ab-11ed-b5e7-ebc03c5f3f52/630cd5ab37c11.image.jpg?crop=1199%2C1199%2C265%2C0&resize=1199%2C1199&order=crop%2Cresize 1200w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/sports/local_sports/meridian-wildcats-victorious-over-hattiesburg-31-6/image_9c750ef3-704e-5e96-bfc5-9b0940b31e5d.html" class="tnt-asset-link"  aria-label="Meridian Wildcats victorious over Hattiesburg 31-6">
                
                
                
                
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Meridian Wildcats victorious over Hattiesburg 31-6"
                            class="img-responsive lazyload full default"
                            width="600"
                            height="600"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/9/c7/9c750ef3-704e-5e96-bfc5-9b0940b31e5d/63270f7e79888.image.jpg?crop=600%2C600%2C89%2C0&resize=150%2C150&order=crop%2Cresize 150w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/9/c7/9c750ef3-704e-5e96-bfc5-9b0940b31e5d/63270f7e79888.image.jpg?crop=600%2C600%2C89%2C0&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/9/c7/9c750ef3-704e-5e96-bfc5-9b0940b31e5d/63270f7e79888.image.jpg?crop=600%2C600%2C89%2C0&resize=225%2C225&order=crop%2Cresize 225w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/9/c7/9c750ef3-704e-5e96-bfc5-9b0940b31e5d/63270f7e79888.image.jpg?crop=600%2C600%2C89%2C0&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/9/c7/9c750ef3-704e-5e96-bfc5-9b0940b31e5d/63270f7e79888.image.jpg?crop=600%2C600%2C89%2C0&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/9/c7/9c750ef3-704e-5e96-bfc5-9b0940b31e5d/63270f7e79888.image.jpg?crop=600%2C600%2C89%2C0&resize=540%2C540&order=crop%2Cresize 540w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/9/c7/9c750ef3-704e-5e96-bfc5-9b0940b31e5d/63270f7e79888.image.jpg?crop=600%2C600%2C89%2C0&resize=600%2C600&order=crop%2Cresize 640w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/news/local_news/ida-brown-closing-one-door-to-open-another/image_4e50dbbb-5477-5d5c-88ac-7ef51a559022.html" class="tnt-asset-link"  aria-label="IDA BROWN: Closing one door to open another">
                
                
                
                
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="IDA BROWN: Closing one door to open another"
                            class="img-responsive lazyload full default"
                            width="490"
                            height="490"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/4/e5/4e50dbbb-5477-5d5c-88ac-7ef51a559022/6324d63b5b372.image.jpg?crop=490%2C490%2C0%2C55&resize=150%2C150&order=crop%2Cresize 150w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/4/e5/4e50dbbb-5477-5d5c-88ac-7ef51a559022/6324d63b5b372.image.jpg?crop=490%2C490%2C0%2C55&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/4/e5/4e50dbbb-5477-5d5c-88ac-7ef51a559022/6324d63b5b372.image.jpg?crop=490%2C490%2C0%2C55&resize=225%2C225&order=crop%2Cresize 225w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/4/e5/4e50dbbb-5477-5d5c-88ac-7ef51a559022/6324d63b5b372.image.jpg?crop=490%2C490%2C0%2C55&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/4/e5/4e50dbbb-5477-5d5c-88ac-7ef51a559022/6324d63b5b372.image.jpg?crop=490%2C490%2C0%2C55&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/assets/v3/editorial/4/e5/4e50dbbb-5477-5d5c-88ac-7ef51a559022/6324d63b5b372.image.jpg?crop=490%2C490%2C0%2C55&resize=490%2C490&order=crop%2Cresize 540w" />
                </a>
                
            </div>
            
        </figure></li>
                        </ul></div>
        
        <div id="videos-2574832" class="tab-pane tab-pane-videos fade in ">
                <h4 class="tab-content-heading">Videos</h4><p class="no-results text-muted">Sorry, there are no recent results for popular videos.</p></div>
        
        
        
        
            <div id="commented-2574832" class="tab-pane tab-pane-commented fade in ">
                <h4 class="tab-content-heading">Commented</h4><p class="no-results text-muted">Sorry, there are no recent results for popular commented articles.</p></div>
        
    </div>
</div></section></div><div id="tncms-block-2574778" class="tncms-block"><!-- 120x60 house ads -->
<div style="width:100%;">
    <!-- button btf1-->
    <div id='adb_button_btf1' style="float:left;margin:10px;"></div>
    <!-- button btf2-->
    <div id='adb_button_btf2' style="float:right;margin:10px;"></div>
</div></div><div id="tncms-block-2574841" class="tncms-block hidden-xs"><!-- mediumRectangle_btf1 flex right rail -->


<div id='adb_mediumRectangle_btf1' style="text-align:center"></div>
<div class="clear" style="padding-bottom:10px"></div>
</div><div id="tncms-block-2574838" class="tncms-block"><!-- Begin Video Homepage ks -->



</div><div id="tncms-block-2574847" class="tncms-block"><!-- Mobile article 300x250 under Monster block -->


<div id="adb_mobileBanner_article_monster" style="width:100%;text-align:center" class="visible-xs visible-sm"></div>
<div class="clear" style="padding-bottom:10px"></div>

</div><div id="tncms-block-2574835" class="tncms-block whatever">
<div id="biz_marquee" style="margin-top:10px;margin-bottom:10px;">
<script type="text/javascript" src="https://static.cnhionline.com/cnhi/data/bizmarquee/meridianstar.js"></script>
</div></div><div id="tncms-block-2574844" class="tncms-block hidden-xs"><!-- mediumRectangle_btf3_flex Section -->



</div></div>  

<div class="row">
    <div class="col-md-12"><div id="tncms-region-option-rail-bottom-one" class="tncms-region "></div></div>
</div>

<div class="row">
    <div class="col-md-12"><div id="tncms-region-option-rail-bottom-two" class="tncms-region "></div></div>
</div>

<div class="row">
    <div class="col-md-12"><div id="tncms-region-option-rail-bottom-three" class="tncms-region "></div></div>
</div>

<div class="row">
    <div class="col-md-12"><div id="tncms-region-option-rail-bottom-four" class="tncms-region "></div></div>
</div>

<div id="tncms-region-asset_side_bottom" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-tertiary" class="tncms-region "></div><div id="tncms-region-article_side_bottom" class="tncms-region hidden-print"></div>
                <div id="sticky-right-rail-spacer">
                    <div id="sticky-right-rail"><div id="tncms-region-global-side-sticky" class="tncms-region hidden-print"><div id="tncms-block-2574856" class="tncms-block">
<!-- mediumRectangle_btf2_flex redesign -->


</div></div><div id="tncms-region-asset_side_sticky" class="tncms-region hidden-print"></div></div>
                </div>
                </div>
            </div></div>
</article>
<div class="row">
            <div class="col-md-12"><div id="tncms-region-global-container-bottom" class="tncms-region "><div id="tncms-block-2574979" class="tncms-block"><div id="flipp-ux-slot-68ce2f21">
<h3 class='flipp-ux-header title mb-0' class="text-muted block-title-inner"style='padding: 0px 0px 10px 0px; display: none;'>Featured Local Savings</h3>
</div></div></div></div>
        </div></section>
    <section id="main-bottom-container" class="container-fullscreen-region container-fluid">
        <div class="fullscreen-region"><div id="tncms-region-global-container-bottom-fullscreen" class="tncms-region "><div id="tncms-block-2554840" class="tncms-block"><div class="modal promo-designer-modal in toaster_right  hidden tnt-dmp-reactive" id="promo-designer-modal-custom-pop" tabindex="-1" role="dialog" aria-label="Promotional pop up" aria-hidden="true"  data-dmp-show='["meridianstar_headlines_daily"]'>
        <div class="modal-dialog modal-md toaster_right">
            <div class="modal-content">
                <div class="modal-body"><section id="block-2554840" class="block emphasis-h2   hidden tnt-dmp-reactive "  data-dmp-show='["meridianstar_headlines_daily"]'><div class="promo-design card-rounded-rectangle"><div class="sticker rounded">
            <span class="fas tnt-envelope"></span>
        </div><div class="card-bg-color rounded_rectangle"><button type="button" class="close" data-dismiss="modal" aria-label="Close">
                <span class="tnt-stack" aria-hidden="true">
                    <i class="fas tnt-circle tnt-inverse tnt-stack-1x"></i>
                    <i class="fas tnt-times-circle tnt-stack-1x"></i>
                </span>
            </button><div class="card-panel panel"><div class="panel-body">
                <div class="promo-designer-wrapper">
                        <div class="lead-in dark ">
                            Stay up to date on COVID-19
                        </div>
                    
                    
                        <div class="headline medium dark ">
                            Get Breaking News
                        </div>
                    
                    
                        <p class="text dark ">
                            Sign up now to get our FREE breaking news coverage delivered right to your inbox.
                        </p>
                    <div class="promo-design-button">
                            <a href="https://bcp.crwdcntrl.net/5/c=6880/b=65082672?https://visitor.r20.constantcontact.com/d.jsp?llr=99oml49ab&p=oi&m=1128481045338&sit=s5fwgcwlb&f=e95c0a03-8db9-4d2a-98d3-7dffa92feef5">
                                <button type="button" class="btn btn-success btn-lg">Sign-up</button>
                            </a>
                        </div></div>
            </div>
        </div>
    </div>
</div></section></div>
            </div>
        </div>
    </div></div><div id="tncms-block-2574976" class="tncms-block hidden-xs"><!-- leaderboard btf -->


<div class="clear" style="margin-top:20px;padding-top:20px;"></div>
<div id='adb_leaderboard_btf' style="margin-bottom:10px;width:100%;text-align:center"></div>
<div class="clear" style="margin-bottom:20px;padding-bottom:20px;"></div>

</div></div></div>
    </section><!-- / main-body-container -->
    </div>
    <div id="site-footer-container" class="hidden-print">
         
            <div class="container">
                <div id="asset-container-bottom" class="col-md-12">
                    <div id="tncms-region-asset_container_bottom" class="tncms-region hidden-print"></div> 
                </div>
            </div>
        

        
            <footer id="site-footer" class="container well-main">
                  
<!-- code here -->  

                <div id="tncms-region-footer-top-col-full" class="tncms-region "><div id="tncms-block-2554744" class="tncms-block"><div style="font-family:times;font-style:italic;margin-bottom:20px" class="fa-block">
<p style="font-size:18px"><span style="font-weight:bold">First Amendment:</span> Congress shall make no law respecting an establishment of religion, or prohibiting the free exercise thereof; or abridging the freedom of speech, or of the press; or the right of the people peaceably to assemble, and to petition the Government for a redress of grievances.</p>
</div></div></div>
                <div class="row">
                    <div id="footer-col-one" class="col-md-4 col-sm-4">
        <div id="tncms-region-footer-col-one" class="tncms-region "><div id="tncms-block-2554732" class="tncms-block"><section id="block-2554732" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-2554732 ">
        <div class="block-title-inner">
            <h4>
                
                Contact Information
                
            </h4>
        </div>
    </div></div><address>
    <strong>meridianstar.com</strong><br>
    814 22nd Avenue<br>
    Meridian, MS 39302
    <br>
    
        <strong>Phone:</strong> 601-693-1551<br>
        <strong>Email:</strong> <a href="mailto:webmaster@themeridianstar.com">webmaster@themeridianstar.com</a><br>
    
</address></section></div><div id="tncms-block-2554729" class="tncms-block"><section id="block-2554729" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-2554729 ">
        <div class="block-title-inner">
            <h4>
                
                Services
                
            </h4>
        </div>
    </div></div></section></div></div>
        <div id="tncms-region-nav-footer-col-two-nav" class="tncms-region-nav"><ul id="footer-col-two-nav_menu" class="bullet-nav nav-list"><li>
                <a class="nav-link  tnt-section-about-us"  href="/site/about-us.html" >
                    <span class="nav-label ">About Us</span>
                </a></li><li>
                <a class="nav-link  tnt-section-contact-us"  href="/site/contact-us.html" >
                    <span class="nav-label ">Contact Us</span>
                </a></li><li>
                <a class="nav-link  tnt-section-advertise-with-us"  href="/site/advertise-with-us.html" >
                    <span class="nav-label ">Advertise with Us</span>
                </a></li><li>
                <a class="nav-link  tnt-section-subscriber-services"  href="/subscriber-services/" >
                    <span class="nav-label ">Subscriber Services</span>
                </a></li><li>
                <a class="nav-link  tnt-section-submission-forms"  href="/site/forms/" >
                    <span class="nav-label ">Submission Forms</span>
                </a></li><li>
                <a class="nav-link  tnt-section-california-privacy-policy"  href="/site/california_privacy_policy.html" >
                    <span class="nav-label ">California Privacy Policy</span>
                </a></li><li>
                <a class="nav-link  tnt-section-california-collection-notice"  href="/site/california_privacy_policy.html#2" >
                    <span class="nav-label ">California Collection Notice</span>
                </a></li><li>
                <a class="nav-link  tnt-section-do-not-sell-my-info"  href="/site/california_privacy_policy.html#3" >
                    <span class="nav-label ">Do Not Sell My Info</span>
                </a></li></ul></div>
    </div>
    <div id="footer-col-two" class="col-md-4 col-sm-4">
    <div id="tncms-region-footer-col-left" class="tncms-region "><div id="tncms-block-2554726" class="tncms-block"><section id="block-2554726" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-2554726 ">
        <div class="block-title-inner">
            <h4>
                
                Sections
                
            </h4>
        </div>
    </div></div></section></div></div>
    <div id="tncms-region-nav-footer-col-one-nav" class="tncms-region-nav"><ul id="footer-col-one-nav_menu" class="bullet-nav nav-list"><li>
                <a class="nav-link nav-home  tnt-section-home"  href="/" >
                    <span class="nav-icon fas tnt-home tnt-fw"></span> <span class="nav-label sr-only">Home</span>
                </a></li><li>
                <a class="nav-link  tnt-section-news"  href="/news/" >
                    <span class="nav-label ">News</span>
                </a></li><li>
                <a class="nav-link  tnt-section-puzzles"  href="/puzzles-palace" >
                    <span class="nav-label ">Puzzles</span>
                </a></li><li>
                <a class="nav-link  tnt-section-comics"  href="/comics-kingdom/" >
                    <span class="nav-label ">Comics</span>
                </a></li><li>
                <a class="nav-link  tnt-section-magazines"  href="/magazines/" >
                    <span class="nav-label ">Magazines</span>
                </a></li><li>
                <a class="nav-link  tnt-section-sports"  href="/sports/" >
                    <span class="nav-label ">Sports</span>
                </a></li><li>
                <a class="nav-link  tnt-section-community"  href="/community/" >
                    <span class="nav-label ">Community</span>
                </a></li><li>
                <a class="nav-link  tnt-section-opinion"  href="/opinion/" >
                    <span class="nav-label ">Opinion</span>
                </a></li><li>
                <a class="nav-link  tnt-section-obituaries"  href="/obituaries/" >
                    <span class="nav-label ">Obituaries</span>
                </a></li><li>
                <a class="nav-link  tnt-section-photos"  href="/gallery/" >
                    <span class="nav-label ">Photos</span>
                </a></li><li>
                <a class="nav-link  tnt-section-video-gallery"  href="/multimedia/videos/" >
                    <span class="nav-label ">Video Gallery</span>
                </a></li><li>
                <a class="nav-link  tnt-section-weather"  href="/weather/" >
                    <span class="nav-label ">Weather</span>
                </a></li></ul></div>
     <div id="tncms-region-footer-col-two" class="tncms-region "><div id="tncms-block-2554738" class="tncms-block padding-bottom"><section id="block-2554738" class="block emphasis-h3   " ><div class="block"><a href="/" rel="nofollow"  >
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/custom/image/9d5f3f66-4984-11e8-80af-bbf49248abbc.png?resize=150%2C24 150w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/custom/image/9d5f3f66-4984-11e8-80af-bbf49248abbc.png?resize=200%2C32 200w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/custom/image/9d5f3f66-4984-11e8-80af-bbf49248abbc.png?resize=225%2C36 225w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/custom/image/9d5f3f66-4984-11e8-80af-bbf49248abbc.png?resize=300%2C49 300w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/custom/image/9d5f3f66-4984-11e8-80af-bbf49248abbc.png?resize=400%2C65 400w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/custom/image/9d5f3f66-4984-11e8-80af-bbf49248abbc.png?resize=540%2C87 540w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/custom/image/9d5f3f66-4984-11e8-80af-bbf49248abbc.png?resize=640%2C104 640w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/custom/image/9d5f3f66-4984-11e8-80af-bbf49248abbc.png?resize=750%2C121 750w, https://bloximages.chicago2.vip.townnews.com/meridianstar.com/content/tncms/custom/image/9d5f3f66-4984-11e8-80af-bbf49248abbc.png 990w" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                width="958"
                height="155"
                alt=""
                aria-hidden="true"></a></div></section></div></div>
        
    </div>
    <div id="footer-col-three" class="col-md-4 col-sm-4">
        <div id="tncms-region-footer-col-three" class="tncms-region "><div id="tncms-block-2554735" class="tncms-block">
<div style="width:100%;text-align:center">
<a href="https://www.rtjgolf.com/fall/?utm_source=CNHI&utm_medium=website&utm_campaign=fall22" target="_blank"><img src="https://static.cnhionline.com/ksherman/images/RTJ-PlayAllDay-Fall-300x250.gif" border="0" style="max-width:300px;" /></a>
</div>
</div></div>
        
    </div>
                </div>
                <div id="tncms-region-footer-bottom-col-full" class="tncms-region "></div>
                

<script>
  function hideFbBlock() {
    var adClose = document.getElementById("floorboard_block");
    if (adClose.style.display === "none") {
      adClose.style.display = "block";
    } else {
      adClose.style.display = "none";
    }
  }

  function hideFbBlockMob() {
    var adClose2 = document.getElementById("floorboard_block_mob");
    if (adClose2.style.display === "none") {
      adClose2.style.display = "block";
    } else {
      adClose2.style.display = "none";
      adClose2.classList.remove('visible-xs', 'visible-sm');
    }
  }
</script>
<!-- DFP Floorboard Ad -->
<div id='floorboard_block' style="position: fixed; z-index: 1040; width:100%; bottom:0; left:0; text-align:center;"
  class="hidden-xs hidden-sm">
  <a href="javascript:void(0)"
    style="z-index: 10002; width:30px;height:30px;position:relative; bottom:25px; left:500px;"
    onclick="hideFbBlock(); return false;"><svg xmlns="http://www.w3.org/2000/svg"
      xmlns:xlink="http://www.w3.org/1999/xlink" width="32" height="32" viewBox="0 0 32 32">
      <image x="1" y="1" width="30" height="30" opacity="0.4"
        xlink:href="data:img/png;base64,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" />
    </svg></a>
  <div id='adb_floorboard' style="position: fixed; z-index: 10001; width:100%; bottom:0; left:0; text-align:center;"
    class="hidden-xs hidden-sm"></div>
</div>
<!-- DFP Reveal OOP -->
<div id='adb_reveal'></div>
<!-- Mobile Banner BTF 300x50 -->
<div id='floorboard_block_mob' class="visible-xs visible-sm"
  style="position: fixed; z-index: 10001; width:100%; bottom:0; left:0; text-align:center;">
  <a href="javascript:void(0)"
    style="z-index: 10002; width:30px;height:30px;position:relative; bottom:10px; left:190px;"
    onclick="hideFbBlockMob(); return false;"><svg xmlns="http://www.w3.org/2000/svg"
      xmlns:xlink="http://www.w3.org/1999/xlink" width="32" height="32" viewBox="0 0 32 32">
      <image x="1" y="1" width="30" height="30" opacity="0.4"
        xlink:href="data:img/png;base64,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" />
    </svg></a>
  <div id="adb_mobileBanner_btf_flex" class="visible-xs visible-sm"
    style="padding:0px; background-color:#fff;position: fixed; z-index: 10001; width:100%; bottom:0; left:0; text-align:center">
  </div>
</div>
<!-- Large Video Player -->
<div id="adb_large-video" style="width: 1px; height: 1px;"></div>


<!-- Viafoura Script -->
<script type="text/javascript" async src="//cdn.viafoura.net/vf-v2.js"></script>




<!-- Tecnavia Login Subscribe Button -->

<script type='text/javascript'>
function loginButtonLink() {
    const elements = document.getElementsByClassName('tnt-section-login');
    for (const element of elements) {
        element.href = 'javascript:var onclick=ta_account();';
       // element.classList.add('ta_account_button');
        element.removeAttribute('id');
    }
}
loginButtonLink();

function subscribeButtonLink() {
    const elements = document.getElementsByClassName('tnt-section-subscribe');
    for (const element of elements) {
        element.href = 'javascript:var onclick=ta_accountOptions();';
        element.removeAttribute('id');
    }
}
subscribeButtonLink();

</script>


<script type='text/javascript'>
function gamesButtonLink() {
    const elements = document.getElementsByClassName('tnt-section-games');
    for (const element of elements) {
        element.target = '_blank';
    }
}
gamesButtonLink();
</script>

            </footer>
        

        <div id="site-copyright-container" class="container">
            <div id="tncms-region-footer-copyright" class="tncms-region "><div id="tncms-block-2554741" class="tncms-block"><div id="site-copyright" class="row">
    <section id="block-2554741"><div class="col-md-7"><small>&copy; Copyright 2022 <a href="/">MeridianStar.com</a>, 814 22nd Avenue Meridian, MS</small><small>&nbsp;| <a href="/site/terms.html">Terms of Use</a></small><small>&nbsp;| <a href="/site/privacy.html">Privacy Policy</a></small></div>
        <div class="col-md-5"><small>Powered by <a href="https://bloxcms.com" title="BLOX Content Management System" target="_blank" rel="noopener">BLOX Content Management System</a> from <a href="https://townnews.com/" title="TownNews.com BLOX Newspaper Content Management" target="_blank" rel="noopener">TownNews.com</a>.</small></div>
    </section>
</div></div></div>
        </div>
    </div>
    
    
        </div><!-- / offcanvas close  -->
    

    
    
    <!-- / site-container close -->
    </div>
    
    
    <script>
        window.__tnt = window.__tnt || {};
        __tnt.compatibility = __tnt.compatibility || {};

        __tnt.compatibility.status = '';
        __tnt.compatibility.check = function() {
            if (typeof __tnt.advertisements == 'undefined') {
                __tnt.compatibility.status = 'FAIL: object 0 undefined';
                return false;
            }
            return true;
        };
        __tnt.compatibility.notification = function() {
            if (!document.getElementById('notification-area')) {
                    var el = document.createElement('div');
                    el.id = 'notification-area';
                    document.querySelector('#asset-content .asset-body').appendChild(el);
                }
                __tnt.template(
                    document.getElementById('template-blox-message-incompatible'),
                    document.getElementById('notification-area'),
                    true,
                    [],
                    function(el) {
                        setTimeout(function() {
                            var message = document.getElementById('blox-message-incompatible');
                            var authStatusCls = (__tnt.user.authToken) ? 'logged-in' : 'not-logged-in';
                                Array.from(message.getElementsByClassName(authStatusCls)).forEach(function(el) {
                                    el.style.display = 'block';
                                });
                            
                            if (__tnt.user.services) {
                                message.parentNode.removeChild(message);
                            } else {
                                message.style.display = 'block';
                                }
                        }, 100);
                    }
                );
            };
        (function() {
            function compatibilityCheck() {
                if (!__tnt.compatibility.check()) {
                    __tnt.trackEvent({
                        'category':'subscription',
                        'action':'adblock',
                        'label':'adblock detected',
                        'value':'1'
                    });
                    __tnt.compatibility.notification();
                }
            }

            if (document.readyState != 'loading') {
                compatibilityCheck();
            } else {
                document.addEventListener('DOMContentLoaded', compatibilityCheck);
            }
        })();
    </script>
    <template id="template-blox-message-incompatible">
            </template>
    
    
    <script>
        jQuery(function() {
            if(typeof TNCMS.Tracking != 'undefined'){
                jQuery(TNCMS.Tracking.trackDeclarativeEvents);
            }dataLayer.push({'tncms.client.recent_five':__tnt.recentFive.add("78352ec9-bf29-5878-a3df-8593459d9946")});});
    </script>

    <script>
        __tnt.trackEvent = function(obj) {
            if (typeof obj === 'object') {
                    if (obj.category && obj.action) {
                        __tnt.googleEvent(obj);
                    } else if (obj.network && obj.socialAction) {
                        __tnt.googleSocial(obj);
                    } else if (obj.url) {
                        __tnt.googlePageView(obj);
                    }
                    if (typeof TNCMS.Tracking != 'undefined' && obj.metric) {
                        TNCMS.Tracking.addEvent({
                            app: obj.app,
                            metric: obj.metric,
                            id: obj.uuid
                        });
                    }
            }
        };

        if (__tnt.trackEventLater.length > 0) {
            __tnt.trackEventLater.forEach(function(obj) {
                __tnt.trackEvent(obj);
            });
        }

        Array.from(document.querySelectorAll('body [data-track]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                __tnt.trackEvent(JSON.parse(el.dataset.track));
            });
        });
        Array.from(document.querySelectorAll('body [data-tncms-track-event]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                __tnt.trackEvent(JSON.parse(el.dataset.tncmsTrackEvent));
            });
        });
        
        Array.from(document.querySelectorAll('body [data-tncms-track-dmp]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                var dmpData = el.dataset.tncmsTrackDmp;
                _cc6893.add('act', dmpData);_cc6893.bcp();
            });
        });
    
    </script>
    
    
<script>/*<![CDATA[*/ dataLayer.push({
            'tncms.asset.sections': ["news/local_news"],
            'tncms.asset.flags': ["centerpiece"],
            'tncms.asset.keywords': ["steakhouse", "steak", "food", "catering", "restaurant", "diamond jim's", "wrap", "salad bar", "fillet"]
        }); /*]]>*/</script>
<script>/*<![CDATA[*/ 
                __tnt.googleEvent = function(obj) {
                    dataLayer.push({
                        'event': 'gaTriggerEvent',
                        'gaEventCategory': obj.category,
                        'gaEventAction': obj.action,
                        'gaEventLabel': obj.label,
                        'gaEventValue': obj.value
                    });
                    dataLayer.push({
                        'event': 'tncms.event.trigger',
                             'tncms.event.trigger.category': obj.category,
                             'tncms.event.trigger.action': obj.action,
                             'tncms.event.trigger.label': obj.label, 
                             'tncms.event.trigger.value': obj.value
                    });
                }
                __tnt.googleSocial = function(obj) {
                    dataLayer.push({
                        'event': 'socialEvent',
                        'socialNetwork': obj.network,
                        'socialAction': obj.socialAction,
                        'socialTarget': obj.url
                    });
                    
                    dataLayer.push({
                        'event': 'tncms.event.social',
                            'tncms.event.social.network': obj.network,
                            'tncms.event.social.action': obj.socialAction,
                            'tncms.event.social.target': obj.url
                    });
                }
                __tnt.googlePageView = function(obj) {
                    var sURL = obj.url.replace(/^.*\/\/[^\/]+/, '');
                    dataLayer.push({
                        'event': 'VirtualPageview',
                        'virtualPageURL': sURL,
                        'virtualPageTitle': obj.title
                    });
                    dataLayer.push({
                        'event': 'tncms.event.virtual_pageview',
                            'tncms.event.virtual_pageview.url': sURL,
                            'tncms.event.virtual_pageview.title': obj.title
                    });
                } /*]]>*/</script>
<script src="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/asset-edit.60e8e67e04be1194326dcfbe7f00b8c3.js"></script>
<script>/*<![CDATA[*/ jQuery(document).ready(function($){
                                    $('#weather_zip_toggle_2554873').click(function(e){
                                        $('#weather-2554873 .zip-update-form').toggle('fast');
                                        return false; 
                                    });
                                }); /*]]>*/</script>
<script src="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/owl.carousel.50dc41fa734414148ce4b489fd904c5f.js"></script>
<script>/*<![CDATA[*/ document.addEventListener('DOMContentLoaded',function(){
                    if (document.readyState != 'complete') {
                        document.addEventListener('readystatechange', function(ev) {
                            carouselInit_78352ec9_bf29_5878_a3df_8593459d9946_photo_modal();
                        });
                    }  else {
                        carouselInit_78352ec9_bf29_5878_a3df_8593459d9946_photo_modal();
                    }
                });// Carousel initialization
            function carouselInit_78352ec9_bf29_5878_a3df_8593459d9946_photo_modal() {
                var gallery_ad_78352ec9_bf29_5878_a3df_8593459d9946_photo_modal = false;
                var gallery_changed_78352ec9_bf29_5878_a3df_8593459d9946_photo_modal = false;
                var sUrl =  window.location.href,
                        sUuid = sUrl.split("_").pop(),
                        sId = sUuid.substring(0, sUuid.indexOf('.')),
                        aInlineImages = document.querySelectorAll('.inline-image .image, .inline-image .expand');
                     for (i = 0; i < aInlineImages.length; ++i) {
                        var oImage = aInlineImages[i],
                            sInstance = oImage.getAttribute('data-instance'),
                            sTarget = oImage.getAttribute('data-target');
                        if (!oImage.classList.contains("tnt-asset-presentation-infographic")) {
                            if (sInstance != null && sTarget != null){
                                if (!sInstance.includes(sId)){
                                    oImage.setAttribute('data-instance', '#gallery-items-' + sId + '-photo-modal');
                                }
                                if (!sTarget.includes(sId)){
                                    oImage.setAttribute('data-target', '#photo-carousel-' + sId);
                                }
                            }
                        }
                     }
                $('#gallery-items-78352ec9-bf29-5878-a3df-8593459d9946-photo-modal').owlCarousel({
                    items: 1,
                    autoHeight: true,
                    lazyLoad: true,
                    loop: false,
                    navRewind: true,
                    responsiveRefreshRate: 500,
                    
                    
                    dots : false,
                    
                    onTranslated:function(){
                        
                        
                        
                            __tnt.trackEvent($('#gallery-items-78352ec9-bf29-5878-a3df-8593459d9946-photo-modal .photo-container').eq(this._current).data('track-object'));
                        

                        
                        

                        

                    }
                });
                
                var owl = $('#gallery-items-78352ec9-bf29-5878-a3df-8593459d9946-photo-modal');
                owl.on('changed.owl.carousel', function(event) {if( !$('#gallery-items-78352ec9-bf29-5878-a3df-8593459d9946-photo-modal .photo-container').eq(event.item.index).hasClass('engagement-stage') ){
                            setTimeout(function(){
                                $("#gallery-items-78352ec9-bf29-5878-a3df-8593459d9946-photo-modal .owl-stage-outer").height( $('#carousel-78352ec9-bf29-5878-a3df-8593459d9946-photo-modal .owl-item.active').height() );
                            }, 300);
                        }
                    
                    
                    

                    
                        var currItem = $('#gallery-items-78352ec9-bf29-5878-a3df-8593459d9946-photo-modal .photo-container').eq(event.item.index).data('count');
                        if(currItem){
                            $('#carousel-78352ec9-bf29-5878-a3df-8593459d9946-photo-modal .current-count').html(currItem);
                        }
                        $('.modal.in, #carousel-78352ec9-bf29-5878-a3df-8593459d9946-photo-modal .item').removeClass('hover');
                    
                    
                });
                
                var photo_carousel_78352ec9_bf29_5878_a3df_8593459d9946_photo_modal = $('#gallery-items-78352ec9-bf29-5878-a3df-8593459d9946-photo-modal').data('owlCarousel');
                $('#carousel-78352ec9-bf29-5878-a3df-8593459d9946-photo-modal .photo-carousel-control.left').on(__tnt.client.clickEvent, function(e){
                    photo_carousel_78352ec9_bf29_5878_a3df_8593459d9946_photo_modal.prev();
                });
                $('#carousel-78352ec9-bf29-5878-a3df-8593459d9946-photo-modal .photo-carousel-control.right').on(__tnt.client.clickEvent, function(e){
                    photo_carousel_78352ec9_bf29_5878_a3df_8593459d9946_photo_modal.next();
                });
            } /*]]>*/</script>
<script>/*<![CDATA[*/ 
                // open photo modal
                jQuery(document).ready(function($){
                    $('[data-photo-target]').on('click', function(e){
                        e.preventDefault();
                        var item_target = $(this).data('target');
                        // get item index
                        var item_index = $(item_target +' '+$(this).data('photo-target')).parent().index();
                        // get current instance of carousel
                        var carousel_instance = $(this).data('instance');
                        var carousel_instance_data = $(carousel_instance).data('owlCarousel');
                        // fix non explict widths at viewports less than 900.
                        if(carousel_instance_data.width() < 320 & carousel_instance_data.viewport() < 900){
                            carousel_instance_data.onThrottledResize();
                        }
                        // load item from index
                        carousel_instance_data.to(item_index, 100, true);
                        // open modal
                        $(item_target).modal({'show':true});
                        __tnt.trackEvent({'category':'tnt-lightbox','action':'carousel-open', 'label':'article', 'value':'1'});
                        return false;
                    });
                    $('.photo-carousel-caption-toggle').on(__tnt.client.clickEvent, function(e){
                        var item_instance = $(this).data('instance');
                        $(item_instance +' .photo-carousel-caption-toggle').find('[data-fa-i2svg]').attr('data-icon', $(item_instance +' .photo-carousel-caption-toggle').find('[data-fa-i2svg]').attr('data-icon') == 'minus-circle' ? 'plus-circle' : 'minus-circle');
                    });
                }); /*]]>*/</script>
<script src="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/shared-content/art/tncms/templates/libraries/flex/components/asset/resources/scripts/tnt.reactions.496ef4077c989f2b546ccbd9a5d4e1f9.js"></script>
<script>/*<![CDATA[*/ 
                        function dmpReactionData(){
                            var sReactionData = document.getElementById('hidden-type').value,
                                sReactionKeywords = "'Engage:Steakhouse','Engage:Steak','Engage:Food','Engage:Catering','Engage:Restaurant','Engage:Diamond Jim\'s','Engage:Wrap','Engage:Salad Bar','Engage:Fillet'";_cc6893.add('act', sReactionData, sReactionKeywords);_cc6893.bcp();} /*]]>*/</script>
<script src="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/sticky-kit.136ae7f2f818eb47f6ccd0348c560674.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.regions.b44801b45845a81b995eeaad12f4f276.js"></script>
<script>/*<![CDATA[*/ (function() {
                    window.addEventListener('load', function() {
                        __tnt.regions.stickySide.init(document.getElementById('sticky-right-rail'), document.getElementById('sticky-right-rail-spacer'), 'siderail', '.sticky-parent');
                    });
                })(); /*]]>*/</script>
<script>/*<![CDATA[*/ window.addEventListener('DOMContentLoaded', function() {
                (function (callback) { var oScript; var oStorage; try { oStorage = JSON.parse(sessionStorage.getItem('tncms.dmp.audiences')); if (!oStorage || !oStorage.audiences || !oStorage.expired) { throw "Not in session storage"; } if (oStorage.expired < new Date().getTime()) { sessionStorage.removeItem('tncms.dmp.audiences'); throw "Cache is expired"; } callback(oStorage.audiences); } catch(oException) { if (!window.tncms_siteaud) { window.tncms_siteaud = null; } oScript = document.createElement('script'); oScript.onerror = function() { callback([]); }; oScript.onload = function() { try { var oResult = { audiences:[], expired: new Date().getTime() + 86400000 }; if (!window.tncms_siteaud) { return; } for(var nIdx = 0; nIdx < window.tncms_siteaud.Profile.Audiences.Audience.length; nIdx++) { var sAbbr = window.tncms_siteaud.Profile.Audiences.Audience[nIdx].abbr; oResult.audiences[oResult.audiences.length] = sAbbr; } oResult.audiences.sort(); sessionStorage.setItem('tncms.dmp.audiences', JSON.stringify(oResult)); } catch(oException) { if (console && console.warn) { console.warn('Failed to add behaviors to session storage'); } } callback(oResult.audiences); }; oScript.setAttribute('async', true); oScript.setAttribute('src', '//ad.crwdcntrl.net/5/c=6880/pe=y/var=tncms_siteaud'); var aHead = document.getElementsByTagName("head"); if (aHead && aHead[0]) { if (TNCMS && TNCMS.Tracking) { var oTracker = TNCMS.Tracking.createBucket({ 'app': 'tncms-dmp', 'metric': 'audience-extraction', 'data': { name: 'client', value: 6880 } }); oTracker.addEvent(new Date().getTime()); } aHead[0].appendChild(oScript); } } })(__tnt.dmp.audienceExtracted);
            }); /*]]>*/</script>
<script src="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/shared-content/art/tncms/templates/libraries/flex/components/block/resources/scripts/dmp.reactive.4682ad7e67deb14b5d5580c46c962432.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/meridianstar.com/shared-content/art/tncms/templates/libraries/flex/components/block/resources/scripts/promo_popup.fe40d77fce691e6ed54cb520a782a693.js"></script>
<script>/*<![CDATA[*/ 
            if (window.location.hash){
                var hashSet = ['tncms_source','utm_source','utm_campaign','utm_medium','utm_content','utm_term'],
                    urlHash = window.location.hash.replace('#','').split('&');
                for (var i = 0; i < urlHash.length; i++) {
                    var data = urlHash[i].split('='),
                        param = data[0].replace('-','_');
                    if (hashSet.indexOf(param) != -1){
                        var dmpData = param + ': ' + data[1];
                        _cc6893.add('act', dmpData);_cc6893.bcp();
                    }
                }
            }
         /*]]>*/</script></body>
</html>